FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Never before seen error???
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Never before seen error??? [message #31794] Thu, 18 May 2006 11:59 Go to next message
chickenout is currently offline  chickenout   United States
Messages: 55
Registered: February 2005
Location: Philadelphia
Karma: 0
Member
add to buddy list
ignore all messages by this user
Hey, I recently installed 2.7.4

I am all of the sudden getting this error?

Any info would be greatly appreciated.
Thanks

Warning: main(): open_basedir restriction in effect. File(/274_FUDforum/include/core.inc) is not within the allowed path(s): (/hsphere/local/home2/chickeno:/usr/local/lib/php:/tmp:/var/tmp) in /hsphere/............t.com/274_forum/GLOBALS.php on line 85

Warning: main(/274_FUDforum/include/core.inc): failed to open stream: Operation not permitted in /hsphere/............t.com/274_forum/GLOBALS.php on line 85

Warning: main(): open_basedir restriction in effect. File(/274_FUDforum/include/core.inc) is not within the allowed path(s): (/hsphere/local/home2/chickeno:/usr/local/lib/php:/tmp:/var/tmp) in /hsphere/............t.com/274_forum/GLOBALS.php on line 85

Warning: main(/274_FUDforum/include/core.inc): failed to open stream: Operation not permitted in /hsphere/............t.com/274_forum/GLOBALS.php on line 85

Fatal error: main(): Failed opening required '/274_FUDforum/include/core.inc' (include_path='.:/usr/local/lib/php') in /hsphere/............t.com/274_forum/GLOBALS.php on line 85

[Updated on: Thu, 18 May 2006 12:00]

Report message to a moderator

Re: Never before seen error??? [message #31799 is a reply to message #31794] Thu, 18 May 2006 16:25 Go to previous messageGo to next message
chickenout is currently offline  chickenout   United States
Messages: 55
Registered: February 2005
Location: Philadelphia
Karma: 0
Member
add to buddy list
ignore all messages by this user
Ok, I guess there were some permission issues with some of my files, but now I am getting these errors:

Warning: Cannot modify header information - headers already sent by (output started at ...../274_forum/GLOBALS.php:88) in ....../274_forum/index.php on line 946

Warning: Cannot modify header information - headers already sent by (output started at ....../274_forum/GLOBALS.php:88) in ....../274_forum/index.php on line 308

Warning: main(): open_basedir restriction in effect. File(/274_forum/theme/default/index.php) is not within the allowed path(s): (/hsphere/local/home2/chickeno:/usr/local/lib/php:/tmp:/var/tmp) in ..../274_forum/index.php on line 1191

Warning: main(/274_forum/theme/default/index.php): failed to open stream: Operation not permitted in ..../274_forum/index.php on line 1191

Warning: main(): open_basedir restriction in effect. File(/274_forum/theme/default/index.php) is not within the allowed path(s): (/hsphere/local/home2/chickeno:/usr/local/lib/php:/tmp:/var/tmp) in ....../274_forum/index.php on line 1191

Warning: main(/274_forum/theme/default/index.php): failed to open stream: Operation not permitted in ..../274_forum/index.php on line 1191

Fatal error: main(): Failed opening required '/274_forum/theme/default/index.php' (include_path='.:/usr/local/lib/php') in ...../274_forum/index.php on line 1191

[Updated on: Thu, 18 May 2006 16:25]

Report message to a moderator

Re: Never before seen error??? [message #31803 is a reply to message #31799] Thu, 18 May 2006 22:57 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The issue is that the forum tries to open a file outside the open_basedir and PHP is refusing to do so.

FUDforum Core Developer
Re: Never before seen error??? [message #31807 is a reply to message #31794] Thu, 18 May 2006 23:42 Go to previous messageGo to next message
chickenout is currently offline  chickenout   United States
Messages: 55
Registered: February 2005
Location: Philadelphia
Karma: 0
Member
add to buddy list
ignore all messages by this user
How can I fix that?

Which file?
Re: Never before seen error??? [message #31811 is a reply to message #31807] Fri, 19 May 2006 10:05 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
This is a configuration setting of your PHP, it can usually be found inside your php.ini file or in your virtual host config in Apache config file.

FUDforum Core Developer
Re: Never before seen error??? [message #31818 is a reply to message #31794] Fri, 19 May 2006 13:02 Go to previous messageGo to next message
chickenout is currently offline  chickenout   United States
Messages: 55
Registered: February 2005
Location: Philadelphia
Karma: 0
Member
add to buddy list
ignore all messages by this user
Ok, I've been working with the tech support of my hosts and have the forum up and running at least for the general user, but I am still getting some errors on the adm side.
For instance when doing consistency checker, I get messages like these throughout the process:
Warning: fopen(......../new_FUDforum/include/GLOBALS.php): failed to open stream: Permission denied in ......../new_FUDforum/include/glob.inc on line 103

Warning: fwrite(): supplied argument is not a valid stream resource in ........./new_FUDforum/include/glob.inc on line 104

Warning: fclose(): supplied argument is not a valid stream resource in ........./new_FUDforum/include/glob.inc on line 105


And

Warning: fopen(...../new_FUDforum/tmp/icon _cache): failed to open stream: Permission denied in ......../new_FUDforum/include/msg_icon_cache.inc on line 20

Warning: fwrite(): supplied argument is not a valid stream resource in ....../new_FUDforum/include/msg_icon_cache.inc on line 21

Warning: fclose(): supplied argument is not a valid stream resource in ......./new_FUDforum/include/msg_icon_cache.inc on line 22

Warning: rename(...../new_FUDforum/tmp/icon_cache,/hsphere/local/home2/chickeno/thec hickenout.com/new_FUDforum/cache/icon_cache): No such file or directory in ....../new_FUDforum/include/msg_icon_cache.inc on line 27



What does it mean and how can I fix it?
Thanks

[Updated on: Fri, 19 May 2006 13:14]

Report message to a moderator

Re: Never before seen error??? [message #31819 is a reply to message #31794] Fri, 19 May 2006 13:12 Go to previous messageGo to next message
chickenout is currently offline  chickenout   United States
Messages: 55
Registered: February 2005
Location: Philadelphia
Karma: 0
Member
add to buddy list
ignore all messages by this user
And if I try to upload smileys, I get these messages:
Warning: fopen(..../new_FUDforum/tmp/ps_cache): failed to open stream: Permission denied in ..../new_FUDforum/include/sml_rcache.inc on line 29

Warning: fwrite(): supplied argument is not a valid stream resource in ..../new_FUDforum/include/sml_rcache.inc on line 30

Warning: fclose(): supplied argument is not a valid stream resource in ..../new_FUDforum/include/sml_rcache.inc on line 31

Warning: rename(..../new_FUDforum/tmp/ps_cache,/hsphere/local/home2/chickeno/thechic kenout.com/new_FUDforum/cache/ps_cache): No such file or directory in ..../new_FUDforum/include/sml_rcache.inc on line 36

Warning: fopen(..../new_FUDforum/tmp/sp_cache): failed to open stream: Permission denied in ..../new_FUDforum/include/sml_rcache.inc on line 38

Warning: fwrite(): supplied argument is not a valid stream resource in ..../new_FUDforum/include/sml_rcache.inc on line 39

Warning: fclose(): supplied argument is not a valid stream resource in ..../new_FUDforum/include/sml_rcache.inc on line 40

Warning: rename(..../new_FUDforum/tmp/sp_cache,/hsphere/local/home2/chickeno/thechic kenout.com/new_FUDforum/cache/sp_cache): No such file or directory in ..../new_FUDforum/include/sml_rcache.inc on line 45




But it still uploads the smiley??

[Updated on: Fri, 19 May 2006 13:14]

Report message to a moderator

Re: Never before seen error??? [message #31823 is a reply to message #31819] Fri, 19 May 2006 13:56 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You want to make sure that the
..../new_FUDforum/tmp directory and the files in it are writable by the webserver user.


FUDforum Core Developer
Re: Never before seen error??? [message #31825 is a reply to message #31794] Fri, 19 May 2006 13:59 Go to previous messageGo to next message
chickenout is currently offline  chickenout   United States
Messages: 55
Registered: February 2005
Location: Philadelphia
Karma: 0
Member
add to buddy list
ignore all messages by this user
I changed it to 777, but there aren't any files in it??
Re: Never before seen error??? [message #31827 is a reply to message #31825] Fri, 19 May 2006 14:00 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The reason there are none is because previous attempts to create files in there have failed.

FUDforum Core Developer
Re: Never before seen error??? [message #31828 is a reply to message #31794] Fri, 19 May 2006 14:15 Go to previous messageGo to next message
chickenout is currently offline  chickenout   United States
Messages: 55
Registered: February 2005
Location: Philadelphia
Karma: 0
Member
add to buddy list
ignore all messages by this user
OK, cool, that seemed to help tremendously. Thank you very much.

New problem. In the admin panel, when trying to change the avatar approval to "no" and clcik set I get this error...same thing?

Warning: fopen(....../new_FUDforum/include/GLOBALS.php): failed to open stream: Permission denied in .....new_FUDforum/include/glob.inc on line 103

Warning: fwrite(): supplied argument is not a valid stream resource in ....../new_FUDforum/include/glob.inc on line 104

Warning: fclose(): supplied argument is not a valid stream resource in ......./new_FUDforum/include/glob.inc on line 105
Re: Never before seen error??? [message #31829 is a reply to message #31828] Fri, 19 May 2006 14:38 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
All those errors are permissions issues, you need to make sure that the webserver has write access to files identified in the error messages.

FUDforum Core Developer
Re: Never before seen error??? [message #31830 is a reply to message #31794] Fri, 19 May 2006 14:52 Go to previous messageGo to next message
chickenout is currently offline  chickenout   United States
Messages: 55
Registered: February 2005
Location: Philadelphia
Karma: 0
Member
add to buddy list
ignore all messages by this user
Thank you very much. Seemed to work.

One last question would be if someone uploads an image in a post, where is that stored?
Re: Never before seen error??? [message #31831 is a reply to message #31830] Fri, 19 May 2006 15:00 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
it is stored inside the files/ directory

FUDforum Core Developer
Re: Never before seen error??? [message #31832 is a reply to message #31794] Fri, 19 May 2006 15:03 Go to previous messageGo to next message
chickenout is currently offline  chickenout   United States
Messages: 55
Registered: February 2005
Location: Philadelphia
Karma: 0
Member
add to buddy list
ignore all messages by this user
OK, that is what I thought. How is it linked, because mine aren't showing up, but I believe it is there in the /files folder?

Re: Never before seen error??? [message #31833 is a reply to message #31794] Fri, 19 May 2006 15:14 Go to previous message
chickenout is currently offline  chickenout   United States
Messages: 55
Registered: February 2005
Location: Philadelphia
Karma: 0
Member
add to buddy list
ignore all messages by this user
Never mind. I figured it out. In the attach table, the path in the location field was incorrect.

thanks for the help.
Smile
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Early Installation Failure
Next Topic: Install a parallel forum?
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Oct 22 19:05:05 EDT 2017

Total time taken to generate the page: 0.00733 seconds