FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Upgrading from 1.6 -> 2.7.7 (How do I go about this?)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Upgrading from 1.6 -> 2.7.7 [message #157894] Tue, 28 October 2008 09:53 Go to next message
jjackson is currently offline  jjackson   United States
Messages: 6
Registered: October 2008
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Our site is running a very old version (1.6) of FUDForum, and we want to upgrade to the newest software without losing our data (users/posts/etc.) What would be the correct way to go about this?
Re: Upgrading from 1.6 -> 2.7.7 [message #157905 is a reply to message #157894] Thu, 13 November 2008 11:03 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3545
Registered: December 2004
Karma: 8
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I haven't tested it, but this should work:

Step 1: Download and run the FUDforum 1.0.X -> 1.2.8 Conversion Script

Step 2: Download and run the FUDforum 1.2.8 -> 2.0.2 Conversion Script

Step 3: Download the latest version and upgrade.

Best of luck!

Frank
Re: Upgrading from 1.6 -> 2.7.7 [message #157911 is a reply to message #157894] Mon, 24 November 2008 05:08 Go to previous messageGo to next message
jjackson is currently offline  jjackson   United States
Messages: 6
Registered: October 2008
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I downloaded the 1.0 -> 1.2.8 upgrade script, but when i run it i get this error.

Fatal error: Cannot redeclare gpc_fmt() (previously declared in update-v1.2.8.php:12) in update-v1.2.8.php on line 2239

I tried commenting out the first declaration of that function but then it complains about another function and so on.

This sounds like a php problem... Is this caused by a php setup issue? PHP version (5.0.3)? Have you seen this before? Any ideas?
Re: Upgrading from 1.6 -> 2.7.7 [message #157919 is a reply to message #157911] Wed, 03 December 2008 16:23 Go to previous messageGo to next message
jjackson is currently offline  jjackson   United States
Messages: 6
Registered: October 2008
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I figured out the problem. The code has data after the actual upgrade section (first 600ish lines). At then end of the upgrade part there is a call to exit() which pre php 5 would have stopped it from looking at the declarations below. But now it does so it was seeing the same functions declared below. This is easily fixed by cutting out that bottom part, putting it in a separate file and changing one line of the code to read in that new file for the data instead of the same file as the upgrade code.
Re: Upgrading from 1.6 -> 2.7.7 [message #157920 is a reply to message #157894] Wed, 03 December 2008 16:48 Go to previous message
jjackson is currently offline  jjackson   United States
Messages: 6
Registered: October 2008
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ok... new issue. We use pgsql not mysql for our FUDForum database. This is supported both in the old (1.6) version and the new 2.7.7 version.

But... The 1.2.8->2.0.2 upgrade script.... only has mysql in it... and no mention of pgsql anywhere in the script. Why is this?
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Newsgroup imports fails with Missing Forum ID Parameter
Next Topic: vB 2.3 to FF
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Fri Aug 22 13:40:26 EDT 2014

Total time taken to generate the page: 0.00721 seconds