FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » FUDforum 3.0+ » Can we drop PHP4 support?
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Can we drop PHP4 support? [message #159063] Fri, 01 May 2009 10:32 Go to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user

Which version of PHP do you use?[ 15 votes ]
1.
2.
3.
 

FUDforum still supports both PHP4 and PHP5. However, doing so is holding our development back. If there is any good reason why we cannot make PHP 5.2 a minimum requirement, please let us know now.

This site has more info on the subject: http://gophp5.org/

Best regards.

Frank
Re: Can we drop PHP4 support? [message #159089 is a reply to message #159063] Sun, 03 May 2009 18:37 Go to previous messageGo to next message
WITCH is currently offline  WITCH   United States
Messages: 42
Registered: December 2006
Location: Illinois USA.
Karma: 0
Member
add to buddy list
ignore all messages by this user
From the article it appears that it is not an issue of "IF" but of "WHEN" you make PHP 5.2 the Minimum. Sounds like you basically have the option of progressing along with developments in technology or stagnating.

Of course that is from my perspective and I cannot even begin to fathom it from a developer's point of view.

Yet as a User 1st (administrator by necessity) what PHP version is used is less important (at least for now) for FUDforums Development/Popularity than usability.

If I understand correctly; making PHP 5.2 a minimum requirement for FUDforum would only affect future releases of the software, so all older versions would continue to run as long as their Host supports PHP4 and PHP5.

What is less clear is if such a change would affect restoring backups such as might be encountered in changing hosts/domains/upgrading to a newer version. My gut instincts say the only issue for the average user/admin would be ensuring their Hosts support the new minimum requirement and moving if not.




I am new to this so explain things very, very carefully!
Re: Can we drop PHP4 support? [message #159093 is a reply to message #159089] Mon, 04 May 2009 01:43 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
The next release, FUDforum 2.8.1 will still support both PHP 4 and 5. However, if there are no serious objections, it will be the last release to support PHP4.

Best regards.

Frank
Re: Can we drop PHP4 support? [message #159103 is a reply to message #159093] Mon, 04 May 2009 10:50 Go to previous message
kerryg is currently offline  kerryg   Canada
Messages: 157
Registered: September 2008
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
As long as older versions of FUDForum were to remain available for that rare circumstance where someone can't upgrade their php, can't see any reason this would be a problem.

[Updated on: Mon, 04 May 2009 10:51]

Report message to a moderator

Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: LDAP Support?
Next Topic: Proposal to rename FUDcode to BBcode
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Thu Oct 19 03:22:51 EDT 2017

Total time taken to generate the page: 0.00680 seconds