FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » How To » FudForum theme and template edition - probleme to have stable css (getting errors or losing css when rebuild theme)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
FudForum theme and template edition - probleme to have stable css [message #159363] Mon, 25 May 2009 10:51 Go to next message
lf-gra is currently offline  lf-gra
Messages: 13
Registered: May 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi,

I'm not expert, so: please sorry if questions are stupids.

I'm trying to change forum.css,
I create a well working new forum.css,
then create a Theme,
copy all default theme generic files and add my personal css
then change headers.tmpl fo add favicon and metatags,
when coming back to forum I get favicon, but my css was lost.
Charged it once again, it works, but lost favicon.

Then I edit message templates, because a problem with traduction (volonteer traduce and format in iso-8891 , but needed utf-8), and I've make an error, a syntax error in /include/theme/mytheme/err.inc. Change it, working well, but lost the possibility of access by login for everybody.

Going back, install all files in backup to server,
work well, but lost css (even if in backup file it was the right css!)

The problem is that my css is lost everytime I go editing others templates like headers or footers or messages.
And if I rebuild theme I get back the syntaxe error I have produced in err.inc
How can I fix it?

Sorry if I'm not understable or clear enough.
Thank you very much for your attentiuon.
LF
Re: FudForum theme and template edition - probleme to have stable css [message #159364 is a reply to message #159363] Mon, 25 May 2009 11:28 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
You need to copy and edit the template file. The forum.css file is generated from forum.css.tmpl. For details, see http://cvs.prohost.org/index.php/Create_a_new_theme
Re: FudForum theme and template edition - probleme to have stable css [message #159365 is a reply to message #159363] Mon, 25 May 2009 11:36 Go to previous messageGo to next message
lf-gra is currently offline  lf-gra
Messages: 13
Registered: May 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi,
I've done all the step in the link you sent me,
reading this once again
i think that my problem is because I've not do that:
Quote:
Also, remove all sections ({SECTION:...}) that you haven't changed for your theme.

I've not do yet, because I'm note able to understand what it mean,
can you or someone , please, try to explain me more easily?
Thanks so much
Re: FudForum theme and template edition - probleme to have stable css [message #159366 is a reply to message #159365] Mon, 25 May 2009 11:44 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
You don't have to remove the unchanged sections. However, it's recommended because it prevents duplication and makes the new theme smaller and easier to maintain.

The use of sections is explained at http://fudforum.org/forum/index.php?t=msg&th=4222

Best regards.

Frank
Re: FudForum theme and template edition - probleme to have stable css [message #159389 is a reply to message #159366] Thu, 28 May 2009 17:33 Go to previous message
lf-gra is currently offline  lf-gra
Messages: 13
Registered: May 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Thank you for your help and for answering me!
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Forum Integration
Next Topic: Configuring Postfix to post to FUDforum
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Oct 17 20:23:03 EDT 2017

Total time taken to generate the page: 0.00747 seconds