FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Issues with Mass E-mail in Admin Control Panel
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Issues with Mass E-mail in Admin Control Panel [message #160744] Mon, 19 October 2009 16:34 Go to next message
JanRei is currently offline  JanRei   
Messages: 361
Registered: October 2005
Location: Germany
Karma: 0
Senior Member
Contributing Core Developer
Translator
add to buddy list
ignore all messages by this user
It seems that mails sent with "Mass E-mail" functionality in Admin Control Panel suffer from similar issues with special characters that were already fixed for post notifications. For me it looks like a separate smtp implementation is used here.

In a short test the subject and body were encoded as UTF-8, but Thunderbird didn't use UTF-8 for displaying the body. This resulted in a borked body.

Also, I think it should be checked whether the mails could actually be sent out. Even with disabled mail() function the mails are reported to be sent successfully.

Windows XP, PHP 5.3.0

[Updated on: Mon, 19 October 2009 16:44]

Report message to a moderator

Re: Issues with Mass E-mail in Admin Control Panel [message #160751 is a reply to message #160744] Wed, 21 October 2009 02:04 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3628
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Can you please prepare a patch for this?
Aw: Re: Issues with Mass E-mail in Admin Control Panel [message #162911 is a reply to message #160751] Sat, 28 August 2010 17:26 Go to previous messageGo to next message
JanRei is currently offline  JanRei   
Messages: 361
Registered: October 2005
Location: Germany
Karma: 0
Senior Member
Contributing Core Developer
Translator
add to buddy list
ignore all messages by this user
This is one of a few older things on my to-do list.

I have attached my first attempt to fix the mentioned problems. Mass mails should have proper headers now. I also tried to improve error handling in case a mail could not be sent.
Re: Aw: Re: Issues with Mass E-mail in Admin Control Panel [message #162913 is a reply to message #162911] Sun, 29 August 2010 03:29 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3628
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Looks good. Please commit.
Aw: Re: Aw: Re: Issues with Mass E-mail in Admin Control Panel [message #162918 is a reply to message #162913] Sun, 29 August 2010 05:33 Go to previous message
JanRei is currently offline  JanRei   
Messages: 361
Registered: October 2005
Location: Germany
Karma: 0
Senior Member
Contributing Core Developer
Translator
add to buddy list
ignore all messages by this user
Patch has been committed.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Wikilinks.plugin isn't working at all
Next Topic: Not sending out confirmation mails
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Dec 10 21:27:09 EST 2017

Total time taken to generate the page: 0.00809 seconds