FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » blank content part of admin screen on saving changes
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
blank content part of admin screen on saving changes [message #164554] Wed, 16 February 2011 15:42 Go to next message
Bradley is currently offline  Bradley
Messages: 41
Registered: February 2011
Karma: 0
Member
add to buddy list
ignore all messages by this user
when i try to change theme, add new categories, when i click update, the content part of the admin screen becomes white and nothing appears to change. there are no errors in the logs, so, what else could it be? it's rendered the forum unusable!
Re: blank content part of admin screen on saving changes [message #164555 is a reply to message #164554] Wed, 16 February 2011 16:32 Go to previous messageGo to next message
Bradley is currently offline  Bradley
Messages: 41
Registered: February 2011
Karma: 0
Member
add to buddy list
ignore all messages by this user
nginx server, fudforum 3 - downloaded today, can't find a version number in the docs but i'm guessing 3.0.2, php 5.3.3

i also find that trying to post points to url: /index.php?t=post which gives an nginx error page suggesting something in the script has gone wrong somewhere, yet again there's nothing in the logs. i'm completely baffled.

------
things are a little too funky for me, i'm downgrading to 3.0.1 which doesn't seem to have these problems!

[Updated on: Wed, 16 February 2011 17:38]

Report message to a moderator

Re: blank content part of admin screen on saving changes [message #164557 is a reply to message #164555] Wed, 16 February 2011 21:56 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
No errors in nginx's error.log file?

Also see "FUDforum shows a blank screen. What now?" at FAQ.
Re: blank content part of admin screen on saving changes [message #164565 is a reply to message #164557] Wed, 16 February 2011 22:45 Go to previous message
Bradley is currently offline  Bradley
Messages: 41
Registered: February 2011
Karma: 0
Member
add to buddy list
ignore all messages by this user
i went back and checked user.log and found a few interesting things. firstly, when installating 3.0.1 i learned that the db user needs lock table grant, i didn't see a message for that on the install.
however, i can't be totally sure, but around the time i was having problems with 3.0.2 i found a lot of this repeated:

PDO::__construct() [<a href='pdo.--construct'>pdo.--construct</a>]: SQLSTATE[HY000]: General error: PDO::ATTR_STATEMENT_CLASS cannot be used with persistent PDO instances in .../include/theme/default/db.inc on line 27

and also found this too:
General error: PDO::ATTR_STATEMENT_CLASS cannot be used with persistent PDO instances in /index.php on line 39

i guess it was me choosing to have persistant conns when i was using pdo-mysql

[Updated on: Wed, 16 February 2011 22:46]

Report message to a moderator

Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Some Bugs Found by Users
Next Topic: most users online can't be right
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Dec 16 02:10:48 EST 2017

Total time taken to generate the page: 0.00727 seconds