FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » pathinfo issues
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
pathinfo issues [message #16466] Fri, 30 January 2004 16:19 Go to next message
Olliver   Germany
Messages: 443
Registered: March 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
There are some path info issues:

If you use private messaging and attempt to switch to the admin control panel it will fail because the uri8 will be added to the pathinfo string. So we never get to the destination until we choose to get to the index site (and kill the string on that occasion)

Another one:
If you edit a topic and then return to it the icons are broken. Apparently for the same reason. As above going to the index page and getting this way back to the topic solves the problem.

Still version 2.6.0

Olliver
Re: pathinfo issues [message #16467 is a reply to message #16466] Fri, 30 January 2004 16:21 Go to previous messageGo to next message
Olliver   Germany
Messages: 443
Registered: March 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Small addition:
For those who haven't had the pleasure yet, using relative paths in combination with pathinfo doesn't work like expected. Such links will get appended to the pathinfo string and you'll end up reloading the same page over and over and can watch the appended string endlessly growing.

Olliver
Re: pathinfo issues [message #16468 is a reply to message #16466] Fri, 30 January 2004 16:25 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Quote:


If you use private messaging and attempt to switch to the admin control panel it will fail because the uri8 will be added to the pathinfo string. So we never get to the destination until we choose to get to the index site (and kill the string on that occasion)



Appears to be fixed in CVS.

Quote:


If you edit a topic and then return to it the icons are broken. Apparently for the same reason. As above going to the index page and getting this way back to the topic solves the problem.



Same thing, 'seems' work properly with latest CVS.

The CVS had a major revision of how the URLs are generated, so it is more then likely that most remaining PATH_INFO issues were resolved by that change.


FUDforum Core Developer
Re: pathinfo issues [message #16469 is a reply to message #16467] Fri, 30 January 2004 16:27 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Olliver wrote on Fri, 30 January 2004 16:21

Small addition:
For those who haven't had the pleasure yet, using relative paths in combination with pathinfo doesn't work like expected. Such links will get appended to the pathinfo string and you'll end up reloading the same page over and over and can watch the appended string endlessly growing.

Olliver



True, BUT FUDforum actually uses (I believe 2.6.0 had that before) <base href="">, which sets a base URL. Meaning that any relative paths actually get appended to that URL rather then whatever you got in your URL bar.


FUDforum Core Developer
Re: pathinfo issues [message #16472 is a reply to message #16468] Fri, 30 January 2004 16:50 Go to previous message
Olliver   Germany
Messages: 443
Registered: March 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Ilia wrote on Fri, 30 January 2004 22:25

The CVS had a major revision of how the URLs are generated, so it is more then likely that most remaining PATH_INFO issues were resolved by that change.


This is good news. Thanks for your efforts.

Olliver
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: File Manager bug
Next Topic: Bug with time zone. Bug with forum statistics query
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Mon Oct 23 07:48:26 EDT 2017

Total time taken to generate the page: 0.00660 seconds