FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Install FUDforum on your PC in under 15 minutes  () 1 Vote
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Install FUDforum on your PC in under 15 minutes [message #158106] Sat, 31 January 2009 06:15 Go to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
It is extremely easy to install FUDforum on any Windows or Linux PC. This quick installation procedure can be followed to get FUDforum up-and-running for testing or development purposes.

1. Install Apache, MySQL and PHP on your system. If it's not already installed, we recommend XAMPP (just the basic package) or BitNami's LAMPstack. Both provide a unified installation with all the required components that you can simply download, extract and start.

2. Create a database for FUDforum by navigating to http://127.0.0.1/ (may be on a different port, like :8080), click on "phpMyAdmin", and "Databases". Enter your database name (say, fuddb) and click "Create".

3. Download and extract FUDform's installer and put it in the 'htdocs' directory (c:\xampp\htdocs or /opt/lamp/htdocs).

5. Start the installation wizard by navigating to http://127.0.0.1/FUDforum2/install.php

6. Select the installation directories (or just accept the defaults) and click "Next". Enter database details (user=root; DBname=fuddb; DBPassword if required or leave empty; leave the rest empty) and click "Next" until FUDforum is completely installed.

7. Stop the clock and let us know how long it took you to get it running.

Enjoy!

Frank
Re: Install FUDforum on your PC in under 15 minutes [message #159440 is a reply to message #158106] Wed, 03 June 2009 08:52 Go to previous messageGo to next message
jwheeler is currently offline  jwheeler
Messages: 2
Registered: June 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Thank you for these easy instructions!

When I get to the step of navigating to the 127.0.0.1/install.php page, I get an "object not found" error message. What am I doing wrong??

[Updated on: Wed, 03 June 2009 08:53]

Report message to a moderator

Re: Install FUDforum on your PC in under 15 minutes [message #159441 is a reply to message #159440] Wed, 03 June 2009 09:04 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Did you copy install.php to the "htdocs" directory? If it's in a sub-folder like htdocs/FUDforum2 you need to change the url to 127.0.0.1/FUDforum2/install.php
Re: Install FUDforum on your PC in under 15 minutes [message #159444 is a reply to message #159441] Wed, 03 June 2009 09:21 Go to previous messageGo to next message
jwheeler is currently offline  jwheeler
Messages: 2
Registered: June 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
That was the problem! Everything worked perfectly. Took me a little over 15 minutes, but that was only due to my ignorance. Smile Thank you!!
Re: Install FUDforum on your PC in under 15 minutes [message #159445 is a reply to message #159444] Wed, 03 June 2009 10:08 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
That is great news. Welcome to the club!
Re: Install FUDforum on your PC in under 15 minutes [message #161574 is a reply to message #159445] Mon, 11 January 2010 00:03 Go to previous messageGo to next message
Hilary is currently offline  Hilary   United Kingdom
Messages: 9
Registered: February 2008
Location: Manchester, Los Angeles
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
12 minutes under vista ... Linux, well ....

I am what I am
Re: Install FUDforum on your PC in under 15 minutes [message #161575 is a reply to message #161574] Mon, 11 January 2010 00:22 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Well done! Twelve minutes is an excellent result!

Please let us know if you are having problems installing it on Linux.
Re: Install FUDforum on your PC in under 15 minutes [message #161585 is a reply to message #161575] Mon, 11 January 2010 23:24 Go to previous messageGo to next message
Hilary is currently offline  Hilary   United Kingdom
Messages: 9
Registered: February 2008
Location: Manchester, Los Angeles
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I now realise the installation of Fud was actually FudForum2Go. This works, but is on IExplorer, and SQLite. However, I'll keep trying.

I'll leave Linux for the moment, til I get Vista sorted.

Thanks, Hilary.


I am what I am
Re: Install FUDforum on your PC in under 15 minutes [message #161591 is a reply to message #161585] Tue, 12 January 2010 12:08 Go to previous messageGo to next message
Hilary is currently offline  Hilary   United Kingdom
Messages: 9
Registered: February 2008
Location: Manchester, Los Angeles
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
OK - I started again.

12 minutes in Vista, the full FUD 3 package, rather than the Fud2Go.

naudefj, thank you.

Hilary


I am what I am
Re: Install FUDforum on your PC in under 15 minutes [message #163418 is a reply to message #158106] Fri, 29 October 2010 00:27 Go to previous messageGo to next message
jbmoss is currently offline  jbmoss   United States
Messages: 1
Registered: October 2010
Location: N-Idaho Panhandle
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
OK, what I'm getting to the request for the reference to /127.0.0.1/ is 'invalid DSN'. Has the location been changed? Where do I go from here? Thanks for any help you can give in my being able to get started on this project.

~ jbm
Re: Install FUDforum on your PC in under 15 minutes [message #163486 is a reply to message #163418] Wed, 03 November 2010 13:11 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
jbmoss wrote:
OK, what I'm getting to the request for the reference to /127.0.0.1/ is 'invalid DSN'. Has the location been changed? Where do I go from here? Thanks for any help you can give in my being able to get started on this project.


As noted above, it may be on a different port depending on the stack you've installed (XAMPP or BitNami or ...?).

For example, the URL may be http://127.0.0.1:8080/
Re: Install FUDforum on your PC in under 15 minutes [message #163582 is a reply to message #158106] Wed, 10 November 2010 05:55 Go to previous messageGo to next message
nimbusgb is currently offline  nimbusgb
Messages: 8
Registered: November 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
10 minutes so far and when chosing the database I get
'pgsql' is not a valid database type or is not supported.


Fail!
Re: Install FUDforum on your PC in under 15 minutes [message #163591 is a reply to message #163582] Wed, 10 November 2010 10:05 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
nimbusgb wrote:
10 minutes so far and when choosing the database I get:
'pgsql' is not a valid database type or is not supported.


The instructions clearly states: "Install Apache, MySQL and PHP." So, why did you decide to rather go with PgSQL? Please follow the instructions.
Re: Install FUDforum on your PC in under 15 minutes [message #163593 is a reply to message #163591] Wed, 10 November 2010 11:25 Go to previous messageGo to next message
nimbusgb is currently offline  nimbusgb
Messages: 8
Registered: November 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Because FUDforum is Posgres compatible which is why we chose it!
Because I have a large installed and maintained postgres database and choose not to run a second database just for forum software.

Subsequently fixing my PHP installation resulted in the app installing fine. So perhaps the Instructions should read "Install Apache, PHP and either MySQL or PosgreSQL." Smile
Re: Install FUDforum on your PC in under 15 minutes [message #163753 is a reply to message #163593] Mon, 29 November 2010 12:20 Go to previous messageGo to next message
Ernesto is currently offline  Ernesto   Sweden
Messages: 413
Registered: August 2005
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
I didn't know pgsql was the same as postgresql

Re: Install FUDforum on your PC in under 15 minutes [message #163772 is a reply to message #163753] Tue, 30 November 2010 02:33 Go to previous messageGo to next message
Atomicrun is currently offline  Atomicrun   Sweden
Messages: 54
Registered: November 2010
Location: Lund
Karma: 0
Member
add to buddy list
ignore all messages by this user
Hi! No I don't think the 15 min is realistic. Be careful with the following:
Your Apache must be set up properly.
The PHP engine must be enabled and properly set up.
The mySQL database, or compatible equivalent, must work properly, and you also need the ID, password and database name in the database for the install. (These are typically the tasks of the server-owner.)

The FUDForum use a special trick with the table names, so it can be installed into the same database as some other application. (My server-owner charge by the database !)

The e-mail settings will also be needed.

Unpacking the FUDForum don't take many minutes. You then need to set up the basic structure of the forum, and that can take a while. An hour or so would be completely realistic.

Re: Install FUDforum on your PC in under 15 minutes [message #163855 is a reply to message #163772] Sun, 05 December 2010 10:07 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Atomicrun wrote:
Your Apache must be set up properly.
The PHP engine must be enabled and properly set up.
The mySQL database, or compatible equivalent, must work properly, and you also need the ID, password and database name in the database for the install. (These are typically the tasks of the server-owner.)


I don't think you've read the first message of this topic.
The steps you've listed is a quick under 1 minute install with XAMPP or LAMPstack (first step of the procedure).
Re: Install FUDforum on your PC in under 15 minutes [message #164699 is a reply to message #163855] Wed, 02 March 2011 00:08 Go to previous messageGo to next message
liuxibin is currently offline  liuxibin   China
Messages: 1
Registered: February 2011
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I am a china user ,I selected Language chinese,however the Current Time is 'Wed Mar 2 09:31:05 Öйú±ê׼ʱ¼ä 2011

' and Last message is '¬P´Á¤T, 02 ¤T¤ë 2011',would you like help me,thank you!
Re: Install FUDforum on your PC in under 15 minutes [message #164709 is a reply to message #164699] Wed, 02 March 2011 05:59 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
liuxibin wrote:
I am a china user ,I selected Language chinese,however the Current Time is 'Wed Mar 2 09:31:05 Öйú±ê׼ʱ¼ä 2011

' and Last message is '¬P´Á¤T, 02 ¤T¤ë 2011',would you like help me,thank you!


Check that you use a valid locale in the Theme Manager ACP.
Also ensure that the locale is installed on you system.
Re: Install FUDforum on your PC in under 15 minutes [message #165327 is a reply to message #164709] Thu, 26 May 2011 22:41 Go to previous messageGo to next message
zxy6532720 is currently offline  zxy6532720
Messages: 1
Registered: May 2011
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Thanks for this site very helpful.

polar lizard D
Re: Install FUDforum on your PC in under 15 minutes [message #165441 is a reply to message #165327] Sat, 18 June 2011 04:26 Go to previous messageGo to next message
Ransaap is currently offline  Ransaap   Netherlands
Messages: 1
Registered: June 2011
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi all,
I'm trying this for the first time, and I wonder if the status is allright since 2 components aren't activated. Will that be a problem or is it normal?
Greets,
Paul

Component
Status
Hint
MySQL database ACTIVATED
PHP ACTIVATED
HTTPS (SSL) ACTIVATED
Common Gateway Interface (CGI) ACTIVATED
Server Side Includes (SSI) ACTIVATED
SMTP Service DEACTIVATED
FTP Service ACTIVATED
Tomcat Service DEACTIVATED
Re: Install FUDforum on your PC in under 15 minutes [message #165444 is a reply to message #165441] Sat, 18 June 2011 04:42 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Ransaap wrote:
I'm trying this for the first time, and I wonder if the status is allright since 2 components aren't activated. Will that be a problem or is it normal?


It looks normal. If you use XAMPP or BitNami's LAMPstack, the default settings are sufficient. You don't need to enable anything extra.
Re: Install FUDforum on your PC in under 15 minutes [message #166413 is a reply to message #158106] Thu, 01 December 2011 14:44 Go to previous messageGo to next message
theupsetter is currently offline  theupsetter   United States
Messages: 4
Registered: December 2011
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I enter 127.0.0.1 into IE8 and then I just get "It Works!"

I had FudForum2Go installed, but I made a mistake and had to start over. I deleted the folder it was in, but maybe there's something still lingering?
Re: Install FUDforum on your PC in under 15 minutes [message #166414 is a reply to message #158106] Thu, 01 December 2011 16:04 Go to previous messageGo to next message
theupsetter is currently offline  theupsetter   United States
Messages: 4
Registered: December 2011
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I had previously installed FUDforum2Go, but I made a change and didn't know how to reverse it so I decided to start over with FUDforum 3.0.3. I deleted the FUDforum2Go folder and then started the install process for FUDforum. I installed XAMPP with no problems. I get to the point where you go to 127.0.0.1, but it always comes up with "It Works!" It seems as though something is still lingering from the previous installation. Any ideas?

(Sorry for the semi-duplicate question. I posted the other over an hour ago and never saw it appear in here)

[Updated on: Thu, 01 December 2011 16:07]

Report message to a moderator

icon14.gif  Re: Install FUDforum on your PC in under 15 minutes [message #166855 is a reply to message #158106] Thu, 08 March 2012 07:24 Go to previous messageGo to next message
hira2 is currently offline  hira2
Messages: 1
Registered: March 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
When I get to the step of navigating to the 127.0.0.1/install.php page, I get an "object not found" error message. What am I doing wrong??

hira 2
Re: Install FUDforum on your PC in under 15 minutes [message #187205 is a reply to message #158106] Sat, 01 October 2016 03:05 Go to previous message
xubuntu6969 is currently offline  xubuntu6969   Greece
Messages: 6
Registered: September 2016
Location: athens
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

I just lost a day trying to transfer a FUD forum.

The database is in FYI/FYD format.

I moved all the files in the new server and edited globals.php file.

Now what ?

I read that the database should be imported through the admin panel but I assume the admin panel cannot load while the database is totally empty.

One option is to ask the previous owner to provide the database in *.SQL format but only god knows if it will be compatible with the new server's mysql version.

What else can i do ?
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: FUDforum2Go Appliance for Windows
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Wed Jun 20 05:35:37 EDT 2018

Total time taken to generate the page: 0.01151 seconds