FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Bug with forum/topic subscription?
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Bug with forum/topic subscription? [message #166053] Thu, 08 September 2011 14:59 Go to next message
wsaxon is currently offline  wsaxon   United States
Messages: 3
Registered: March 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
We've seen this problem since at least 3.0.1, although we are using 3.0.3RC2 right now.

We have users who are subscribed to forums only - not topics - but they get notices for both new topics and new posts in existing topics. When viewing a topic, they see the 'unsubscribe' link even though they are not subscribed to the topic. Clicking the unsubscribe link does not 'do' anything, i.e. these users continue to receive notices for new replies in the topic.

I thought subscribing to a forum generated notifications for new topics only, and that if I wanted notices for new replies in an existing topic that I had to subscribe to each topic individually. Is this incorrect? Is there a configuration setting that needs to be set to enable this behavior?
Re: Bug with forum/topic subscription? [message #166142 is a reply to message #166053] Wed, 28 September 2011 10:25 Go to previous messageGo to next message
mikem401 is currently offline  mikem401   United Kingdom
Messages: 4
Registered: September 2011
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

There is a setting in the admin->Config->Global Settings manager

Under the Email Settings section check the following entry:

All Message Forum Notification:
If enabled, subscribers to a forum will receive notifications about every new message in the forum, rather then just new topics in the forum.
Re: Bug with forum/topic subscription? [message #166190 is a reply to message #166053] Mon, 10 October 2011 09:59 Go to previous messageGo to next message
tw_nick   United States
Messages: 57
Registered: October 2010
Location: Dallas, TX
Karma: 0
Member
add to buddy list
ignore all messages by this user

We're running 3.0.2 and have a problem with subscriptions, too. Ours, however, is that users subscribe to their threads but then don't get e-mail notifications when replies are added. I know that e-mail is working from the site, however, because Moderators DO get alerts when new posts are added to the forum(s) for which they are responsible. Is this an issue with 3.0.2, because this problem didn't exist before.

Thanks!!
Re: Bug with forum/topic subscription? [message #166192 is a reply to message #166190] Mon, 10 October 2011 10:45 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3550
Registered: December 2004
Karma: 10
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Difficult to say. We've all moved on to FUDforum 3.0.3.
Re: Bug with forum/topic subscription? [message #166204 is a reply to message #166190] Mon, 10 October 2011 16:26 Go to previous message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
Just a hunch... but Check:

Quote:
Smart Notification:
Enable 'smart' e-mail notification mechanism that would only notify users if they read previous notification. This prevents filling up of the user's mailbox with notifications if they are not reading them.



"I'm a Witcher, I solve human problems; not always using a sword!"
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: errors upgrading
Next Topic: Long messages truncated
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Sep 02 00:15:20 EDT 2014

Total time taken to generate the page: 0.00748 seconds