FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » issue with deleted attachmens
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
issue with deleted attachmens [message #16882] Thu, 26 February 2004 02:56 Go to next message
Olliver   Germany
Messages: 443
Registered: March 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
It seems Fud has sort of a zombie feature regarding deleted attachments. Let me explain:

Assumed you have a number of attachments and some of them got revised with a more recent version leaving older ones obsolete. I usually delete such older ones. After the forum upgrade last night (my time) each of the deleted attachments had arisen from the dead and happily offered their links when in fact they should have been gone for good ( = deleted) Confused

To me this behavior seems like a bug. Attachments once deleted should stay this way after an upgrade. I don't feel like deleting old attachments over and over again with each upgrade.

Olliver
Re: issue with deleted attachmens [message #16888 is a reply to message #16882] Thu, 26 February 2004 10:04 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Let me see if I understand the steps needed to replicate the bug (correct me if I wrong).

1) Create a new message with 1 or more attachments
2) Edit existing message, while editing remove 1 attachment and replace it with another.
3) Run consistency checker.

At this point the deleted attachment re-appears (replacing??) the new one or in addition to the new one?


FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: You've followed an invalid link, please notify the...
Next Topic: search dialog hangs on support forum
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Dec 12 13:13:43 EST 2017

Total time taken to generate the page: 0.00693 seconds