FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Locking Forums in 3.0.5 makes perms 000
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Locking Forums in 3.0.5 makes perms 000 [message #183072] Mon, 07 October 2013 01:57 Go to next message
cpreston is currently offline  cpreston   United States
Messages: 160
Registered: June 2012
Location: Oceanside
Karma: 6
Senior Member
add to buddy list
ignore all messages by this user
I unlocked forums for the migration tool, but when I went to lock them afterwards, both /home/<user>/FUDforum and /home/<user>/public_html/forum end up getting NO permissions. (000). I make them 755 again, as required by my webserver, then did it again, and voila! 000 again.

still running php 5.3.27 from the migration (due to the problem I had w/the migration tool and 5.4.20).

Thoughts?
Re: Locking Forums in 3.0.5 makes perms 000 [message #183076 is a reply to message #183072] Mon, 07 October 2013 05:12 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Locking should change the permissions for files to 600 (rw-/---/---) and directories to 700 (rwx/---/---).
Unlocking will change them to 755 (rwx/r-x/r-x) and 644 (rw-/r--/r--).
The files must belong (chown) to the web server user for this to work.
Re: Locking Forums in 3.0.5 makes perms 000 [message #183080 is a reply to message #183076] Mon, 07 October 2013 11:02 Go to previous messageGo to next message
cpreston is currently offline  cpreston   United States
Messages: 160
Registered: June 2012
Location: Oceanside
Karma: 6
Senior Member
add to buddy list
ignore all messages by this user
That's what it SHOULD be doing. Instead, it is changing the forum directory and FUDforum directory to 000 when I lock them.

I have permission or it wouldn't be doing that either.

BTW, 755 and 644 are the typical permissions I set everything to on my site. I usually do that after installing new software, I do a recursive change of everything to those permissions.

[Updated on: Mon, 07 October 2013 11:04]

Report message to a moderator

Re: Locking Forums in 3.0.5 makes perms 000 [message #183093 is a reply to message #183080] Mon, 07 October 2013 18:30 Go to previous messageGo to next message
cpreston is currently offline  cpreston   United States
Messages: 160
Registered: June 2012
Location: Oceanside
Karma: 6
Senior Member
add to buddy list
ignore all messages by this user
I just manually set file permissions to 600 and directories to 700, and the forum immediately stopped working. This is a cpanel site with suphp turned on, which I believe is typical. Both the user and nobody has to have the ability to read the files.

I also verified again that it is setting the parent directories to 000, not 700.
Re: Locking Forums in 3.0.5 makes perms 000 [message #183094 is a reply to message #183093] Tue, 08 October 2013 02:25 Go to previous messageGo to next message
naudefj is currently offline  naudefj   
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Strangely enough it's working perfectly on my server. The values are also correctly coded in the script.

Maybe we just need to remove this control panel. Every server is different and it's impossible to know how a server will react when file permissions are changed.
Re: Locking Forums in 3.0.5 makes perms 000 [message #183097 is a reply to message #183094] Tue, 08 October 2013 14:44 Go to previous messageGo to next message
cpreston is currently offline  cpreston   United States
Messages: 160
Registered: June 2012
Location: Oceanside
Karma: 6
Senior Member
add to buddy list
ignore all messages by this user
When you say "remove this control panel," are you referring to the lock/unlock one? it's always been there.
Re: Locking Forums in 3.0.5 makes perms 000 [message #183100 is a reply to message #183097] Tue, 08 October 2013 15:41 Go to previous messageGo to next message
naudefj is currently offline  naudefj   
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Yes, this lock/unlock business is just causing problems.
Do you perhaps have a test forum where I can test, as I'm unable to reproduce?
Re: Locking Forums in 3.0.5 makes perms 000 [message #183192 is a reply to message #183100] Fri, 11 October 2013 22:08 Go to previous messageGo to next message
cpreston is currently offline  cpreston   United States
Messages: 160
Registered: June 2012
Location: Oceanside
Karma: 6
Senior Member
add to buddy list
ignore all messages by this user
Yes, I do. PM/email me for details.
Re: Locking Forums in 3.0.5 makes perms 000 [message #183397 is a reply to message #183192] Tue, 22 October 2013 03:23 Go to previous message
naudefj is currently offline  naudefj   
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Fix committed @ http://sourceforge.net/p/fudforum/code/5714
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: search engine bug
Next Topic: Error with images after upgrade to 3.0.5
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Dec 12 17:01:26 EST 2017

Total time taken to generate the page: 0.00851 seconds