FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Upgrade from 3.0.4 to 3.0.5 failed (DB upgrade with Fatal error: Uncaught exception )
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Upgrade from 3.0.4 to 3.0.5 failed [message #183593] Fri, 01 November 2013 17:38 Go to next message
-ml- is currently offline  -ml-
Messages: 12
Registered: March 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi,

when trying to upgrade from 3.0.4 to 3.0.5 I get the following error
Warning: pg_query(): Query failed: FEHLER: Operator existiert nicht: character varying = integer LINE 1: UPDATE fud30_users SET conf_key =NULL WHERE conf_key =0 ^ HINT: Kein Operator stimmt mit dem angegebenen Namen und den Argumenttypen überein. Sie müssen möglicherweise ausdrückliche Typumwandlungen hinzufügen. in /home/httpd/private/sql/pgsql/db.inc on line 108

Fatal error: Uncaught exception 'Exception' with message ': FEHLER: Operator existiert nicht: character varying = integer LINE 1: UPDATE fud30_users SET conf_key =NULL WHERE conf_key =0 ^ HINT: Kein Operator stimmt mit dem angegebenen Namen und den Argumenttypen überein. Sie müssen möglicherweise ausdrückliche Typumwandlungen hinzufügen. @ UPDATE fud30_users SET conf_key =NULL WHERE conf_key =0' in /home/httpd//upgrade.php:170 Stack trace: #0 /home/httpd//private/sql/pgsql/db.inc(108): fud_sql_error_handler('UPDATE fud30_us...', 'FEHLER: Operat...', '', '9.1.9') #1 /home/httpd//upgrade.php(87): q('UPDATE fud30_us...') #2 /home/httpd//upgrade.php(918): users_conf_key(Array) #3 {main} thrown in /home/httpd//upgrade.php on line 170


It seems like all forum categories are being ignored. All forums are listed under "Private Forums Another test category for demonstration purposes." which I never used.


My configuration is
FUDforum version: 	3.0.5
PHP version: 	5.4.4-14+deb7u5
PHP built on: 	Linux rechenknecht 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64
Database type: 	pgsql (pgsql)
Database version: 	9.1.9
Web server: 	Apache/2.2
Web Server load: 	0,3
Web server to PHP interface: 	apache2handler
WebServer User/Group: 	www-data / www-data (33/33)
Relevant PHP settings: 	
Safe mode: 	OFF
Open basedir: 	none
Display errors: 	ON
File uploads: 	ON
Maximum file upload size: 	20M
Magic quotes: 	OFF
Output buffering: 	Yes
Disabled functions: 	pcntl_alarm, pcntl_fork, pcntl_waitpid, pcntl_wait, pcntl_wifexited, pcntl_wifstopped, pcntl_wifsignaled, pcntl_wexitstatus, pcntl_wtermsig, pcntl_wstopsig, pcntl_signal, pcntl_signal_dispatch, pcntl_get_last_error, pcntl_strerror, pcntl_sigprocmask, pcntl_sigwaitinfo, pcntl_sigtimedwait, pcntl_exec, pcntl_getpriority, pcntl_setpriority,
PSpell support: 	No
Zlib support: 	Yes


What should I do? Revert to 3.0.4? Any way to fix this?

Best regards

[Updated on: Fri, 01 November 2013 17:47]

Report message to a moderator

Re: Upgrade from 3.0.4 to 3.0.5 failed [message #183604 is a reply to message #183593] Sat, 02 November 2013 02:06 Go to previous messageGo to next message
naudefj is currently offline  naudefj   
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Just run it again.

Nothing is deleted. Everything will be made viable during the last step (consistency check).
Re: Upgrade from 3.0.4 to 3.0.5 failed [message #183605 is a reply to message #183604] Sat, 02 November 2013 02:32 Go to previous messageGo to next message
naudefj is currently offline  naudefj   
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
And if that doesn't work, here is the fix:
http://sourceforge.net/p/fudforum/code/5722
Re: Upgrade from 3.0.4 to 3.0.5 failed [message #183628 is a reply to message #183605] Sun, 03 November 2013 07:35 Go to previous messageGo to next message
-ml- is currently offline  -ml-
Messages: 12
Registered: March 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi naudefj,

both applying the patch re-trying do not resolve the problem.

I now get
Warning: pg_query(): Query failed: FEHLER: NULL-Wert in Spalte »conf_key« verletzt Not-Null-Constraint in /home/httpd/private/sql/pgsql/db.inc on line 108

Fatal error: Uncaught exception 'Exception' with message ': FEHLER: NULL-Wert in Spalte »conf_key« verletzt Not-Null-Constraint @ UPDATE fud30_users SET conf_key =NULL WHERE conf_key ='0'' in /home/httpd/upgrade.php:170 Stack trace: #0 /home/httpd/private/sql/pgsql/db.inc(108): fud_sql_error_handler('UPDATE fud30_us...', 'FEHLER: NULL-W...', '', '9.1.9') #1 /home/httpd/upgrade.php(87): q('UPDATE fud30_us...') #2 /home/httpd/upgrade.php(921): users_conf_key(Array) #3 {main} thrown in /home/httpd/upgrade.php on line 170


Just for curiosity I commented out line 170 in upgrade.php which throws the exception. This results in
Warning: pg_query(): Query failed: FEHLER: NULL-Wert in Spalte »conf_key« verletzt Not-Null-Constraint in /home/httpd/private/sql/pgsql/db.inc on line 108

Warning: pg_query(): Query failed: FEHLER: NULL-Wert in Spalte »reset_key« verletzt Not-Null-Constraint in /home/httpd/private/sql/pgsql/db.inc on line 108
Alter database column reset_key in table fud30_users.
Convert reset_key & conf_key from 0 to NULL

Warning: pg_query(): Query failed: FEHLER: NULL-Wert in Spalte »conf_key« verletzt Not-Null-Constraint in /home/httpd/private/sql/pgsql/db.inc on line 108

Warning: pg_query(): Query failed: FEHLER: NULL-Wert in Spalte »reset_key« verletzt Not-Null-Constraint in /home/httpd/private/sql/pgsql/db.inc on line 108
Alter database column registration_ip in table fud30_users.
Convert reg_ip to registration_ip for IPv6 compatibility

Warning: pg_query(): Query failed: FEHLER: Spalte »reg_ip« existiert nicht LINE 1: SELECT id, reg_ip FROM fud30_users ^ in /home/httpd/private/sql/pgsql/db.inc on line 108

Warning: pg_fetch_row() expects parameter 1 to be resource, boolean given in /home/httpd/private/sql/pgsql/db.inc on line 148
Alter database column last_used_ip in table fud30_users.
Convert last_known_ip to last_used_ip IPv6 compatibility

Warning: pg_query(): Query failed: FEHLER: Spalte »last_known_ip« existiert nicht LINE 1: SELECT id, last_known_ip FROM fud30_users ^ in /home/httpd/private/sql/pgsql/db.inc on line 108

Warning: pg_fetch_row() expects parameter 1 to be resource, boolean given in /home/httpd/private/sql/pgsql/db.inc on line 148
Alter database column ip_addr in table fud30_msg.
Alter database column ip_addr in table fud30_pmsg.

Warning: pg_query(): Query failed: FEHLER: doppelter Schlüsselwert verletzt Unique-Constraint »fud30_search_i_w« DETAIL: Schlüssel »(word)=(übliche)« existiert bereits. in /home/httpd/private/sql/pgsql/db.inc on line 108

Warning: pg_query(): Query failed: FEHLER: doppelter Schlüsselwert verletzt Unique-Constraint »fud30_search_i_w« DETAIL: Schlüssel »(word)=(überwinden)« existiert bereits. in /home/httpd/private/sql/pgsql/db.inc on line 108

Warning: pg_query(): Query failed: FEHLER: doppelter Schlüsselwert verletzt Unique-Constraint »fud30_search_i_w« DETAIL: Schlüssel »(word)=(übernommen)« existiert bereits. in /home/httpd/private/sql/pgsql/db.inc on line 108

Warning: pg_query(): Query failed: FEHLER: doppelter Schlüsselwert verletzt Unique-Constraint »fud30_search_i_w« DETAIL: Schlüssel »(word)=(über)« existiert bereits. in /home/httpd/private/sql/pgsql/db.inc on line 108

Warning: pg_query(): Query failed: FEHLER: doppelter Schlüsselwert verletzt Unique-Constraint »fud30_search_i_w« DETAIL: Schlüssel »(word)=(übernachtet)« existiert bereits. in /home/httpd/private/sql/pgsql/db.inc on line 108

Warning: pg_query(): Query failed: FEHLER: doppelter Schlüsselwert verletzt Unique-Constraint »fud30_search_i_w« DETAIL: Schlüssel »(word)=(überlegt)« existiert bereits. in /home/httpd/private/sql/pgsql/db.inc on line 108

Warning: pg_query(): Query failed: FEHLER: doppelter Schlüsselwert verletzt Unique-Constraint »fud30_search_i_w« DETAIL: Schlüssel »(word)=(üben)« existiert bereits. in /home/httpd/private/sql/pgsql/db.inc on line 108

Warning: pg_query(): Query failed: FEHLER: doppelter Schlüsselwert verletzt Unique-Constraint »fud30_search_i_w« DETAIL: Schlüssel »(word)=(ärztliches)« existiert bereits. in /home/httpd/private/sql/pgsql/db.inc on line 108

Warning: pg_query(): Query failed: FEHLER: doppelter Schlüsselwert verletzt Unique-Constraint »fud30_search_i_w« DETAIL: Schlüssel »(word)=(könnte)« existiert bereits. in /home/httpd/private/sql/pgsql/db.inc on line 108

Warning: pg_query(): Query failed: FEHLER: doppelter Schlüsselwert verletzt Unique-Constraint »fud30_search_i_w« DETAIL: Schlüssel »(word)=(übernehmen)« existiert bereits. in /home/httpd/private/sql/pgsql/db.inc on line 108
SQL upgrades completed.
Checking GLOBAL variables.
Please manually update custom theme RAG_neu.
WARNING: {DEF: img_ext} is deprecated. Please replace it with .png in drawmsg.tmpl.
WARNING: {DEF: img_ext} is deprecated. Please replace it with .png in drawmsg.tmpl.
WARNING: {DEF: img_ext} is deprecated. Please replace it with .png in drawmsg.tmpl.
WARNING: {DEF: img_ext} is deprecated. Please replace it with .png in drawmsg.tmpl.
WARNING: {DEF: img_ext} is deprecated. Please replace it with .png in drawmsg.tmpl.
WARNING: {DEF: img_ext} is deprecated. Please replace it with .png in drawmsg.tmpl.
WARNING: {DEF: img_ext} is deprecated. Please replace it with .png in drawmsg.tmpl.
WARNING: {DEF: img_ext} is deprecated. Please replace it with .png in drawmsg.tmpl.
WARNING: {DEF: img_ext} is deprecated. Please replace it with .png in drawmsg.tmpl.
WARNING: {DEF: img_ext} is deprecated. Please replace it with .png in drawmsg.tmpl.
WARNING: {DEF: img_ext} is deprecated. Please replace it with .png in drawmsg.tmpl.
WARNING: {DEF: img_ext} is deprecated. Please replace it with .png in drawmsg.tmpl.
WARNING: {DEF: img_ext} is deprecated. Please replace it with .png in drawmsg.tmpl.
WARNING: {DEF: img_ext} is deprecated. Please replace it with .png in drawmsg.tmpl.
WARNING: {DEF: img_ext} is deprecated. Please replace it with .png in drawmsg.tmpl.
WARNING: {DEF: img_ext} is deprecated. Please replace it with .png in drawmsg.tmpl.
Theme RAG_neu was successfully compiled.
Theme default was successfully compiled.
Theme Grau was successfully compiled.


The good news is that the categories are back.

Any idea how to fix the remaining issues?


Thanks
Re: Upgrade from 3.0.4 to 3.0.5 failed [message #183690 is a reply to message #183628] Sun, 10 November 2013 12:58 Go to previous message
naudefj is currently offline  naudefj   
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The upgrade script didn't drop NOT NULL constraints.
Patch committed at http://sourceforge.net/p/fudforum/code/5733/

I assume you forum is up and running. If not, you should be able to drop the NOT NULL constraints manually.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Can't logout from Firefox
Next Topic: Problems part 2
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Dec 12 17:03:55 EST 2017

Total time taken to generate the page: 0.00748 seconds