FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » Imported messages » comp.lang.php » installation de php_ssh2.dll avec PHP 5.4.3
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
installation de php_ssh2.dll avec PHP 5.4.3 [message #186445] Thu, 31 July 2014 05:32 Go to next message
rimayari91 is currently offline  rimayari91
Messages: 1
Registered: July 2014
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Bonjour a tous,

j'ai besoin de telecharger php_ssh2.dll sur windows 7 aprés l'avoir fait je reçois le message suivant:

Call to undefined function ssh2_connect() aprés des recherches j'ai trouvé qu'il s'agit d'une incompatibilté avec la version php 5.4.3 en essayant de télécharger la version adéquate j'ai trouvé 2 fichier le premier NTS et le deuxieme TS ensuite ces fichiers contiennet en plus de php_ssh2.dll libssh2.dll

Quel fichier dois-je choisir et pourquoi il exsite enplus de php_ssh2.dll le fichier libssh2.dll

Merci par avance
voici le lien dans lequel j'ai trouvé les fichiers

http://pecl.php.net/package/ssh2/0.12/windows
Re: installation de php_ssh2.dll avec PHP 5.4.3 [message #186446 is a reply to message #186445] Thu, 31 July 2014 07:52 Go to previous messageGo to next message
Jerry Stuckle is currently offline  Jerry Stuckle
Messages: 2598
Registered: September 2010
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
On 7/31/2014 5:32 AM, rimayari91(at)gmail(dot)com wrote:
> Bonjour a tous,
>
> j'ai besoin de telecharger php_ssh2.dll sur windows 7 aprés l'avoir fait je reçois le message suivant:
>
> Call to undefined function ssh2_connect() aprés des recherches j'ai trouvé qu'il s'agit d'une incompatibilté avec la version php 5.4.3 en essayant de télécharger la version adéquate j'ai trouvé 2 fichier le premier NTS et le deuxieme TS ensuite ces fichiers contiennet en plus de php_ssh2.dll libssh2.dll
>
> Quel fichier dois-je choisir et pourquoi il exsite enplus de php_ssh2.dll le fichier libssh2.dll
>
> Merci par avance
> voici le lien dans lequel j'ai trouvé les fichiers
>
> http://pecl.php.net/package/ssh2/0.12/windows

This is an English language newsgroup. You'll get a lot better help if
you post your question in English.

But from what I understand of your question, there are two files for
Windows because it depends on the version of PHP (thread-safe or
non-thread-safe). You must download the file which matches your version.


--
==================
Remove the "x" from my email address
Jerry Stuckle
jstucklex(at)attglobal(dot)net
==================
Re: installation de php_ssh2.dll avec PHP 5.4.3 [message #186447 is a reply to message #186446] Thu, 31 July 2014 09:04 Go to previous messageGo to next message
Christoph Michael Bec is currently offline  Christoph Michael Bec
Messages: 207
Registered: June 2013
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Jerry Stuckle wrote:

> On 7/31/2014 5:32 AM, rimayari91(at)gmail(dot)com wrote:
>>
>> j'ai besoin de telecharger php_ssh2.dll sur windows 7 aprés l'avoir
>> fait je reçois le message suivant:
>>
>> Call to undefined function ssh2_connect() aprés des recherches j'ai
>> trouvé qu'il s'agit d'une incompatibilté avec la version php 5.4.3
>> en essayant de télécharger la version adéquate j'ai trouvé 2
>> fichier le premier NTS et le deuxieme TS ensuite ces fichiers
>> contiennet en plus de php_ssh2.dll libssh2.dll
>>
>> Quel fichier dois-je choisir et pourquoi il exsite enplus de
>> php_ssh2.dll le fichier libssh2.dll
>>
>> Merci par avance voici le lien dans lequel j'ai trouvé les
>> fichiers
>>
>> http://pecl.php.net/package/ssh2/0.12/windows
>
> This is an English language newsgroup. You'll get a lot better help
> if you post your question in English.

Or ask in a French newsgroup, for instance, fr.comp.lang.php.

> But from what I understand of your question, there are two files for
> Windows because it depends on the version of PHP (thread-safe or
> non-thread-safe). You must download the file which matches your
> version.

It seems to me that this isn't a TS vs. NTS issue, but rather that
php_ssh2.dll contains the PHP bindings for libssh2.dll, so most likely
both files have to be installed on Windows.

--
Christoph M. Becker
Re: installation de php_ssh2.dll avec PHP 5.4.3 [message #186448 is a reply to message #186447] Thu, 31 July 2014 09:25 Go to previous messageGo to next message
Jerry Stuckle is currently offline  Jerry Stuckle
Messages: 2598
Registered: September 2010
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
On 7/31/2014 9:04 AM, Christoph M. Becker wrote:
> Jerry Stuckle wrote:
>
>> On 7/31/2014 5:32 AM, rimayari91(at)gmail(dot)com wrote:
>>>
>>> j'ai besoin de telecharger php_ssh2.dll sur windows 7 aprés l'avoir
>>> fait je reçois le message suivant:
>>>
>>> Call to undefined function ssh2_connect() aprés des recherches j'ai
>>> trouvé qu'il s'agit d'une incompatibilté avec la version php 5.4.3
>>> en essayant de télécharger la version adéquate j'ai trouvé 2
>>> fichier le premier NTS et le deuxieme TS ensuite ces fichiers
>>> contiennet en plus de php_ssh2.dll libssh2.dll
>>>
>>> Quel fichier dois-je choisir et pourquoi il exsite enplus de
>>> php_ssh2.dll le fichier libssh2.dll
>>>
>>> Merci par avance voici le lien dans lequel j'ai trouvé les
>>> fichiers
>>>
>>> http://pecl.php.net/package/ssh2/0.12/windows
>>
>> This is an English language newsgroup. You'll get a lot better help
>> if you post your question in English.
>
> Or ask in a French newsgroup, for instance, fr.comp.lang.php.
>
>> But from what I understand of your question, there are two files for
>> Windows because it depends on the version of PHP (thread-safe or
>> non-thread-safe). You must download the file which matches your
>> version.
>
> It seems to me that this isn't a TS vs. NTS issue, but rather that
> php_ssh2.dll contains the PHP bindings for libssh2.dll, so most likely
> both files have to be installed on Windows.
>

That's possible - I'm not sure exactly what he's asking. I assumed he
was asking why two copies of libssh2.dll, but I could easily be wrong.

--
==================
Remove the "x" from my email address
Jerry Stuckle
jstucklex(at)attglobal(dot)net
==================
Re: installation de php_ssh2.dll avec PHP 5.4.3 [message #186449 is a reply to message #186445] Thu, 31 July 2014 09:38 Go to previous messageGo to next message
F. George McDuffee is currently offline  F. George McDuffee
Messages: 1
Registered: July 2014
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
On Thu, 31 Jul 2014 02:32:05 -0700 (PDT),
rimayari91(at)gmail(dot)com wrote:

> Bonjour a tous,
>
> j'ai besoin de telecharger php_ssh2.dll sur windows 7 aprés l'avoir fait je reçois le message suivant:
>
> Call to undefined function ssh2_connect() aprés des recherches j'ai trouvé qu'il s'agit d'une incompatibilté avec la version php 5.4.3 en essayant de télécharger la version adéquate j'ai trouvé 2 fichier le premier NTS et le deuxieme TS ensuite ces fichiers contiennet en plus de php_ssh2.dll libssh2.dll
>
> Quel fichier dois-je choisir et pourquoi il exsite enplus de php_ssh2.dll le fichier libssh2.dll
>
> Merci par avance
> voici le lien dans lequel j'ai trouvé les fichiers
>
> http://pecl.php.net/package/ssh2/0.12/windows
=================
FWIW Bing Translation (
http://www.bing.com/translator/follows ) follows:

Hello to all,

I need download php_ssh2.dll on windows 7 apr = materials
have made it =
I re = E7ois the following message:

Call to undefined function ssh2_connect() apr = materials of
research I have found =
= E9 it's an incompatibilt = E9 with the php 5.4.3 in essay
= version
t = download Ant = 84o ad = E9quate version I have found =
E9 2 file pre =
Mier NTS and the second TS then these files contain in
addition to php_s =
SH2.dll libssh2.dll = 20

What file should I choose and why it exsite php_ssh2.dll
then l =
file libssh2.dll

Thanks in advance = 20
Here is the link where I found = E9 files

http://pecl.php.NET/package/SSH2/0.12/Windows


--
Unka' George

"Gold is the money of kings,
silver is the money of gentlemen,
barter is the money of peasants,
but debt is the money of slaves"

-Norm Franz, "Money and Wealth in the New Millenium"
Re: installation de php_ssh2.dll avec PHP 5.4.3 [message #186450 is a reply to message #186449] Thu, 31 July 2014 10:15 Go to previous message
Jerry Stuckle is currently offline  Jerry Stuckle
Messages: 2598
Registered: September 2010
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
On 7/31/2014 9:38 AM, F. George McDuffee wrote:
> On Thu, 31 Jul 2014 02:32:05 -0700 (PDT),
> rimayari91(at)gmail(dot)com wrote:
>
>> Bonjour a tous,
>>
>> j'ai besoin de telecharger php_ssh2.dll sur windows 7 aprés l'avoir fait je reçois le message suivant:
>>
>> Call to undefined function ssh2_connect() aprés des recherches j'ai trouvé qu'il s'agit d'une incompatibilté avec la version php 5.4.3 en essayant de télécharger la version adéquate j'ai trouvé 2 fichier le premier NTS et le deuxieme TS ensuite ces fichiers contiennet en plus de php_ssh2.dll libssh2.dll
>>
>> Quel fichier dois-je choisir et pourquoi il exsite enplus de php_ssh2.dll le fichier libssh2.dll
>>
>> Merci par avance
>> voici le lien dans lequel j'ai trouvé les fichiers
>>
>> http://pecl.php.net/package/ssh2/0.12/windows
> =================
> FWIW Bing Translation (
> http://www.bing.com/translator/follows ) follows:
>
> Hello to all,
>
> I need download php_ssh2.dll on windows 7 apr = materials
> have made it =
> I re = E7ois the following message:
>
> Call to undefined function ssh2_connect() apr = materials of
> research I have found =
> = E9 it's an incompatibilt = E9 with the php 5.4.3 in essay
> = version
> t = download Ant = 84o ad = E9quate version I have found =
> E9 2 file pre =
> Mier NTS and the second TS then these files contain in
> addition to php_s =
> SH2.dll libssh2.dll = 20
>
> What file should I choose and why it exsite php_ssh2.dll
> then l =
> file libssh2.dll
>
> Thanks in advance = 20
> Here is the link where I found = E9 files
>
> http://pecl.php.NET/package/SSH2/0.12/Windows
>
>

Yes, I can use Google Translate, also. But the question is still not
all that clear. Google Translate does OK, but not the greatest.

Does he mean two files as in php_ssh2.dll and libssh2.dll? Or two
different versions of one (or both) of the files with the same name?
Due to deficiencies in computerized translations, it could be either.

I tend to agree with Christopher now - but to me it still is not clear
that IS what the OP means.

--
==================
Remove the "x" from my email address
Jerry Stuckle
jstucklex(at)attglobal(dot)net
==================
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: sending pdf files to individual email...
Next Topic: Facebook's new PHP spec
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Mon Oct 16 18:20:25 EDT 2017

Total time taken to generate the page: 0.00848 seconds