FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » FUDForum problems with sqlite3
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
FUDForum problems with sqlite3 [message #186471] Sun, 17 August 2014 20:54 Go to next message
mandel is currently offline  mandel   China
Messages: 2
Registered: August 2014
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I have php5 and sqlite3 installed. but the install.php says:

FUDforum requires a database to function. Your PHP installation does not support any of following databases: IBM DB2, Firebird, MySQL, Oracle, PosgreSQL, SQLite or MS-SQL Server. Please rectify this and try again.

my settings are:

SQLite3 module version 0.7-dev
SQLite Library 3.7.7.1
sqlite3.extension_dir no value no value
PHP Version 5.3.27

I try to comment and uncomment the following 3 lines in php.ini in all kinds of combinations.
extension=php_pdo_sqlite.dll
extension=php_sqlite.dll
extension=php_sqlite3.dll
none worked.


Re: FUDForum problems with sqlite3 [message #186476 is a reply to message #186471] Tue, 19 August 2014 14:05 Go to previous messageGo to next message
eclipsewebmaster is currently offline  eclipsewebmaster   
Messages: 46
Registered: November 2009
Location: Ottawa, Ontario, Canada
Karma: 0
Member
add to buddy list
ignore all messages by this user
You also need to install the php modules for sqlite. For instance:

# rpm -qa | grep php
php53-sqlite-5.3.17-0.13.7
php53-mysql-5.3.17-0.17.1
Re: FUDForum problems with sqlite3 [message #186504 is a reply to message #186476] Fri, 29 August 2014 22:29 Go to previous message
mandel is currently offline  mandel   China
Messages: 2
Registered: August 2014
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I have installed php 5.3.27, the sqlite3 is included in this version of php.

and, the OS is windows server 2003, not linux.

[Updated on: Fri, 29 August 2014 22:29]

Report message to a moderator

Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: FUDforum on Debian server with firebird 2.6
Next Topic: Is FUDforum2go still viable
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Jan 20 19:59:09 EST 2018

Total time taken to generate the page: 0.00713 seconds