FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » General » PHP discussions » PHP cli problems (Webhost server and php cli problems.)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
PHP cli problems [message #164123] Wed, 05 January 2011 07:24 Go to next message
mikesla is currently offline  mikesla   Canada
Messages: 15
Registered: December 2010
Location: Nova Scotia
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi.

I am using FUDforum on a webhost server named "Free webhosting", and in the Jobs section of my forum, I placed what FUDform accepts as proper php path (/usr/lib/php/), but when I wish to run the job (importing messages for Newsgroups) I get this error message ERROR: "Unable to submit: PHP CLI Executable not set or is not executable."

Now I have no idea why I cannot get this NNTP to work on this server. I changed the path in my NNTP.php file to the path which FUDform says is the proper php path.

Also, I have tried setting up a CRON job, and this is what I was told to do to set the job up php -f /home/Account Name/User name/public_html/scripts/nntp.php (note: Account name is not account name)but it doesn't work.

So am I out of luck here?

Any help will be appreciated.

[Updated on: Wed, 05 January 2011 07:25]

Report message to a moderator

Re: PHP cli problems [message #164128 is a reply to message #164123] Wed, 05 January 2011 08:31 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3622
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
What is your value for PHP_CLI in your GLOBALS.php file?

Please also post the "ls -l" output of the file.
Re: PHP cli problems [message #164132 is a reply to message #164128] Wed, 05 January 2011 13:36 Go to previous messageGo to next message
mikesla is currently offline  mikesla   Canada
Messages: 15
Registered: December 2010
Location: Nova Scotia
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
naudefj wrote on Wed, 05 January 2011 08:31
What is your value for PHP_CLI in your GLOBALS.php file?

Please also post the "ls -l" output of the file.


Hi, thanks for the reply.

Before I go, and take a look at the Globals.php I need to know if running FUDforum requires to be run on a Windows server, and not a linux server?

The free webhost server which FUDforum is currently installed is a linux server.

Request:I do run a local FUDforum server using Xammp (totally flawless), so I need to know if anyone here knows of a decent FREE windows server to run FUDforum on? Currently I am looking into a Windows Webhost which is free but it's cursed meaning that it will only allow you to upload a file no greater than 500kb, I guess I'm suppose to stare at the c-panel, and have happy thoughts.

Later!

Re: PHP cli problems [message #164133 is a reply to message #164128] Wed, 05 January 2011 13:44 Go to previous messageGo to next message
mikesla is currently offline  mikesla   Canada
Messages: 15
Registered: December 2010
Location: Nova Scotia
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
naudefj wrote on Wed, 05 January 2011 08:31
What is your value for PHP_CLI in your GLOBALS.php file?

Please also post the "ls -l" output of the file.


Here is what it says for PHP_CLI in the globals.php

$PHP_CLI = '/usr/lib/php/'

I just checked my Globals.php on my local server and it shows /usr/bin/php/php.exe as it should, but since I'm on a linux server, where would the executable be? or is there one?

Later!


[Updated on: Wed, 05 January 2011 13:48]

Report message to a moderator

Re: PHP cli problems [message #164143 is a reply to message #164133] Thu, 06 January 2011 07:19 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3622
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
Looks like your $PHP_CLI contains a directory and not an executable.
It's normally /usr/bin/php or /usr/local/bin/php on Linux systems.
Re: PHP cli problems [message #164149 is a reply to message #164143] Thu, 06 January 2011 09:41 Go to previous messageGo to next message
mikesla is currently offline  mikesla   Canada
Messages: 15
Registered: December 2010
Location: Nova Scotia
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
naudefj wrote on Thu, 06 January 2011 07:19
Looks like your $PHP_CLI contains a directory and not an executable.
It's normally /usr/bin/php or /usr/local/bin/php on Linux systems.


Hi.

I used both for the php path setup you posted, and it doesn't work. I posted a request on their forum asking for the path a couple of days ago, and they haven't responded so I guess I'll have to offer up my usenet groups from my computer. I really don't want to have to do this simply because I only have a whopping super fast dial-up connection (you can all laugh now, I am)Smile.

I guess it will have to do until I can find a server which will allow me to use FUDform properly.

Note: I have to say the more I use FUDform, it puts to shame so many other forum software out there. I really like FUDforum, now to get it to work on a webhost server which will allow me to run jobs, even cron jobs won't work without the proper php path.

I run several websites, so I'm going to promote FUDforum. From what I have noticed, many people do not even know it exists.

Later, and thanks allot for the help.



[Updated on: Thu, 06 January 2011 09:44]

Report message to a moderator

Re: PHP cli problems [message #168259 is a reply to message #164149] Mon, 25 March 2013 00:15 Go to previous messageGo to next message
Jack Hard is currently offline  Jack Hard
Messages: 7
Registered: December 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I use the PHP configuration path said they did not work. I posted a request on their forum to ask questions about how in a few days, did not answer, so I guess I should give these groups from my PC Usenet. I really did not want to do simply because we have a single set of huge super fast

I think you have to do until you can find a server that allows me to use FUDform correctly.

Note: I must say that the more you use FUDform, as evidenced by the other forum software out there for many people. I love FUDforum now to make it work for the server hosting that allows me to do my job, including PHP cron job will not work without the right path.

I can work with multiple websites, so I'll help you FUDforum. From what I've seen many people do not even know it exists.
Re: PHP cli problems [message #187114 is a reply to message #168259] Thu, 21 April 2016 06:50 Go to previous message
markpowell is currently offline  markpowell
Messages: 2
Registered: April 2016
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Thanks for info!
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Using PHP to send mail
Next Topic: PHP Image Functions
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Fri Sep 22 06:08:56 EDT 2017

Total time taken to generate the page: 0.00745 seconds