FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Failing to change forum to RTL
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Failing to change forum to RTL [message #187608] Sun, 21 October 2018 18:45 Go to next message
watershed is currently offline  watershed   France
Messages: 4
Registered: October 2018
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi there!

I am running a demo of FUDforum which is intended for a community in Hebrew. I was prompted to select a language when setting up the forum, and chose Hebrew.
Most of the forum is indeed translated to Hebrew, but the text alignment is left to right (rather than right to left as it should be in Hebrew).

I see that when adding Arabic (another RTL language) it is aligned properly - is there a way to get the same for Hebrew?

Went through all the settings and couldn't seem to find how to do that.

Many thanks Smile

Re: Failing to change forum to RTL [message #187610 is a reply to message #187608] Mon, 22 October 2018 02:46 Go to previous messageGo to next message
naudefj is currently offline  naudefj   United States
Messages: 3685
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Copy the file called "dir" from the Arabic translation to the Hebrew translation and recompile your theme.
We will fix it in the next release.
Re: Failing to change forum to RTL [message #187611 is a reply to message #187610] Mon, 22 October 2018 05:37 Go to previous messageGo to next message
watershed is currently offline  watershed   France
Messages: 4
Registered: October 2018
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Thanks for the quick reply Smile

Could you please point me to where this file is located exactly? (edit: nevermind, I found it in the i18n folders)

Thanks again Cool

[Updated on: Mon, 22 October 2018 05:45]

Report message to a moderator

Re: Failing to change forum to RTL [message #187612 is a reply to message #187608] Sun, 28 October 2018 13:20 Go to previous messageGo to next message
watershed is currently offline  watershed   France
Messages: 4
Registered: October 2018
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
A quick follow up

After taking the steps to fix the RTL view in the forums I still have some alignment issues (see screenshot) where the poster info is misaligned.

Are there any steps i can take to fix this?

Thanks again, I am running a medium sized community and we are considering migrating to FUD Cool
  • Attachment: followup.JPG
    (Size: 24.96KB, Downloaded 39 times)
Re: Failing to change forum to RTL [message #187614 is a reply to message #187612] Mon, 29 October 2018 12:24 Go to previous message
naudefj is currently offline  naudefj   United States
Messages: 3685
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Strange. I assume it must be something in the HTML code that aligns/ floats the poster info to the right when you enable RTL support.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Migration Problem
Next Topic: FUDforum2Go Appliance for Windows
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Nov 18 03:13:00 EST 2018

Total time taken to generate the page: 0.00689 seconds