FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Wrong message when resetting password
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Wrong message when resetting password [message #19865] Tue, 14 September 2004 16:39 Go to next message
smike is currently offline  smike   Germany
Messages: 182
Registered: April 2002
Location: Munich/Germany
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
When resetting the password at your forum I received an email to confirm the process. If I click on that link I get an error message "Invalid password reset key" of your forum. After that error message a new email with my new password is sent.

index.php?t=getfile&id=1299&private=0

So, the process is working fine, only the displayed message is wrong.

Bye, Mike
Re: Wrong message when resetting password [message #19887 is a reply to message #19865] Wed, 15 September 2004 01:32 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
This is a "funny" problem it happens due to your e-mail client automatically opening the URL in the e-mail. The consequence of that action is the sending of password and clearing the reset key. So when you manually access the URL the reset key is no longer valid.

FUDforum Core Developer
Re: Wrong message when resetting password [message #19906 is a reply to message #19887] Wed, 15 September 2004 12:57 Go to previous messageGo to next message
smike is currently offline  smike   Germany
Messages: 182
Registered: April 2002
Location: Munich/Germany
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
I'm using the KMail-Client from the current KDE 3.3 version on SuSE Linux 9.0. Perhaps I reset my password again and analyse the network traffic with a sniffer.
If I find out something interesting, I'll tell you.
Re: Wrong message when resetting password [message #19928 is a reply to message #19906] Thu, 16 September 2004 21:11 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
It definitely does it with Kmail I was able to replicate the problem with kmail and confirm kmail opened the URL automatically internally.

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Typo error at german translation
Next Topic: Can't change settings in user CP(2.6.5RC3)
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Fri Dec 15 09:13:54 EST 2017

Total time taken to generate the page: 0.00614 seconds