FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » mysql setup issue
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
mysql setup issue [message #202] Thu, 24 January 2002 01:59 Go to next message
shnikees is currently offline  shnikees   United States
Messages: 1
Registered: January 2002
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hey whats up everyone,

I'm having a problem install the FUD board, on step three of the web based installation I'm getting the error

Failed to create table fud_search ( CREATE TABLE fud_search ( id INT UNSIGNED NOT NULL AUTO_INCREMENT PRIMARY KEY, word CHAR(255), UNIQUE(word) ) ), SQL Reason: Column 'word' is used with UNIQUE or INDEX but is not defined as NOT NULL

I cant figure out for the life of me why it cant create the table, any insight would be appreciated

Thanks
shnikees
Re: mysql setup issue [message #203 is a reply to message #202] Thu, 24 January 2002 02:55 Go to previous message
hackie is currently offline  hackie   Canada
Messages: 177
Registered: January 2002
Karma: 0
Senior Member
Core Developer
add to buddy list
ignore all messages by this user

shnikees wrote on Thu, 24 January 2002 1:59 AM

Hey whats up everyone,

I'm having a problem install the FUD board, on step three of the web based installation I'm getting the error

Failed to create table fud_search ( CREATE TABLE fud_search ( id INT UNSIGNED NOT NULL AUTO_INCREMENT PRIMARY KEY, word CHAR(255), UNIQUE(word) ) ), SQL Reason: Column 'word' is used with UNIQUE or INDEX but is not defined as NOT NULL

I cant figure out for the life of me why it cant create the table, any insight would be appreciated

Thanks
shnikees


You are using an old version of MySQL, it doesn't support NULL indexes, this isn't a problem though.. replace in the installer with the file I attached for you, it should solve this problem.

(do not forget to ungzip the file before copying it over, i.e.
$ gzip -d fud_search.tbl.gz
)


cc intelligence.c -o intelligence
$ ./intelligence
Segmentation fault
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Install probs.
Next Topic: Not able to go to Admin CP
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Oct 22 11:44:54 EDT 2017

Total time taken to generate the page: 0.00725 seconds