FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » trying to install but mysql problem
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
trying to install but mysql problem [message #23487] Fri, 18 March 2005 10:54 Go to next message
fjrohlf is currently offline  fjrohlf   United States
Messages: 82
Registered: February 2002
Karma: 0
Member
add to buddy list
ignore all messages by this user
I am trying to insall the forum on a new computer using the current RH Enterprise Linux.

In step 2 of the install script I get the following warnings:
"Warning: mysql_connect(): Can't connect to MySQL server on '127.0.0.1' (111) in /var/www/html/forum/install.php on line 83

Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /var/www/html/forum/install.php on line 87

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /var/www/html/forum/install.php on line 121"

And then the message:

"Failed to connect to the MySQL Server, SQL Reason: Can't connect to MySQL server on '127.0.0.1' (111)"

I believe the problem is that the mysql service is not running. When I try to start it in the list of services it is not listed. MySql is installed on the computer.

If I enter mysql in a terminal window I get the following:

"ERROR 2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)"

If I look at the /var/lib directory there is no mysql subdirectory.

Suggestions?

Jim


Jim
Re: trying to install but mysql problem [message #23488 is a reply to message #23487] Fri, 18 March 2005 10:59 Go to previous messageGo to next message
dennisp is currently offline  dennisp   Belize
Messages: 49
Registered: December 2004
Location: Belize
Karma: 0
Member
add to buddy list
ignore all messages by this user
As you said, it might not be running.....
try starting it with
service mysql start

thats the way it used to be done in redhat 9..i don't know about the enterprise edition but suspect that it has not changed....


About there being no mysql dir in /var/lib....i don't know...might be that redhat enterprise has it in a diff location but i doubt it..
maybe its not installed correctly.......
anyways..try starting it first before doing any re-installs/un-installs.....

regards

[Updated on: Fri, 18 March 2005 11:01]

Report message to a moderator

Re: trying to install but mysql problem [message #23489 is a reply to message #23488] Fri, 18 March 2005 11:02 Go to previous messageGo to next message
fjrohlf is currently offline  fjrohlf   United States
Messages: 82
Registered: February 2002
Karma: 0
Member
add to buddy list
ignore all messages by this user
I had tried that. I get the following message:

"mysql: unrecognized service"

Somehow the service does not exist.


Jim
Re: trying to install but mysql problem [message #23490 is a reply to message #23489] Fri, 18 March 2005 11:12 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Could it be that MySQL is not installed on the machine?

FUDforum Core Developer
Re: trying to install but mysql problem [message #23492 is a reply to message #23490] Fri, 18 March 2005 12:25 Go to previous messageGo to next message
fjrohlf is currently offline  fjrohlf   United States
Messages: 82
Registered: February 2002
Karma: 0
Member
add to buddy list
ignore all messages by this user
Would the folloiwng happen if mysql were not installed?

If I enter mysql in a terminal window I get the following:
"ERROR 2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)"

The RH add/remove program tool says that various mysql features are installed.


Jim
Re: trying to install but mysql problem [message #23493 is a reply to message #23492] Fri, 18 March 2005 12:29 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Your PHP has MySQL support, but it cannot connect/find MySQL server for it to use.

FUDforum Core Developer
Re: trying to install but mysql problem [message #23498 is a reply to message #23493] Fri, 18 March 2005 13:54 Go to previous messageGo to next message
fjrohlf is currently offline  fjrohlf   United States
Messages: 82
Registered: February 2002
Karma: 0
Member
add to buddy list
ignore all messages by this user
I just noticed that there is no mysql.sock file on my system. Is that something I create or should it have been part of the install of mysql?

Jim
Re: trying to install but mysql problem [message #23500 is a reply to message #23498] Fri, 18 March 2005 14:16 Go to previous message
fjrohlf is currently offline  fjrohlf   United States
Messages: 82
Registered: February 2002
Karma: 0
Member
add to buddy list
ignore all messages by this user
That was it. The various mysql files to support php etc. were installed but not the mysql-server itself.

Thanks for the help. Now to try to get past step 2 of the install ...


Jim


Jim
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: URGENT : administrator error
Next Topic: Update to 2.6.12RC2
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Mon Dec 11 00:58:08 EST 2017

Total time taken to generate the page: 0.00794 seconds