FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » 1.10 update problem
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
1.10 update problem [message #254] Mon, 28 January 2002 21:30 Go to next message
zerobits is currently offline  zerobits   United Kingdom
Messages: 69
Registered: January 2002
Location: Malaysia
Karma: 0
Member
add to buddy list
ignore all messages by this user
i tried the 1.10 update file.
When I do the web install, it gives me the following error.

/xxx/kopitiam/data/include/GLOBALS.php is not a valid FUDforum GLOBALS.php file

so exactly which GLOBALS.php is it referring to? Wink
Re: 1.10 update problem [message #257 is a reply to message #254] Mon, 28 January 2002 21:40 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
zerobits wrote on Mon, 28 January 2002 9:30 PM

i tried the 1.10 update file.
When I do the web install, it gives me the following error.

/xxx/kopitiam/data/include/GLOBALS.php is not a valid FUDforum GLOBALS.php file

so exactly which GLOBALS.php is it referring to? Wink


could you show me what you have inside the $INCLUDE variable of your GLOBALS.php?


FUDforum Core Developer
Re: 1.10 update problem [message #259 is a reply to message #257] Mon, 28 January 2002 21:47 Go to previous messageGo to next message
zerobits is currently offline  zerobits   United Kingdom
Messages: 69
Registered: January 2002
Location: Malaysia
Karma: 0
Member
add to buddy list
ignore all messages by this user
/xxx/kopitiam/data/include/
Re: 1.10 update problem [message #260 is a reply to message #259] Mon, 28 January 2002 21:53 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
zerobits wrote on Mon, 28 January 2002 9:47 PM

/xxx/kopitiam/data/include/


Unusual.

It would appear the error is occuring because php thinks
that
( realpath() <- PHP's path resolving function )

readpath('/xxx/kopitiam/data/include/GLOBALS.php') != realpath($GLOBALS['INCLUDE'].'GLOBALS.php');


You can slightly modify the script to bypass this check, although I wonder why this happens...

TO comment out the GLOBALS.php validity code comment out lines: 188-192 inside update.php

If possible PM me or show me what php's realpath function resolves the path of GLOBALS.php to...


FUDforum Core Developer
Re: 1.10 update problem [message #263 is a reply to message #260] Mon, 28 January 2002 23:17 Go to previous messageGo to next message
zerobits is currently offline  zerobits   United Kingdom
Messages: 69
Registered: January 2002
Location: Malaysia
Karma: 0
Member
add to buddy list
ignore all messages by this user
Solved. done.

What exactly are the improvement, can't see any visual changes on my forum? And my differs from your Legend box, and the "Logged in users" box in the main page...

And i don't have online/offline, welcome greetings as well. What exactly is the 1.1 update for? Visual bug fix?

[Updated on: Mon, 28 January 2002 23:30]

Report message to a moderator

Re: 1.10 update problem [message #265 is a reply to message #263] Tue, 29 January 2002 00:05 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
zerobits wrote on Mon, 28 January 2002 11:17 PM

Solved. done.

What exactly are the improvement, can't see any visual changes on my forum? And my differs from your Legend box, and the "Logged in users" box in the main page...

And i don't have online/offline, welcome greetings as well. What exactly is the 1.1 update for? Visual bug fix?




Verify that your index.php has been replaced, as the greeting should be there in the new version.
The online/offline status you may want to check that you have enabled in the global control panel. It is an option you can turn on & off.

The brunt of the 1.1.0 release was bug fixes and various code cleanups. The SQL indexes has been completely reworked from scratch to offer better performance as well.
The admin now has the ability to edit ALL of the user's settings.
A number of optimizations were added that made most commonly used poritions of the forum, such as message drawing much faster.

For full details read the change log.


FUDforum Core Developer
Re: 1.10 update problem [message #267 is a reply to message #265] Tue, 29 January 2002 00:23 Go to previous messageGo to next message
zerobits is currently offline  zerobits   United Kingdom
Messages: 69
Registered: January 2002
Location: Malaysia
Karma: 0
Member
add to buddy list
ignore all messages by this user
nope index.php has not been replaced. I have my index.php set to user makan, owner makan, so is that the reason why the file is not overwritten? And no, i still cannot edit ALL user's settings from the admin control panel.

[Updated on: Tue, 29 January 2002 00:28]

Report message to a moderator

Re: 1.10 update problem [message #268 is a reply to message #267] Tue, 29 January 2002 00:25 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
zerobits wrote on Tue, 29 January 2002 12:23 AM

nope index.php has not been replaced. I have my index.php set to user makan, owner makan, so is that the reason why the file is not overwritten?


Most definately, the upgrade script should have given you warnings saying that file(s) could not have been replaced and told you how to fix the problem (what to chmod).

I suspect many of your files have NOT been replaced as the result.


FUDforum Core Developer
Re: 1.10 update problem [message #269 is a reply to message #268] Tue, 29 January 2002 00:29 Go to previous messageGo to next message
zerobits is currently offline  zerobits   United Kingdom
Messages: 69
Registered: January 2002
Location: Malaysia
Karma: 0
Member
add to buddy list
ignore all messages by this user
so by right, what should the file permission settings for all my files... nope it did not receive any warnings.
Re: 1.10 update problem [message #270 is a reply to message #269] Tue, 29 January 2002 00:32 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
if you are the owner of the files, their permissions should have been 666, to allow the webserver to modify the files.

If you did not recieve a warning, it implies the upgrade script was able to do its job.

What is the date of your index.php? and if possible its md5sum?


FUDforum Core Developer
Re: 1.10 update problem [message #271 is a reply to message #270] Tue, 29 January 2002 00:33 Go to previous messageGo to next message
zerobits is currently offline  zerobits   United Kingdom
Messages: 69
Registered: January 2002
Location: Malaysia
Karma: 0
Member
add to buddy list
ignore all messages by this user
prottoss wrote on Tue, 29 January 2002 12:32 AM

if you are the owner of the files, their permissions should have been 666, to allow the webserver to modify the files.

If you did not recieve a warning, it implies the upgrade script was able to do its job.

What is the date of your index.php? and if possible its md5sum?


nope, no warning...
I have already changed all my files to 777, still to no avail.
Re: 1.10 update problem [message #272 is a reply to message #271] Tue, 29 January 2002 00:35 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
zerobits wrote on Tue, 29 January 2002 12:33 AM

prottoss wrote on Tue, 29 January 2002 12:32 AM

if you are the owner of the files, their permissions should have been 666, to allow the webserver to modify the files.

If you did not recieve a warning, it implies the upgrade script was able to do its job.

What is the date of your index.php? and if possible its md5sum?


nope, no warning...
I have already changed all my files to 777, still to no avail.



What's the date on the file(s)?

Also, could you paste me the output of the upgrade script?


FUDforum Core Developer
Re: 1.10 update problem [message #274 is a reply to message #272] Tue, 29 January 2002 00:38 Go to previous messageGo to next message
zerobits is currently offline  zerobits   United Kingdom
Messages: 69
Registered: January 2002
Location: Malaysia
Karma: 0
Member
add to buddy list
ignore all messages by this user
date is 20th Jan.... when i first installed the forum app.
the installation completed, without any error and gone thru' successful forum consistency check.

Here's the output from the opened window

And this is the output of the script

Got chunk info: , , , ,

Executing Consistency Checker (if the popup with the consistency checker failed to appear you MUST click here

Completed
PLEASE REMOVE THIS FILE(/xxx/kopitiam/update.php) UPON COMPLETION OF THE UPGRADE PROCESS.
THIS IS IMPERATIVE, OTHERWISE ANYONE COULD RUN THIS SCRIPT!

[Updated on: Tue, 29 January 2002 00:47]

Report message to a moderator

Re: 1.10 update problem [message #275 is a reply to message #274] Tue, 29 January 2002 00:43 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
zerobits wrote on Tue, 29 January 2002 12:38 AM

date is 20th Jan.... when i first installed the forum app.
the installation completed, without any error and gone thru' successful forum consistency check.


Okie, lets do a step by step check to see what has gone wrong.

1) Did you place the update.php script inside your forum's root browseable directory or somewhere else? It should be in the same dir where index.php for the forum resides.
ex: my forum was installed inside
/home/forum/www/docs/forum/
which is where I copied my update.php
so I could run it by going to http://fud.prohost.org/forum/update.php



FUDforum Core Developer
Re: 1.10 update problem [message #276 is a reply to message #274] Tue, 29 January 2002 00:44 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
that's the consistency checker output, not the output of the update.php script.


FUDforum Core Developer
Re: 1.10 update problem [message #277 is a reply to message #275] Tue, 29 January 2002 00:46 Go to previous messageGo to next message
zerobits is currently offline  zerobits   United Kingdom
Messages: 69
Registered: January 2002
Location: Malaysia
Karma: 0
Member
add to buddy list
ignore all messages by this user
yes it is in my web root...
i.e. www.mydomain.com/update.php

I even have the status of the update output as files UPGRADE_STATUS and UPDATE_STATUS
Re: 1.10 update problem [message #278 is a reply to message #277] Tue, 29 January 2002 00:52 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Would it be possible for you to get on IRC for a little while, it will be far faster for us to talk that way?

FUDforum Core Developer
Re: 1.10 update problem [message #279 is a reply to message #278] Tue, 29 January 2002 00:53 Go to previous messageGo to next message
zerobits is currently offline  zerobits   United Kingdom
Messages: 69
Registered: January 2002
Location: Malaysia
Karma: 0
Member
add to buddy list
ignore all messages by this user
how about MSN?
do you have one?
Re: 1.10 update problem [message #280 is a reply to message #279] Tue, 29 January 2002 00:54 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
zerobits wrote on Tue, 29 January 2002 12:53 AM

how about MSN?
do you have one?



I only have ICQ...


FUDforum Core Developer
Re: 1.10 update problem [message #281 is a reply to message #280] Tue, 29 January 2002 00:55 Go to previous messageGo to next message
zerobits is currently offline  zerobits   United Kingdom
Messages: 69
Registered: January 2002
Location: Malaysia
Karma: 0
Member
add to buddy list
ignore all messages by this user
okie... how to connect to you, which channel?
Re: 1.10 update problem [message #282 is a reply to message #281] Tue, 29 January 2002 00:56 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
irc.openprojects.net port 6667

channel #fudforum


FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Today Post visual bugs
Next Topic: GOLBALS.php & Custom_avatars won't delete
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Wed Oct 18 12:53:45 EDT 2017

Total time taken to generate the page: 0.01028 seconds