FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » fudapi.inc.php
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
fudapi.inc.php [message #26355] Sun, 17 July 2005 12:54 Go to next message
malkusch is currently offline  malkusch   Germany
Messages: 2
Registered: July 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
On line 660 (in fud_add_user() at the return statement) it must be <?php
".(int)$vals['referer_id'].",
?>
and not
<?php
".(int)$vals['ref_id'].",
?>


BTW. could you consider to use fud_add_user() with an already MD5ed password hash? For me it's of course no problem to change the method, but I don't want to do this for every update.
Re: fudapi.inc.php [message #26356 is a reply to message #26355] Sun, 17 July 2005 13:25 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Var name confusion fixed and I added the ability to specify md5 hashes. To do this, make sure the password starts with a "md5" prefix. The prefix will be removed and the rest of the value be used as the hash.

FUDforum Core Developer
Re: fudapi.inc.php [message #26360 is a reply to message #26355] Mon, 18 July 2005 04:14 Go to previous messageGo to next message
malkusch is currently offline  malkusch   Germany
Messages: 2
Registered: July 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Thanks for fixing. Here is another one:
fud_new_topic() causes text_to_worda() in include/theme/default/isearch.inc to throw the notice:
Notice: Undefined index: good_locale in include/theme/default/isearch.inc on line 52

I think a <?php
if (!isset($GLOBALS['good_locale']) || !$GLOBALS['good_locale']) {
?>
will fix it.
Re: fudapi.inc.php [message #26361 is a reply to message #26360] Mon, 18 July 2005 08:55 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Fixed in CVS, here is the fix:
http://cvs.prohost.org/c/index.cgi/FUDforum/chngview?cn=7120


FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Quirk while upgrading from 2.6.0 to 2.6.14
Next Topic: Firefox 1.0.5 - user unable to log in
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Thu Dec 14 23:46:36 EST 2017

Total time taken to generate the page: 0.00634 seconds