FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » How To » Create a poll problem
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Create a poll problem [message #27023] Wed, 24 August 2005 16:23 Go to next message
bluedev is currently offline  bluedev   United States
Messages: 9
Registered: August 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

Another attempt[ 0 votes ]
1.
2.
 

I try to create a poll in 2.7.1, but I never see the poll.
It shows that a poll has been created, but I can't see it to vote.
This post has a poll that I tried to create. Am I doing something wrong? I press the CREATE POLL link and input the information then press the UPDATE button. Is there something I'm missing?

Thanks,
Blue
Re: Create a poll problem [message #27025 is a reply to message #27023] Wed, 24 August 2005 17:16 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Fixed in CVS, apply the patch below, rebuild the theme and run consistency checker to fix existing polls.
http://cvs.prohost.org/c/index.cgi/FUDforum/chngview?cn=7252


FUDforum Core Developer
Re: Create a poll problem [message #27026 is a reply to message #27025] Wed, 24 August 2005 17:43 Go to previous messageGo to next message
bluedev is currently offline  bluedev   United States
Messages: 9
Registered: August 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Do I run the patch against the mysql database ?
If not how do I apply it?

Thanks,
Blue
Re: Create a poll problem [message #27027 is a reply to message #27026] Wed, 24 August 2005 17:53 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
This is a patch against the forum's source code.

FUDforum Core Developer
Re: Create a poll problem [message #27028 is a reply to message #27027] Wed, 24 August 2005 18:04 Go to previous messageGo to next message
bluedev is currently offline  bluedev   United States
Messages: 9
Registered: August 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I'm not too familiar with cvs syntax. Any chance you could give me the syntax for applying the patch?

Thanks,
Blue
Re: Create a poll problem [message #27029 is a reply to message #27028] Wed, 24 August 2005 18:41 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Well the patch really changes just one line, so open your text editor and change the - line into the + line in the appropriate place.

FUDforum Core Developer
Re: Create a poll problem [message #27030 is a reply to message #27029] Wed, 24 August 2005 19:06 Go to previous messageGo to next message
bluedev is currently offline  bluedev   United States
Messages: 9
Registered: August 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
That got me working.

Thanks for your help and patience!!
Re: Create a poll problem [message #27057 is a reply to message #27030] Thu, 25 August 2005 09:43 Go to previous messageGo to next message
bluedev is currently offline  bluedev   United States
Messages: 9
Registered: August 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
After testing this further, I'm still having the issue. I fixed the lines as you suggested, and rebuilt the theme and did the consistency check. This fixed the existing polls, but any new polls are the same as before. They do not show up.

I may have missed something.

Any ideas?

Thanks,
Blue
Re: Create a poll problem [message #27058 is a reply to message #27057] Thu, 25 August 2005 09:45 Go to previous messageGo to next message
bluedev is currently offline  bluedev   United States
Messages: 9
Registered: August 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Just found another issue with the existing polls.
If the poll has 3 items on it, it does not matter which you vote for. The system shows that you voted for #4, which was not even an option.

If I run the consistency check it fixes the votes and puts them to the correct items, but any future votes go to #4 again until I rerun the consistency check.


Thanks,
Blue

[Updated on: Thu, 25 August 2005 09:48]

Report message to a moderator

Re: Create a poll problem [message #27061 is a reply to message #27058] Thu, 25 August 2005 09:56 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
This is addressed by the following patch:
http://cvs.prohost.org/c/index.cgi/FUDforum/chngview?cn=7257


FUDforum Core Developer
Re: Create a poll problem [message #27071 is a reply to message #27061] Thu, 25 August 2005 11:23 Go to previous messageGo to next message
bluedev is currently offline  bluedev   United States
Messages: 9
Registered: August 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Applied that fix, but I still have the same issue.

Is there a new build coming soon? If not, would I be better off going down to 2.7.0 or 2.6.x?

Thanks,
Blue
Re: Create a poll problem [message #27072 is a reply to message #27071] Thu, 25 August 2005 11:32 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Did you rebuild the theme and run the consistency checker? It works fine after the latest patch on my development server.

I suspect 2.7.2 will be out as early as Monday.


FUDforum Core Developer
Re: Create a poll problem [message #27074 is a reply to message #27072] Thu, 25 August 2005 11:48 Go to previous messageGo to next message
bluedev is currently offline  bluedev   United States
Messages: 9
Registered: August 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Rebuilt and reran consistency checker, but still had same error.
I will take a look at it again to ensure I didn't miss anything.
If issue remains, I may wait for 2.7.2.

Thanks,
Blue
Re: Create a poll problem [message #27075 is a reply to message #27074] Thu, 25 August 2005 11:53 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Well, if you don't figure out the issue know it is likely to remain unsolved even in 2.7.2. That said I am unable to replicate the problem (which I could before) after applying the show patch.

FUDforum Core Developer
Re: Create a poll problem [message #27076 is a reply to message #27074] Thu, 25 August 2005 12:03 Go to previous message
bluedev is currently offline  bluedev   United States
Messages: 9
Registered: August 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
That got me fixed up.

I rebuilt and reran consistency check.

Created a new poll and it worked properly.

Thanks again for all your help!!
Blue
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Deleting a users subscription
Next Topic: Global Settings not sticking
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Oct 21 13:35:47 EDT 2017

Total time taken to generate the page: 0.00811 seconds