FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Disappearing reappearing thread?
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Disappearing reappearing thread? [message #30300] Thu, 16 February 2006 09:58 Go to next message
JamesS is currently offline  JamesS   United States
Messages: 275
Registered: July 2002
Location: Atlanta, GA
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
I started a new forum with a fresh install of 2.7.4. The third user to register started the second topic in one of the forums. Whenever he goes directly to this forum, via the front page, he does not see his thread; he sees the other threads though. He says that if he then uses the drop down box to re-navigate to the forum, he sees his thread listed. I can't think of anything that would be causing this.

Attached are two screenshots he sent me.

Any suggestions? I have already run a consistency check and rebuilt the search index.
  • Attachment: pic10393.jpg
    (Size: 138.31KB, Downloaded 522 times)
  • Attachment: pic30548.jpg
    (Size: 179.93KB, Downloaded 523 times)
Re: Disappearing reappearing thread? [message #30304 is a reply to message #30300] Thu, 16 February 2006 10:13 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I suspect browser cache is at fault here, ask the user to clear out their browser cache and restart the browser. The thread should appear after that.

FUDforum Core Developer
Re: Disappearing reappearing thread? [message #30306 is a reply to message #30300] Thu, 16 February 2006 10:23 Go to previous messageGo to next message
JamesS is currently offline  JamesS   United States
Messages: 275
Registered: July 2002
Location: Atlanta, GA
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
That makes sense. Don't know why I didn't think of that. IE's cache is stupid.
Re: Disappearing reappearing thread? [message #30405 is a reply to message #30300] Thu, 23 February 2006 11:08 Go to previous messageGo to next message
JamesS is currently offline  JamesS   United States
Messages: 275
Registered: July 2002
Location: Atlanta, GA
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
The user is still having this problem, but it is board-wide. It doesn't matter what forum he starts the thread in. I suspect a broken proxy, but he says it only happens when he starts a thread. He can see other new thread just fine.

Any other ideas? Does FUDforum set an expire date on each served page?

*Edit*

He has already cleared his cache and IE is set to check for a new page every visit.

[Updated on: Thu, 23 February 2006 11:10]

Report message to a moderator

Re: Disappearing reappearing thread? [message #30407 is a reply to message #30300] Thu, 23 February 2006 11:55 Go to previous messageGo to next message
JamesS is currently offline  JamesS   United States
Messages: 275
Registered: July 2002
Location: Atlanta, GA
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
See my post about drop down navigation. When the user who is having problems viewing new threads by navigating to a forum directly from the front page does the action described in that post, he is able to see all of the threads.

Seems to confirm caching issues. I am still suspecting a bad expire header. Or at least one that IE doesn't like. Which is just about any of them.
Re: Disappearing reappearing thread? [message #30408 is a reply to message #30407] Thu, 23 February 2006 13:05 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
FUDforum only sends caching headers for anonymous users on a small number of pages where it makes sense to do.
You can disable this caching by editing core.inc __fud_cache() function and to make it always return 0.


FUDforum Core Developer
Re: Disappearing reappearing thread? [message #30417 is a reply to message #30300] Thu, 23 February 2006 13:36 Go to previous messageGo to next message
JamesS is currently offline  JamesS   United States
Messages: 275
Registered: July 2002
Location: Atlanta, GA
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
He shouldn't be anonymous though. I have URL sessions disabled, multi-host logins enabled, and cookie sessions enabled. On top of that, he is only logging in from one machine. His session should really never expire and make him show as anonymous.
Re: Disappearing reappearing thread? [message #30419 is a reply to message #30300] Thu, 23 February 2006 16:17 Go to previous messageGo to next message
JamesS is currently offline  JamesS   United States
Messages: 275
Registered: July 2002
Location: Atlanta, GA
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
The problem has now spread to not seeing posts within a thread. I assume the forum caches those pages for anonymous users too?

As far as I know, this problem is only happening when the user is at work (he hasn't bothered to check from home yet). He doesn't know if he is behind a proxy but he was able to confirm there is a firewall between him and the outside. I am willing to bet that there is also a proxy involved.

I would really rather we try to find an upstream solution so that I don't have to patch core.inc every time there is a new version available. Even if it is a switch in the administration panel that turns anonymous caching on or off. Though, that hasn't been tested to be an appropriate fix as of yet.
Re: Disappearing reappearing thread? [message #30427 is a reply to message #30419] Fri, 24 February 2006 12:46 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I am not against deploying a config switch to disable anonymous caching, but I'd like to be 100% certain that is in fact the fix for the situation you've described.

FUDforum Core Developer
Re: Disappearing reappearing thread? [message #30435 is a reply to message #30300] Fri, 24 February 2006 14:10 Go to previous messageGo to next message
JamesS is currently offline  JamesS   United States
Messages: 275
Registered: July 2002
Location: Atlanta, GA
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
I made the change to __fud_cache() yesterday. It seems to have cleared it up but I am giving it a couple days before I proclaim it so.
Re: Disappearing reappearing thread? [message #30467 is a reply to message #30435] Mon, 27 February 2006 09:17 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Ok, flag was added to the CVS.

FUDforum Core Developer
Re: Disappearing reappearing thread? [message #30473 is a reply to message #30300] Mon, 27 February 2006 12:26 Go to previous message
JamesS is currently offline  JamesS   United States
Messages: 275
Registered: July 2002
Location: Atlanta, GA
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Cool. I haven't heard of any problems since I made the switch.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Avatar appoval error
Next Topic: Topic Rating - Ignore when no rating was selected
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Mon Dec 18 00:20:18 EST 2017

Total time taken to generate the page: 0.00901 seconds