FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » General » FUDforum in eGroupWare » Help configuring NNTP on fudforum inside EGW
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
icon2.gif  Help configuring NNTP on fudforum inside EGW [message #33719] Sat, 16 September 2006 17:00 Go to next message
gogou is currently offline  gogou   Austria
Messages: 5
Registered: September 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hello everybody, we are the infrastructure group of SSETI ( http://www.sseti.net ). We are responsible for the maintenance of the infrastructure of sseti. We mainly use EGW for our projects.

We need to implement a web interface for newsgroups (nntp). We found that fudforum has that capability and we started to integrate it in EGW. Unfortunately we faced problems during the installation part.

When we try to import news from the news server, by the help of the nntp.php script (provided in the package), we are stuck.

In fact, we followed that post ( http://fudforum.org/forum/index.php?t=msg&th=3487& ) and no messages from the news server are imported to the forum.
We traced inside the nntp.php script to see where it stops. We found that this line: "require_once('/path/to/egroupware/header.inc.php');" prevent the script to continue it’s execution.

Could someone help us to solve this problem? We really want to use this nice application instead of an ugly solution Razz




Re: Help configuring NNTP on fudforum inside EGW [message #33738 is a reply to message #33719] Mon, 18 September 2006 12:33 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
That file is probably owned exclusively by the web server user, while the nntp.php is probably running under a different user account through cron or equivalent. To solve this problem you need to use the forum's "file unlock" control panel to release secure permission bits from the forum's files.

FUDforum Core Developer
Re: Help configuring NNTP on fudforum inside EGW [message #33747 is a reply to message #33738] Mon, 18 September 2006 13:59 Go to previous messageGo to next message
gogou is currently offline  gogou   Belgium
Messages: 5
Registered: September 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hello thanks a lot for your reply,

Actualy we did the unlock file from the admin panel of the forum.
And we lauch the nntp.php from the cron as webserver user.

The forum itself, I'mean the standalone version work well. It is just fudforum under EGW that give us error :s

(we are using the last version of egw under mysql 5)

As soon as the nntp things will work, we'll document our stuff and release it here Smile

[Updated on: Mon, 18 September 2006 14:01]

Report message to a moderator

Re: Help configuring NNTP on fudforum inside EGW [message #33756 is a reply to message #33747] Tue, 19 September 2006 10:41 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Does the file the header.inc.php script trying to open exist at the searched-for location?

FUDforum Core Developer
Re: Help configuring NNTP on fudforum inside EGW [message #33758 is a reply to message #33719] Tue, 19 September 2006 11:15 Go to previous messageGo to next message
gogou is currently offline  gogou   Belgium
Messages: 5
Registered: September 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
yes it exist in the main directory of egw

When I comment the line wich include that file, the script work but cannot processe the right sql querry because it don't know the egw module :s

it seem quite bisare. I'll maibe reinstall fud forum and see if it is better. Do you have a how to set fudforum perfectly for EGW ? Very Happy and well nntp how to?

Here is the step I've done till now:
Followed this thread: http://fudforum.org/forum/index.php?t=msg&th=3487&

1) Give permition to the server to the fudforum (ff) directory
2) Copy the ff source inside directory
3) Install ff from the admin menu
4) Give admin permition to use ff
5) Lauch fudforum from the top bar once
6) Symlink globals.php /opt/appsdata/domain/web/apache2/egroupware-files-test/fudforum/crc32/inclu de
to /opt/apps/egroupware/test/fudforum/setup/base/scripts/symlink_to_globals_he re
7) Be sure to "unlock" file from the forum, using the forum file unlock admin controle
8 ) Insert ( $GLOBALS['phpgw_info']['flags']['currentapp'] = 'fudforum'; ) at the top of the nntp.php file
(/opt/apps/egroupware/test/fudforum/setup/base/scripts/nntp.php)
9) Insert those line after the globals.php include (around line 39).

require_once('/path/to/egw/header.inc.php');
if (!empty($GLOBALS['phpgw_info']['server']['use_adodb'])) {
// open your own connection, as ADOdb does not export the use Link_ID
switch ($GLOBALS['phpgw_info']['server']['db_type']) {
case 'mysql':
$func = $GLOBALS['phpgw_info']['server']['db_persistent'] ? 'mysql_pconnect' : 'mysql_connect';
define('fud_sql_lnk',$func($GLOBALS['phpgw']->db->Host,
$GLOBALS['phpgw']->db->User, $GLOBALS['phpgw']->db->Password));
mysql_select_db($GLOBALS['phpgw']->db->Database,fud_sql_lnk);
break;

case 'pgsql':
$func = $GLOBALS['phpgw_info']['server']['db_persistent'] ? 'pg_pconnect' : 'pg_connect';
define('fud_sql_lnk',$func('dbname='.$GLOBALS['phpgw']->db->Database.
' host='.$GLOBALS['phpgw']->db->Host.
' user='.$GLOBALS['phpgw']->db->User.
' password='.$GLOBALS['phpgw']->db->Password));
break;

default:
die('FUDforum only supports mysql or pgsql !!!');
}
unset($func);
} else {
define('fud_sql_lnk', $GLOBALS['phpgw']->db->Link_ID);
}

10) Inside ff admin configuration, make a new syncronisation btw ff and news server
- adress news.newserver.net
- choose the right news group
- no create user
11) For the cron job use the path to /path/to/egw/open/directory/fudforum/setup/base/scripts/nntp.php
12) Edit /path/to/egw/fudforum/setup/base/src/forumsel.inc.t at line 38 change "reads" for "read_view"
13) Admin panel of ff synchronise src

[Updated on: Tue, 26 September 2006 04:17]

Report message to a moderator

Re: Help configuring NNTP on fudforum inside EGW [message #33848 is a reply to message #33758] Sat, 23 September 2006 16:02 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Are the permissions on the file allow inclusion from the CLI?

FUDforum Core Developer
Re: Help configuring NNTP on fudforum inside EGW [message #33902 is a reply to message #33848] Tue, 26 September 2006 04:07 Go to previous messageGo to next message
gogou is currently offline  gogou   United States
Messages: 5
Registered: September 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
hello, sorry I'm late to reply just that I was travelling.

what do you mean by "the permissions on the file allow inclusion from the CLI" we gave the 777 permission on nntp.php file inside the open folder (I mean the files folder)

It still don't import news.

In my precedent post, the step we passed by, can you find any error from our side ? Something we did wrong?
Re: Help configuring NNTP on fudforum inside EGW [message #33908 is a reply to message #33902] Tue, 26 September 2006 11:18 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Can you try taking out the code that loads header.inc.php and the subsequent MySQl connection bit and replace it with a basic
mysql_connect()
mysql_select_db()

calls?


FUDforum Core Developer
Re: Help configuring NNTP on fudforum inside EGW [message #35255 is a reply to message #33908] Tue, 19 December 2006 12:08 Go to previous message
gogou is currently offline  gogou   Belgium
Messages: 5
Registered: September 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Thanks for your help, I'll try this start of next week Smile got too much work for the moment.
I'll try to make it work.
Best Regards Yves Prignon
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: How to install?
Next Topic: Error 404 in eGroupware
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Oct 22 02:42:36 EDT 2017

Total time taken to generate the page: 0.00825 seconds