FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » install.php returns 20 bytes only
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
install.php returns 20 bytes only [message #34940] Sun, 26 November 2006 08:00 Go to next message
anatoliy is currently offline  anatoliy   Ukraine
Messages: 3
Registered: November 2006
Location: Ukraine
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

Hello!

install.php does not work on my server.

Fudforum: 2.7.6 (tried both zipped and not)
Apache: 2.2.3 (Unix)
PHP: 5.2.0
Linux: 2.6.14-1.1653_FC4smp #1 SMP x86_64

PHP: ./configure --with-apxs2 --with-zlib-dir=/usr --with-mysql/ --with-iconv --with-curl --with-gd --enable-ftp --enable-mbstring --enable-zend-multibyte
APACHE: ./configure --enable-proxy --enable-rewrite --enable-vhost-alias --enable-so --enable-charset-lite --with-mpm=worker
Write permissions for apache are granted.

GET /<CUT>/install.php HTTP/1.1
Host: <CUT>

HTTP/1.1 200 OK
Date: Sun, 26 Nov 2006 12:49:29 GMT
Server: Apache/2.2.3 (Unix) PHP/5.2.0
X-Powered-By: PHP/5.2.0
Content-Length: 20
Content-Type: text/html; charset=cp-1251

<?php
/* ????????
- and that's all input from install.php

Could you please help me to solve this?

Thanks!
Anatoliy.
Re: install.php returns 20 bytes only [message #34941 is a reply to message #34940] Sun, 26 November 2006 10:44 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The problem is caused by a bug inside --enable-zend-multibyte, you need to disable it and then the installer will work.

FUDforum Core Developer
Re: install.php returns 20 bytes only [message #34967 is a reply to message #34941] Tue, 28 November 2006 03:35 Go to previous messageGo to next message
anatoliy is currently offline  anatoliy   Ukraine
Messages: 3
Registered: November 2006
Location: Ukraine
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

This was helpful - I have recompiled PHP and then successully installed fudforum. Thank you.

However, after installation I've tried to create a test topic and got the following error:

(<CUT>/fud/index.php:199
<CUT>/fud/theme/default/post.php:2882
<CUT>/fud/theme/default/post.php:1727
<CUT>/fud/theme/default/post.php:4045
<CUT>/fud/index.php:1187
) 1270: Illegal mix of collations (latin1_swedish_ci,IMPLICIT), (cp1251_general_ci,COERCIBLE), (cp1251_general_ci,COERCIBLE) for operation ' IN '
Query: INSERT INTO fud26_index (word_id, msg_id) SELECT id, 1 FROM fud26_search WHERE word IN('Форум','установлен')
_GET: array ( 't' => 'post', )
_POST: array ( 'S' => '208623a3c02983067707c7313930d4e6', 'SQ' => 'dffc4e5e4c8678e565ee580652a20eef', 'submitted' => '1', 'reply_to' => '0', 'th_id' => '', 'frm_id' => '1', 'start' => '0', 'msg_id' => '0', 'pl_id' => '0', 'old_subject' => '', 'prev_loaded' => '1', 'msg_subject' => 'Форум начал свою работу', 'thr_ordertype' => '0', 'thr_orderexpiry' => '1000000000', 'msg_icon' => '', 'fnt_size' => '', 'fnt_color' => '', 'fnt_face' => '', 'msg_body' => 'Форум установлен', 'tmp_f_val' => '1', 'msg_poster_notif' => 'Y', 'msg_show_sig' => 'Y', 'btn_submit' => 1, )
Server Version: 4.1.16
[Referring Page] http://<CUT>/fud/index.php?t=post&frm_id=1&S=208623a3c02983067707c7313930d4e6

Could you please help me to fix this?

Thanks.
Re: install.php returns 20 bytes only [message #34969 is a reply to message #34967] Tue, 28 November 2006 10:54 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You need to do "show create table fud26_index" and see what the collation of the table is set to. If it is set to latin1, you need to use the "MySQL Charset Changer" admin control panel to change the tale charset to cp1251.

FUDforum Core Developer
Re: install.php returns 20 bytes only [message #34972 is a reply to message #34969] Tue, 28 November 2006 15:36 Go to previous message
anatoliy is currently offline  anatoliy   Ukraine
Messages: 3
Registered: November 2006
Location: Ukraine
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

It works now. Thanks!
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Problems intalling in install.php on line 553
Next Topic: 2.7.2 to 2.7.6, chinese to utf-8
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Dec 12 11:14:16 EST 2017

Total time taken to generate the page: 0.00750 seconds