FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Installing FUDforum from CVS
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Installing FUDforum from CVS [message #37145] Tue, 08 May 2007 17:31 Go to next message
pachanga is currently offline  pachanga   Russian Federation
Messages: 7
Registered: May 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I find upgrade scripts and installers to much magic for me and I like installing PHP software using more low-level ways: get archive, unpack it, copy this and that, edit config settings, etc.

Unfortunately(at least for me) FUDforum is shipped as a wizard and there're no traditional release tarballs(I couldn't find any). Thus I decided to go the CVS route and check out FUDforum from there.

Hence I have the question regarding database schema changes between releases. Can I safely, say, use database schema from 2.7.4 with HEAD code(which is 2.7.7RC2 atm). What is the general rule for assigning releases versions if database schema is changed? Are you changing the minor number in this case(meaning 2.7.4 schema is compatible with 2.7.7)?
Re: Installing FUDforum from CVS [message #37158 is a reply to message #37145] Wed, 09 May 2007 20:05 Go to previous messageGo to next message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The upgrade script updates the database if needed based on the table definitions inside the sql directory. Because that is the case database schema can change between any release version.

FUDforum Core Developer
Re: Installing FUDforum from CVS [message #37162 is a reply to message #37158] Thu, 10 May 2007 03:07 Go to previous messageGo to next message
pachanga is currently offline  pachanga
Messages: 7
Registered: May 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ilia wrote on Wed, 09 May 2007 20:05

The upgrade script updates the database if needed based on the table definitions inside the sql directory. Because that is the case database schema can change between any release version.


Hmm...I see. Does it mean you recommend applying all upgrade scripts one-by-one released since 2.7.4 up to 2.7.7RC2 in my case?
Re: Installing FUDforum from CVS [message #37171 is a reply to message #37162] Thu, 10 May 2007 17:55 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
No, the upgrade scripts are cumulative, the script for 2.7.7 will upgrade the forum on its own from any 2.2+ release.

FUDforum Core Developer
Re: Installing FUDforum from CVS [message #37176 is a reply to message #37171] Fri, 11 May 2007 00:42 Go to previous messageGo to next message
pachanga is currently offline  pachanga   Russian Federation
Messages: 7
Registered: May 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ilia wrote on Thu, 10 May 2007 17:55

No, the upgrade scripts are cumulative, the script for 2.7.7 will upgrade the forum on its own from any 2.2+ release.


Thanks, just one more question. The most optimal way to move from 2.7.4 to CVS HEAD in my case will be:

1) run the latest upgrade script which updates the database schema
2) checkout CVS HEAD somewhere
3) configure working copy so that it uses upgraded database
4) copy my custom themes to the working copy

?
Re: Installing FUDforum from CVS [message #37201 is a reply to message #37176] Sun, 13 May 2007 13:27 Go to previous message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
That sounds about right.

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: error 406 Not Acceptable
Next Topic: Importing forum data
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Oct 22 08:07:10 EDT 2017

Total time taken to generate the page: 0.00909 seconds