FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » User reports intermittent thread subscription bug
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
User reports intermittent thread subscription bug [message #37764] Thu, 21 June 2007 16:40 Go to next message
Astoria is currently offline  Astoria   United States
Messages: 225
Registered: April 2004
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
I received the following bug report today:
Quote:


I like the "Subscribe to topic" link at the top of threads on the boards here. Occasionally, though, when I click on the subscribe link, it kicks me to the forum home page and does not subscribe me to the topic. I go back the the original page, click the link again, and it works fine on the second try. I wonder why this happens. It seems to be random. Any ideas?



I have had the same thing happen to me when trying to jump into Admin CP, where it just sends me back to Home instead. I don't know whether the problems could be related.
Re: User reports intermittent thread subscription bug [message #37862 is a reply to message #37764] Tue, 26 June 2007 15:31 Go to previous messageGo to next message
Astoria is currently offline  Astoria   United States
Messages: 225
Registered: April 2004
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
The bug has been happening again, to the same poster.

I asked him to pass along an example link the next time it happened; here is one:

{My forum path}/index.php?t=msg&th=9131&notify=169&&opt=on&start= 0&SQ=fc3f021ed31744e6a33817f886b5f421

The only thing that looks odd to me is that there are two ampersands before "opt".

[Updated on: Tue, 26 June 2007 17:21]

Report message to a moderator

Re: User reports intermittent thread subscription bug [message #37867 is a reply to message #37862] Tue, 26 June 2007 20:40 Go to previous messageGo to next message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Can you find out what browser and cookie settings is this user using?

FUDforum Core Developer
Re: User reports intermittent thread subscription bug [message #37869 is a reply to message #37867] Wed, 27 June 2007 01:29 Go to previous messageGo to next message
Astoria is currently offline  Astoria   United States
Messages: 225
Registered: April 2004
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
He is using:
Quote:


Firefox 2.0.0 on Kubuntu Edgy. There's no restrictions on cookies from this site at present. They are kept until they expire.



When I encountered the same anomaly clicking into my Admin CP, I was using Firefox 2.0.0.4 on Ubuntu 6.06. Same cookie settings as above.

Just now when I tried to get into this thread from the forum index, it brought me to what I think must have been the old cached page from the first time I visited today -- it showed me as not logged in, and only the initial post on the thread was displayed. Hitting F5 to refresh resolved the problem, but that version of this page shouldn't have been in my cache at all since I have visited it more than once after subsequent posts were made.

Hmmm...
Re: User reports intermittent thread subscription bug [message #37881 is a reply to message #37869] Thu, 28 June 2007 18:46 Go to previous message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
When browsing as anonymous user the forum sends caching headers, it is possible your browser decided to fetch the cached version of the page in this case. If reloading the page showed you as being logged in, this is definitely a browser cache issue.

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: tags_to_html() Bug
Next Topic: SQL Error Log
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Oct 22 00:47:32 EDT 2017

Total time taken to generate the page: 0.00761 seconds