FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » How To » would re-installing the forum help?
Show: Today's Messages :: Unread Messages :: Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
would re-installing the forum help? [message #38503] Sun, 12 August 2007 02:48 Go to next message
ron4 is currently offline  ron4   Netherlands
Messages: 17
Registered: July 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hello,

I am having trouble with solving a log in issue on my forum, and still cannot log in via the forum frontend.
I am using the 2.7.7 RC2 version.

I am relatively new to FUD forum, but I was wondering whether it is possible to re-install the forum and use a datadump to get my information back on the newly installed forum?

Is it also possible to downgrade to version 2.7.6 - as that might solve the issue on my server...

If it is possible to downgrade, I also want to keep the information and members I have on the forum at this point.
So when should I take a datadump? Before I change versions from 2.7.7 to 2.7.6?
Then I have a problem with different versions of course...

Grateful for your help!

kind regards
Ron

[Updated on: Sun, 12 August 2007 02:48]

Report message to a moderator

Re: would re-installing the forum help? [message #38522 is a reply to message #38503] Sun, 12 August 2007 13:17 Go to previous messageGo to next message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
You can downgrade the forum's files by running the older upgrade script.

FUDforum Core Developer
Re: would re-installing the forum help? [message #38532 is a reply to message #38522] Mon, 13 August 2007 05:37 Go to previous messageGo to next message
ron4 is currently offline  ron4   Netherlands
Messages: 17
Registered: July 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
OK, thanks! Good to know I can downgrade if that would be necessary.

But if I downgrade will all my member, forum and post information be saved in the database and usable after downgrading?

Or will I lose everything when I use the upgrade script?

kind regards
Ron
Re: would re-installing the forum help? [message #38537 is a reply to message #38532] Mon, 13 August 2007 19:22 Go to previous messageGo to next message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
The upgrade script won't delete any information.

FUDforum Core Developer
Re: would re-installing the forum help? [message #38551 is a reply to message #38537] Tue, 14 August 2007 15:56 Go to previous messageGo to next message
ron4 is currently offline  ron4   Netherlands
Messages: 17
Registered: July 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Dear Ilia,

I ran the upgrade script to downgrade to version 2.7.6 (from 2.7.7. RC2) and now I cannot view any of my posts anymore...all my forum's don't function.

The error reads (they all look like this only with some different values for the different categories):

) 1054: Unknown column 't.tdescr' in 'field list'
Query: SELECT m.attach_cnt, m.poll_id, m.subject, m.icon, m.post_stamp, u.alias, u.id, u2.id, u2.alias, m2.id, m2.post_stamp, f.id, f.name, t.id, t.moved_to, t.root_msg_id, t.replies, t.rating, t.thread_opt, t.views, r.last_view, t.n_rating, t.tdescr FROM fud26_tv_4 tv INNER JOIN fud26_thread t ON tv.thread_id=t.id INNER JOIN fud26_msg m ON t.root_msg_id=m.id INNER JOIN fud26_msg m2 ON m2.id=t.last_post_id LEFT JOIN fud26_users u ON u.id=m.poster_id LEFT JOIN fud26_users u2 ON u2.id=m2.poster_id LEFT JOIN fud26_forum f ON f.id=t.moved_to LEFT JOIN fud26_read r ON t.id=r.thread_id AND r.user_id=2 WHERE tv.seq BETWEEN -37 AND 2 ORDER BY tv.seq DESC
_GET: array ( 't' => 'thread', 'frm_id' => '4', 'S' => '00a938ebaf89454b409fa27d59e5d48c', )
Server Version: 4.1.11-Debian_4sarge7-log
[Referring Page] http://www.DOMAIN.com/forum/index.php?S=00a938ebaf89454b409fa27d59e5d48c&am p;SQ=94576f6528ee8f01359e3b138972f78a

I have run the forum consistency after running the upgrade script.
What should I do now to show the posts?

Grateful for your help!

kind regards
Ron
Re: would re-installing the forum help? [message #38555 is a reply to message #38551] Tue, 14 August 2007 19:29 Go to previous messageGo to next message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
You need to run the consistency checker.

FUDforum Core Developer
Re: would re-installing the forum help? [message #38563 is a reply to message #38555] Wed, 15 August 2007 06:00 Go to previous messageGo to next message
ron4 is currently offline  ron4   Netherlands
Messages: 17
Registered: July 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I did that after running the script.

But the forum categories still dont work, the posts will not show..instead the error mentioned above comes up.

What should I do now?

grateful for your help,

Ron
Re: would re-installing the forum help? [message #38570 is a reply to message #38563] Wed, 15 August 2007 14:31 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
Edit the thread.php.t and remove the t.tdescr from the query.

FUDforum Core Developer
Re: would re-installing the forum help? [message #38572 is a reply to message #38570] Wed, 15 August 2007 14:51 Go to previous messageGo to next message
ron4 is currently offline  ron4   Netherlands
Messages: 17
Registered: July 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Before I edit the file name, I just wanted to make this sure:
is it the thread.php.t in the .../src folder of the forum?

In the .../theme/default folder I already see a thread.php file.

Re: would re-installing the forum help? [message #38582 is a reply to message #38572] Thu, 16 August 2007 14:53 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
yes, it is the thread.php.t inside the src/ folder.

FUDforum Core Developer
Re: would re-installing the forum help? [message #38585 is a reply to message #38582] Thu, 16 August 2007 15:49 Go to previous messageGo to next message
ron4 is currently offline  ron4   Netherlands
Messages: 17
Registered: July 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I am so sorry, but my posts still dont show. Sad

I have changed the file name in /src to 'thread.php' now and ran forum consistency.

But I could not run rebuild theme, an error occurs here too:

Missing Message entry move_msg_th_expl inside i18n/english/msg


grateful for help!

Ron



Re: would re-installing the forum help? [message #38623 is a reply to message #38585] Sun, 19 August 2007 09:25 Go to previous messageGo to next message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
You shouldn't rename the thread.php.t to thread.php, theme rebuilder will generate thread.php automatically. As far as the error you can solve it by downloading the latest msg file from the CVS.

FUDforum Core Developer
Re: would re-installing the forum help? [message #38641 is a reply to message #38623] Mon, 20 August 2007 04:10 Go to previous messageGo to next message
ron4 is currently offline  ron4   Netherlands
Messages: 17
Registered: July 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ah.. I looked at the file again but in the thread.php.t I cannot find the t.tdescr part in the query.
It is not present in that file...is there somewhere else I should look?

Sorry, but I am not quite sure how to work with CVS. How can I find the msg file there?

thanks!
Re: would re-installing the forum help? [message #38648 is a reply to message #38641] Mon, 20 August 2007 19:31 Go to previous messageGo to next message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
If you can't find it, then rebuilding of the theme should fix the error. If it does not check the threadt.php.t file as well for the t.descr string.

FUDforum Core Developer
Re: would re-installing the forum help? [message #38720 is a reply to message #38648] Thu, 23 August 2007 11:35 Go to previous message
ron4 is currently offline  ron4   Netherlands
Messages: 17
Registered: July 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
YES! Thank you, thank you so much!

After updating the msg file from CVS I was able to rebuild the theme and now the forum fully functions again. Smile

Thanks for the support, Ilia! It is much appreciated.

kind regards,
Ron
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Integrating with other php app
Next Topic: fudapi fetch Messages for my HomePage
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Oct 04 19:58:32 EDT 2022

Total time taken to generate the page: 0.01051 seconds