FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Error when deleting user (I deleted a user and got this error in 2.7.7 RC2)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Error when deleting user [message #38816] Wed, 29 August 2007 20:02 Go to next message
WITCH is currently offline  WITCH   United States
Messages: 42
Registered: December 2006
Location: Illinois USA.
Karma: 0
Member
add to buddy list
ignore all messages by this user
I installed a test installation of the newest version of Fudforum 2.7.7 RC2 to experiment with , I deleted one of the fictitious users I had assigned for testing the ranks manager and when I did I got this error:

(/home/. SERVER/ username/FUDforum/include/theme/default/db.inc:72
/home/. SERVER/username/FUDforum/include/users_adm.inc:25
/home/. SERVER/username/domain.org/adm/admuser.php:156
) 1100: Table 'fud26_mod' was not locked with LOCK TABLES
Query: DELETE FROM fud26_mod WHERE user_id IN(27)
_POST: array ( 'S' => '86746452d3ad3f054c42f90ebcfbd2f1', 'SQ' => 'df376e0f1807f59f7beb42eca13c6734', 'act' => 'del', 'f' => '0', 'usr_id' => '27', 'del_confirm' => '1', 'btn_yes' => 'Yes', )
Server Version: 5.0.24a-standard-log
[Referring Page] http://domain.org/adm/admuser.php?act=del&usr_id=27&S=86746452d3ad3 f054c42f90ebcfbd2f1&SQ=df376e0f1807f59f7beb42eca13c6734

Everything else seems to be working normally it was a totally new installation; I have reinstalled it at least twice with the same result, I even tried an upgrade to an older version and it repeats each time. It like wise appears if I restore a back up to a 2.7.6.version which was created with the RC2 version.

In looking at the fud download page I see some codes with a time line, are those patches that need to be installed in the software or are they just changes that have been made?

If they are patches that need to be installed can any one point out how to install them (in plain English) I am not seeing such instructions anywhere?

The first copy of the software I downloaded was corrupt, and would not install subsequent copies installed without incident, however I get a different error when attempting to upgrade to the RC2 from the RC1 versions Which seems to be being addressed in another thread Janrei’s thread

Unfortunately none of that helps much if we do not know how to install a patch unless there is a source for downloading the install/upgrade php with the patches already installed?


I am new to this so explain things very, very carefully!
Re: Error when deleting user [message #38839 is a reply to message #38816] Thu, 30 August 2007 18:31 Go to previous messageGo to next message
Ilia is currently offline  Ilia   
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
This is fixed in CVS.

FUDforum Core Developer
icon7.gif  Re: Error when deleting user [message #38863 is a reply to message #38839] Mon, 03 September 2007 01:19 Go to previous message
WITCH is currently offline  WITCH   United States
Messages: 42
Registered: December 2006
Location: Illinois USA.
Karma: 0
Member
add to buddy list
ignore all messages by this user
Thank you Ilia, part of the problem was I was not sure how to install the patches,But i think I have it right now!
Installed the patch and everything works a-ok!


I am new to this so explain things very, very carefully!
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Code align
Next Topic: egroupware 1.4 break the support for fudforum
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Thu Oct 19 06:56:41 EDT 2017

Total time taken to generate the page: 0.00772 seconds