FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Invalid Registration Key
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Invalid Registration Key [message #5856] Wed, 25 September 2002 14:44 Go to next message
smike is currently offline  smike   Germany
Messages: 182
Registered: April 2002
Location: Munich/Germany
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
On my 2.3.1-Forum the E-Mail-Confirmation for new Users is activated.
If a new user registrates at the forum he will receive a registration key per E-Mail.

If he clicks on the url at this E-Mail he gets an error message of the forum, that this registration key is not valid and he should check the url inside the E-Mail.
The same happens if you copy & paste the url into the browser.

The url looks like this:
http://domain-name/forum/index.php?t=emailconf&conf_key=8f19d287ce9dc8c 52eba70ba1a3347f5

I tested this several times with Mozilla 1.1 and Konqueror 3.0.3.

Users reported this error also with IE 5.5.

Bye, Mike

http://fud.prohost.org/forum/index.php?t=getfile&id=387

[Updated on: Wed, 25 September 2002 14:46]

Report message to a moderator

Re: Invalid Registration Key [message #5858 is a reply to message #5856] Wed, 25 September 2002 15:19 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I've noticed this error happening as well. I did eliminate 1 potential problem, that causes that message to appear if a user goes to email confirmation URL twice. However, there is still a rare problem when the key that is sent does not appear to be valid.
I have not yet been able to track down why that is happening as in all my tests code works properly.


FUDforum Core Developer
Re: Invalid Registration Key [message #5873 is a reply to message #5856] Thu, 26 September 2002 10:27 Go to previous messageGo to next message
BugLaden is currently offline  BugLaden   United States
Messages: 208
Registered: February 2002
Location: New Windsor, Md.
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

Don't know if this will help, but I had the same problem a few months ago. After upgrading to the next version it stopped.

I seem to recall possibly having ties to the template. Once I redid the template from scratch that might have stopped it.


-=BugLaden
CCG Workshop, LLC
Play Hobby and Strategy Games Online!
Re: Invalid Registration Key [message #5875 is a reply to message #5858] Thu, 26 September 2002 14:26 Go to previous messageGo to next message
smike is currently offline  smike   Germany
Messages: 182
Registered: April 2002
Location: Munich/Germany
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Hm, bad news!

I don't know what I should tell you in order to help to fix that problem.

The error happens if I click once, twice or several times on the link.
Re: Invalid Registration Key [message #5876 is a reply to message #5873] Thu, 26 September 2002 14:27 Go to previous messageGo to next message
smike is currently offline  smike   Germany
Messages: 182
Registered: April 2002
Location: Munich/Germany
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
BugLaden wrote on Thu, 26 September 2002 16:27

Once I redid the template from scratch that might have stopped it.

What do you mean by that?

Thanks, Mike
Re: Invalid Registration Key [message #5877 is a reply to message #5876] Thu, 26 September 2002 15:20 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
There was 1 bug that would give that message if a user accidentaly go to that URL more then once. That bug I already fixed. However, this is another bug that occurs here, which actually causes invalid confirmation keys to be sent out.

FUDforum Core Developer
Re: Invalid Registration Key [message #5897 is a reply to message #5877] Fri, 27 September 2002 06:32 Go to previous messageGo to next message
smike is currently offline  smike   Germany
Messages: 182
Registered: April 2002
Location: Munich/Germany
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Would it be helpful to tell you some of these invalid keys?
Re: Invalid Registration Key [message #5904 is a reply to message #5897] Fri, 27 September 2002 07:47 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I am afraid not, those are just random md5 sums and would yield no useful data.

FUDforum Core Developer
Re: Invalid Registration Key [message #5941 is a reply to message #5904] Fri, 27 September 2002 16:01 Go to previous messageGo to next message
smike is currently offline  smike   Germany
Messages: 182
Registered: April 2002
Location: Munich/Germany
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Ok, I'll look forward to 2.3.2.
Hope this error disappears, because allowing the registration without email-confirmation is not the way I want to use my forum.
Re: Invalid Registration Key [message #5943 is a reply to message #5941] Fri, 27 September 2002 16:39 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
At least one possible cause of this bug has been resolved, I hope to find the 2nd prior to final 2.3.2 release. This is a nasty bug to track since I've yet been unable to replicate it, but I do see it once in a while on some forums I was given admin access to.

FUDforum Core Developer
Re: Invalid Registration Key [message #5958 is a reply to message #5943] Sat, 28 September 2002 16:16 Go to previous messageGo to next message
smike is currently offline  smike   Germany
Messages: 182
Registered: April 2002
Location: Munich/Germany
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
If 2.3.2 is out, I will install and test it. Of course I tell you the results.
Re: Invalid Registration Key [message #6020 is a reply to message #5856] Mon, 30 September 2002 17:34 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
After a few hours of meticiously analyzing the log files I found the problem and have implemented the fix in the CVS.

The problem occured due the double confirmation, on the 2nd run the confirmation key would no longer be in the database resulting in an error about invalid confirmation key.
The proper solution in this bug is already in the latest CVS.


FUDforum Core Developer
Re: Invalid Registration Key [message #6037 is a reply to message #6020] Tue, 01 October 2002 07:59 Go to previous messageGo to next message
smike is currently offline  smike   Germany
Messages: 182
Registered: April 2002
Location: Munich/Germany
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Hey, very good! Surprised

But I couldn't update my server to the CVS, because it is a productive service.
How difficult is it to generate a patch for 2.3.1?
How long will it take until 2.3.2 is out? It's no problem to let the 2.3.1 running with the bug, if the new version is out during 1 or 2 weeks.

Thanks, Mike
Re: Invalid Registration Key [message #6039 is a reply to message #6037] Tue, 01 October 2002 08:18 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
2.3.2 is schedueled for later on today. So, take a look at the site later in the afternoon, the 2.3.2 is likely to be out by then.

FUDforum Core Developer
Re: Invalid Registration Key (V2.7.7) [message #40155 is a reply to message #5858] Thu, 17 January 2008 11:20 Go to previous messageGo to next message
Astoria is currently offline  Astoria   United States
Messages: 225
Registered: April 2004
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Ilia,
I have new signups getting this problem in V2.7.7. It only seems to be happening when they sign up from Yahoo email accounts. (Their accounts are showing as unconfirmed so it is not a double confirmation problem).
Re: Invalid Registration Key (V2.7.7) [message #40156 is a reply to message #40155] Thu, 17 January 2008 11:47 Go to previous messageGo to next message
Astoria is currently offline  Astoria   United States
Messages: 225
Registered: April 2004
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Additional info: Yahoo routes our emails to their "bulk" folders. The referring page url is extremely long in the failure messages I'm seeing.
Re: Invalid Registration Key (V2.7.7) [message #40160 is a reply to message #40156] Thu, 17 January 2008 15:01 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
It would seems you mail server is getting red-flagged by yahoo as a possible source of spam?

FUDforum Core Developer
Re: Invalid Registration Key (V2.7.7) [message #40162 is a reply to message #40160] Thu, 17 January 2008 18:19 Go to previous messageGo to next message
Astoria is currently offline  Astoria   United States
Messages: 225
Registered: April 2004
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Ilia wrote on Thu, 17 January 2008 12:01

It would seems you mail server is getting red-flagged by yahoo as a possible source of spam?

Possibly, but that doesn't explain why the confirmation keys sent there are generating failure errors.
Re: Invalid Registration Key (V2.7.7) [message #40164 is a reply to message #40162] Thu, 17 January 2008 20:54 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
It could be that the URL is getting truncated or word wrapped by Yahoo web mail client?

FUDforum Core Developer
Re: Invalid Registration Key (V2.7.7) [message #40166 is a reply to message #40164] Thu, 17 January 2008 22:15 Go to previous messageGo to next message
Astoria is currently offline  Astoria   United States
Messages: 225
Registered: April 2004
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Ilia wrote on Thu, 17 January 2008 17:54

It could be that the URL is getting truncated or word wrapped by Yahoo web mail client?

I asked one of the ones who had a problem and he said that it was all on one line. He forwarded me his email, and the keys look correct.
Re: Invalid Registration Key (V2.7.7) [message #40184 is a reply to message #40166] Sun, 20 January 2008 10:37 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
was the key 32 bytes in length? Did you check if his account was already active? Perhaps Yahoo mail client automatically visited the link?

FUDforum Core Developer
Re: Invalid Registration Key (V2.7.7) [message #40189 is a reply to message #40184] Sun, 20 January 2008 13:26 Go to previous message
Astoria is currently offline  Astoria   United States
Messages: 225
Registered: April 2004
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
The key was correct, and the account was not already activated.

I suggested to another Yahoo signup to copy and paste the link rather than trying to click there from the email, and his activation worked correctly. So I believe that the problem does have something to do with the length of the referral URL.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Unconfirmed user message but no such user (V2.7.7)
Next Topic: Hide thread after moving all messages
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Oct 24 02:00:44 EDT 2017

Total time taken to generate the page: 0.01043 seconds