FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Topic description sometimes vanishes (V2.7.7 + move topic patch)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Topic description sometimes vanishes (V2.7.7 + move topic patch) [message #40298] Tue, 05 February 2008 17:36 Go to next message
Astoria is currently offline  Astoria   United States
Messages: 225
Registered: April 2004
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
I seem to have an intermittent problem where the topic description disappears. It happens after more posts are made on the thread.

Today I had one that disappeared twice. I had created a topic, made a few posts when I noticed the description was gone. I edited it back into the first post again. There were a few more posts made on the thread, then I noticed the description was gone again.

The topic has not been moved since I started it, and I didn't edit the initial post (except to replace the description after it disappeared). It is in a forum that does not allow anonymous viewers.

???
Re: Topic description sometimes vanishes (V2.7.7 + move topic patch) [message #40301 is a reply to message #40298] Tue, 05 February 2008 18:32 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Does running the consistency checker fix the problem?

FUDforum Core Developer
Re: Topic description sometimes vanishes (V2.7.7 + move topic patch) [message #40302 is a reply to message #40301] Tue, 05 February 2008 18:40 Go to previous messageGo to next message
Astoria is currently offline  Astoria   United States
Messages: 225
Registered: April 2004
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Ilia wrote on Tue, 05 February 2008 15:32

Does running the consistency checker fix the problem?

I haven't tried it since doing so disables my forum for a while, but I don't see why it would. The description appears with the thread at first, and then it suddenly doesn't. How would a consistency check make it reappear? (The description is put in as part of the initial post's creation, not afterwards).

edited to add: it's as if when some later post in the thread is made it updates the description, to nothing since there is no where to enter a description in the reply form.

[Updated on: Tue, 05 February 2008 18:42]

Report message to a moderator

Re: Topic description sometimes vanishes (V2.7.7 + move topic patch) [message #40304 is a reply to message #40302] Wed, 06 February 2008 05:27 Go to previous messageGo to next message
Jaems is currently offline  Jaems   Denmark
Messages: 27
Registered: February 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
This happens to me as well. Mostly it seems to be if someone edits their post that included the topic description then the description goes away. It seems to be pretty consistent.




jnote.org
FUD version 2.7.7, Apache

[Updated on: Wed, 06 February 2008 05:27]

Report message to a moderator

Re: Topic description sometimes vanishes (V2.7.7 + move topic patch) [message #40481 is a reply to message #40298] Sun, 09 March 2008 06:55 Go to previous messageGo to next message
Ernesto is currently offline  Ernesto   Sweden
Messages: 413
Registered: August 2005
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
I have this problem as well. Haven't figured out why or how it happends though

Re: Topic description sometimes vanishes (V2.7.7 + move topic patch) [message #40509 is a reply to message #40298] Thu, 13 March 2008 08:06 Go to previous messageGo to next message
Ernesto is currently offline  Ernesto   Sweden
Messages: 413
Registered: August 2005
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Cnsistency checker does not solve the problem

Re: Topic description sometimes vanishes (V2.7.7 + move topic patch) [message #40510 is a reply to message #40509] Thu, 13 March 2008 13:24 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Was the original topic message edited?

FUDforum Core Developer
Re: Topic description sometimes vanishes (V2.7.7 + move topic patch) [message #40511 is a reply to message #40298] Thu, 13 March 2008 13:30 Go to previous messageGo to next message
Ernesto is currently offline  Ernesto   Sweden
Messages: 413
Registered: August 2005
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
I just found out the answer to that is yes

[Updated on: Thu, 13 March 2008 13:30]

Report message to a moderator

Re: Topic description sometimes vanishes (V2.7.7 + move topic patch) [message #40512 is a reply to message #40511] Thu, 13 March 2008 16:09 Go to previous messageGo to next message
Jaems is currently offline  Jaems   Denmark
Messages: 27
Registered: February 2007
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I have noticed it both when the original post was edited, and when it was not.

jnote.org
FUD version 2.7.7, Apache
Re: Topic description sometimes vanishes (V2.7.7 + move topic patch) [message #40527 is a reply to message #40512] Sun, 16 March 2008 13:42 Go to previous messageGo to next message
Astoria is currently offline  Astoria   United States
Messages: 225
Registered: April 2004
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
I just edited my topic post, without changing the description, and it did not vanish.

Then I made another post on the thread and edited it. No description is retrieved or appears for the edit. Once I had edited the second post, the topic description disappeared from the first one.

Edited to add: It occurred to me that possibly this only happened using my admin account... but I logged in with an unpriveleged account and performed the same test, and got the same result.

I notice that you set the thread description to null in line 155, and update it in the database in lines 240, 248 and 251 of imsg_edt.inc.t

[Updated on: Sun, 16 March 2008 14:25]

Report message to a moderator

Re: Topic description sometimes vanishes (V2.7.7 + move topic patch) [message #40533 is a reply to message #40527] Sun, 16 March 2008 23:44 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Fixed in CVS.

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Abusing FUD reply notification as spam source
Next Topic: visits limit? how many
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Dec 17 10:48:29 EST 2017

Total time taken to generate the page: 0.00764 seconds