FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » themes and templates
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
themes and templates [message #6460] Sat, 12 October 2002 14:25 Go to next message
fjrohlf is currently offline  fjrohlf   United States
Messages: 82
Registered: February 2002
Karma: 0
Member
add to buddy list
ignore all messages by this user
May not be a 'bug' but a corruption of some of my files, but I need to know how to fix it.

I just upgraded to 2.3.2. Seems to work fine except that when I click on the admin control panel and go down to 'Theme Manager' the language drop down box is very narrow and it empty. The locale edit box has the following in it:
Quote:

<? echo htmlspecialchars($thm_locale?$thm_locale:'english'); ?>


In the table listing the various themes, it has the following in the Locale column for each theme:
Quote:

<? echo htmlspecialchars($thm_lo


If I click on Template Editor or the Message Editor then I get the following in the window:
Quote:

$de"; } echo ''; closedir($dp); ?>



There is also a drop-down box with the word "default" in it and a button that says "Edit". If I click the button then the screen blinks but still displays the same information.

Thanks for your help.


Jim
Re: themes and templates [message #6464 is a reply to message #6460] Sun, 13 October 2002 02:26 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Looks like a file corruption to me. You can fix it by running the upgrade script for the 2nd time.

FUDforum Core Developer
Re: themes and templates [message #6466 is a reply to message #6464] Sun, 13 October 2002 08:43 Go to previous messageGo to next message
fjrohlf is currently offline  fjrohlf   United States
Messages: 82
Registered: February 2002
Karma: 0
Member
add to buddy list
ignore all messages by this user
I ran the upgrade script again and got the following messages:
Quote:

Beginning the file upgrade process
File Upgrade Complete
Any changed files were backed up to: "/var/www/forumdata/errors/.backup/"

Beginning SQL Upgrades
SQL Upgrade Complete

Adding GLOBAL Variables
Finished Adding GLOBAL Variables
DATADIR: /var/www/forumdata/
Compiling default
Compiling morphlayout
Unable to open (/var/www/forumdata/thm/default/i18n//charset) in (/var/www/html/forum)

Warning: fopen("/var/www/forumdata/thm/default/i18n//msg", "rb") - No such file or directory in /var/www/forumdata/include/compiler.inc on line 372

Warning: fgets(): supplied argument is not a valid File-Handle resource in /var/www/forumdata/include/compiler.inc on line 374

Warning: fclose(): supplied argument is not a valid File-Handle resource in /var/www/forumdata/include/compiler.inc on line 390
Missing Message entry postcheck_subj_needed inside i18n//msg



The "morphlayout" mentioned is the custom layout I had used previously. I then ran the consistency checker and it seemed happy. I re-enabled the forum and went to the theme manager and it was still corrupted.

I then tried to delete the morphlayout theme from the Theme Manager and it gave the following error message:
Quote:

(rid=1&S=c973ca5945a253f672623a7b2aa06d5d&del=4&rand=1025991841 ) 1064: You have an error in your SQL syntax near '' at line 1
Query: DELETE FROM fud_themes WHERE id=
Server Version: 3.23.52
[Referring Page] http://morph.bio.sunysb.edu/forum/adm/admthemes.php?rid=1&S=c973ca5945a 253f672623a7b2aa06d5d


I then went down the control panel clicking on every choice and found that they all seemed to display ok except the smiley manager which was also corrupted. I also did a datadump and that worked with no error messages.

I hope there is a simple fix!


Jim

[Updated on: Sun, 13 October 2002 09:04]

Report message to a moderator

Re: themes and templates [message #6501 is a reply to message #6466] Tue, 15 October 2002 07:38 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
From the looks of it your custom theme was corrupted by something. Hence the problems you are seeing. At this point which forum version are you running and does it work (you mentioned no errors after a datadump)?

FUDforum Core Developer
Re: themes and templates [message #6595 is a reply to message #6501] Thu, 17 October 2002 18:42 Go to previous messageGo to next message
fjrohlf is currently offline  fjrohlf   United States
Messages: 82
Registered: February 2002
Karma: 0
Member
add to buddy list
ignore all messages by this user
I am running FUD version 2.3.2. It is working but I would like to restore the orginal header image etc.

Jim
Re: themes and templates [message #6597 is a reply to message #6595] Thu, 17 October 2002 18:49 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Which template contained this header image? Just copy it from there into the new template.

FUDforum Core Developer
Re: themes and templates [message #6601 is a reply to message #6597] Fri, 18 October 2002 01:16 Go to previous messageGo to next message
fjrohlf is currently offline  fjrohlf   United States
Messages: 82
Registered: February 2002
Karma: 0
Member
add to buddy list
ignore all messages by this user
But the forum software is corrupted. I need to know what FUD forum files need to be replaced before I worry about inserting my header image.

Jim
Re: themes and templates [message #6611 is a reply to message #6601] Fri, 18 October 2002 09:57 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Well, then don't replace the files, merely the parts with your header from old theme to the new one.

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: F.A.Q. topics not working in 2.3.2 (Stable)
Next Topic: Forum deleted - Permissions still there
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Oct 21 13:53:58 EDT 2017

Total time taken to generate the page: 0.00770 seconds