FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » email subscriptions  () 1 Vote
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
email subscriptions [message #6580] Thu, 17 October 2002 14:31 Go to next message
zapal   Poland
Messages: 68
Registered: October 2002
Location: Poland
Karma: 0
Member
add to buddy list
ignore all messages by this user
I noticed an error in sending notifications about new messages in subscribed topics. In short - it doesn't send those emails.

It all started to happen after upgrade from 2.3.2RC2 to 2,3,2 (it also happens in newer versions).

Longer description - after an upgrade there was no configuration changed (it was revised, but not changed). Notifications emails about thread which were started before an upgrade are being correctly received.
But notifications about threads started aftert the upgrade doesn't reach the server. In subscribed threads I can see all threads I'm interested in.

Unfortunately I can't figure out which file+line contains a bug (or maybe it's due to some changes in database tables?).
Re: email subscriptions [message #6593 is a reply to message #6580] Thu, 17 October 2002 18:22 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Could you do a small test for me to see if there trully is a bug.
On the front page click on the 'mark all messages read' link, then as another user post a message in a thread you are subscribed to. Let me know the results of this test.


FUDforum Core Developer
Odp:Re: email subscriptions [message #6603 is a reply to message #6593] Fri, 18 October 2002 02:31 Go to previous messageGo to next message
zapal   Poland
Messages: 68
Registered: October 2002
Location: Poland
Karma: 0
Member
add to buddy list
ignore all messages by this user
I tested on fud installed on local machine.

Results: emails to some users are always sent (and they reach destination server), but for others not.

All of my tested users used the same account for mailbox (I only used different hostname for mailserver). All of the domains I used are correct (they are handled by the same machine as fud wad installed on).

I also tested this on fud installed somewhere else (not by me) - and the same is happening. Several users from that forum noticed that they don't get notifications.

Error log in admin panel is empty.

Any suggestions?
Re: Odp:Re: email subscriptions [message #6607 is a reply to message #6603] Fri, 18 October 2002 07:57 Go to previous messageGo to next message
smike is currently offline  smike   Germany
Messages: 182
Registered: April 2002
Location: Munich/Germany
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
zapal schrieb am Fre, 18 Oktober 2002 08:31

I also tested this on fud installed somewhere else (not by me) - and the same is happening. Several users from that forum noticed that they don't get notifications.
I noticed the same behavior. Perhaps I can help testing, too.

Bye, Mike
Re: Odp:Re: email subscriptions [message #6616 is a reply to message #6607] Fri, 18 October 2002 10:04 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The users who do not recieve the emails, can you send them emails via PHP @ all?

FUDforum Core Developer
Odp:Re: Odp:Re: email subscriptions [message #6618 is a reply to message #6616] Fri, 18 October 2002 10:58 Go to previous messageGo to next message
zapal   Poland
Messages: 68
Registered: October 2002
Location: Poland
Karma: 0
Member
add to buddy list
ignore all messages by this user
Yes, all of the emails sent by fud's send email panel go well.
Re: Odp:Re: Odp:Re: email subscriptions [message #6619 is a reply to message #6618] Fri, 18 October 2002 11:12 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Then I'd say there is no bug.

FUDforum Core Developer
Re: Odp:Re: Odp:Re: email subscriptions [message #6628 is a reply to message #6618] Fri, 18 October 2002 18:03 Go to previous messageGo to next message
smike is currently offline  smike   Germany
Messages: 182
Registered: April 2002
Location: Munich/Germany
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
zapal schrieb am Fre, 18 Oktober 2002 16:58

Yes, all of the emails sent by fud's send email panel go well.
I can verify this on my system, too.
Re: Odp:Re: Odp:Re: email subscriptions [message #6798 is a reply to message #6628] Thu, 24 October 2002 17:03 Go to previous messageGo to next message
patrick is currently offline  patrick   Netherlands
Messages: 103
Registered: September 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
I've noticed the same problem since installing 2.3.3.

No notification was send to myself about a post within a forum to which I am subscribed.

For you information:

  1. I logged-in this morning at 10Am. When I logged-out there where no new messages.
  2. A message was posted at 1Pm.
  3. I logged-in again at 10Pm and noticed the new message.
  4. I did not receive any notification.


Re: Odp:Re: Odp:Re: email subscriptions [message #6800 is a reply to message #6798] Thu, 24 October 2002 17:13 Go to previous messageGo to next message
Olliver   Germany
Messages: 443
Registered: March 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Exactly the same problem with the forum I maintain. Some people already complained that since upgrading they don't receive any notifications anymore. Although I didn't touch the configuration at all. already wrote about it in a different thread but thought it wouldn't do any harm to repeat the story Wink. Just hoping the feature's behavior may change again one day Wink
bye
Ken
Re: Odp:Re: Odp:Re: email subscriptions [message #6803 is a reply to message #6800] Thu, 24 October 2002 17:24 Go to previous messageGo to next message
patrick is currently offline  patrick   Netherlands
Messages: 103
Registered: September 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

Good to know that I'm not the only person at this moment. Wink

Cheers, Patrick
Re: email subscriptions [message #6810 is a reply to message #6803] Thu, 24 October 2002 23:49 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Hmm... could you tell me if this problem began after 2.3.3 upgrade or did it occur earlier on 2.3.2 releases as well?

I am planning to make a 2.3.4 release tomorrow (Friday) and if this is indeed a problem I'd like to have it cleared up before the release is made.


FUDforum Core Developer

[Updated on: Thu, 24 October 2002 23:49]

Report message to a moderator

Re: email subscriptions [message #6813 is a reply to message #6810] Fri, 25 October 2002 02:00 Go to previous messageGo to next message
zapal   Poland
Messages: 68
Registered: October 2002
Location: Poland
Karma: 0
Member
add to buddy list
ignore all messages by this user
The problem began after an upgrade to 2.3.2 (from 2.3.2RC2). On one forum the version wasn't changed any more (yet).

On the other forum I've upgraded to the newest version 2.3.3 and it looks as if it worked. But this is on my localhost.

On this (support) forum I have the same problem. It started I think after 2.3.2 was released. I don't receive _any_ notifications.
I tried to check if this forum can send me a mail via mail panel, but it's blocked.
Re: email subscriptions [message #6817 is a reply to message #6810] Fri, 25 October 2002 03:47 Go to previous messageGo to next message
patrick is currently offline  patrick   Netherlands
Messages: 103
Registered: September 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Protttos,

I've noticed it since 2.3.3, therefor I think the problem started with the 2.3.3 release.

The issue seems not to be very consistent, since there are still notifications being sent.
I'll let you know if I'm able to reproduce this issue.

Cheers, Patrick
Re: email subscriptions [message #6839 is a reply to message #6580] Fri, 25 October 2002 12:24 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
2.3.4RC is out, I've put some fixes that will hopefuly address this issue. Please try it and let me know how it works out.

FUDforum Core Developer
Re: email subscriptions [message #6870 is a reply to message #6839] Sun, 27 October 2002 04:58 Go to previous messageGo to next message
zapal   Poland
Messages: 68
Registered: October 2002
Location: Poland
Karma: 0
Member
add to buddy list
ignore all messages by this user
I tested it with this support forum.

I posted a message on test forum. Then I logged out and as anonymous posted a reply. I received a notification and removed it (I didn't use a link given in this mail). Then I read this reply as 'zapal' and then again logged out and posted second reply, to which I didn't receive a notification. As 'zapal' I marked all msgs as read, and as anonymous posted another reply. Still no notification.

So I created new thread as 'zapal', and replied as anonymous. I received notification, and read the reply by using link given in a mail. After that I posted second reply and haven't received a notification so far.
Re: email subscriptions [message #6882 is a reply to message #6870] Sun, 27 October 2002 16:15 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Finally found the real cause of the problem and it has been fixed.
Unless there are any major issues that appear between now and Monday, I'll release 2.3.4 on Monday, which will have a fix for this problem.


FUDforum Core Developer
Re: email subscriptions [message #6914 is a reply to message #6882] Mon, 28 October 2002 12:40 Go to previous messageGo to next message
zapal   Poland
Messages: 68
Registered: October 2002
Location: Poland
Karma: 0
Member
add to buddy list
ignore all messages by this user
Actually there's another one connected with notifications.
Let's say we've got message A, which is posted by other user (and I'm subscribed to this topic). I get the notification (which works quite well) and use link provided in this mail to go to the site.
I get the first message from the whole topic and see, that message A is marked as read.

Anyway, there's not too much time between Sunday 22:15 and Monday Laughing.
Re: email subscriptions [message #6915 is a reply to message #6914] Mon, 28 October 2002 12:45 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Say what? I fail to see the problem.

FUDforum Core Developer
Re: email subscriptions [message #6921 is a reply to message #6915] Mon, 28 October 2002 13:06 Go to previous message
zapal   Poland
Messages: 68
Registered: October 2002
Location: Poland
Karma: 0
Member
add to buddy list
ignore all messages by this user
You're right. Maybe it was the issue with older version. I checked it and it looks good. Sorry for that.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Empty list of colors
Next Topic: Everyone's a moderator?
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Fri Oct 20 03:12:03 EDT 2017

Total time taken to generate the page: 0.00958 seconds