FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Forum dies after some accounts... (...are denied membership in the "Account Approval" interface.)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Forum dies after some accounts... [message #40643] Mon, 31 March 2008 20:43 Go to next message
dfgngirl is currently offline  dfgngirl   United States
Messages: 87
Registered: December 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user

Forum dies after some accounts are denied membership in the "Account Approval" interface. It doesn't happen all the time, but some times when we click "Delete Account" on the membership approval interface, the forum stops responding - times out with a white page. Restarting apache gets the forum going again.

However, when the forum dies, apache static pages are still going strong.

What should I look for to trouble-shoot this?

We have the latest release on Ubuntu 7.04.

Thanks.
Re: Forum dies after some accounts... [message #40668 is a reply to message #40643] Tue, 01 April 2008 14:22 Go to previous messageGo to next message
Ilia is currently offline  Ilia   United States
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Have you checked your PHP and apache error logs for details?

FUDforum Core Developer
Re: Forum dies after some accounts... [message #40678 is a reply to message #40643] Wed, 02 April 2008 12:52 Go to previous messageGo to next message
dfgngirl is currently offline  dfgngirl   United States
Messages: 87
Registered: December 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user

Apache shows nothing remarkable. I can't seem to find a php error log anywhere.
Re: Forum dies after some accounts... [message #40681 is a reply to message #40643] Wed, 02 April 2008 17:03 Go to previous messageGo to next message
dfgngirl is currently offline  dfgngirl   United States
Messages: 87
Registered: December 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user

OK, I figured out how to log php, and this is the result of trying to delete an accout:

[Wed Apr 02 16:56:56 2008] [error] [client 71.21.96.41] PHP Fatal error:  Call to undefined function pmsg_del() in /home/forum/dataroot/include/users_adm.inc on line 47, referer: http://forum.com/adm/admaccapr.php?S=77bbac9e6375671f046bfb2606e6fbea&SQ=a2d063fe0ba18a4d275f3483ec3b9955
Re: Forum dies after some accounts... [message #40689 is a reply to message #40681] Thu, 03 April 2008 13:58 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Have you tried upgrading to the latest FUDforum version?

FUDforum Core Developer
Re: Forum dies after some accounts... [message #40802 is a reply to message #40643] Sun, 13 April 2008 12:03 Go to previous messageGo to next message
dfgngirl is currently offline  dfgngirl   United States
Messages: 87
Registered: December 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user

Our forum reads "Powered by: FUDforum 2.7.7." Isn't that the latest version?
Re: Forum dies after some accounts... [message #40816 is a reply to message #40802] Mon, 14 April 2008 16:08 Go to previous messageGo to next message
Ilia is currently offline  Ilia   United States
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Yes, that is the latest version. you need to apply the following patch:

http://cvs.prohost.org/c/index.cgi/FUDforum/chngview?cn=11811


FUDforum Core Developer
Re: Forum dies after some accounts... [message #40819 is a reply to message #40643] Mon, 14 April 2008 17:54 Go to previous message
dfgngirl is currently offline  dfgngirl   United States
Messages: 87
Registered: December 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user

Thanks!

Though...Rolling Eyes...I dunno how to do that.

But "upgrading" to the newest version will fix this? I'll be trying that anyways due to restore glitch in other thread.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Attached images
Next Topic: JavaScript Broken after Import forum data
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Mon Oct 16 22:05:40 EDT 2017

Total time taken to generate the page: 0.00737 seconds