FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Upgrade Issue: Members List Blank
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Upgrade Issue: Members List Blank [message #40698] Sat, 05 April 2008 13:05 Go to next message
treebeard is currently offline  treebeard   
Messages: 44
Registered: April 2004
Location: Huge Universe
Karma: 0
Member
add to buddy list
ignore all messages by this user
I'm in the process of upgrading our PSW forums to 2.7.7 (we were at 2.7.4). Everything appears to have gone well once I ran the upgrade.php script and repopulated customized templates (e.g., to include our custom top, side, and footer elements). However, when I click on the "Members" link, I get a blank page. Generaged html:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META content="text/html; charset=windows-1252" http-equiv=Content-Type></HEAD>
<BODY></BODY></HTML>

The two forums that I've upgraded so far are churchsound.prosoundweb.com and networkforums.prosoundweb.com. I don't want to upgrade our other forums (especially srforums.prosoundweb.com and recforums.prosoundweb.com, which in aggregate draw over 2 million pageviews/month) if this is an issue.

FWIW, the Admin Control panel is set to Enable Members Search with a setting of 40 members per page.

TIA!
Re: Upgrade Issue: Members List Blank [message #40699 is a reply to message #40698] Sun, 06 April 2008 10:29 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Have you checked the PHP error log page? Also have you rebuild the theme?

FUDforum Core Developer
Re: Upgrade Issue: Members List Blank [message #40703 is a reply to message #40699] Sun, 06 April 2008 13:53 Go to previous messageGo to next message
treebeard is currently offline  treebeard   
Messages: 44
Registered: April 2004
Location: Huge Universe
Karma: 0
Member
add to buddy list
ignore all messages by this user
Rebuilding the theme didn't help; I had already tried that. What would I look for in the error logs? Nothing jumps out at me.
Re: Upgrade Issue: Members List Blank [message #40710 is a reply to message #40703] Mon, 07 April 2008 13:03 Go to previous messageGo to next message
treebeard is currently offline  treebeard   
Messages: 44
Registered: April 2004
Location: Huge Universe
Karma: 0
Member
add to buddy list
ignore all messages by this user
Any ideas on how to get the members list page back?
Re: Upgrade Issue: Members List Blank [message #40711 is a reply to message #40710] Mon, 07 April 2008 19:56 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Have you checked the member list options in the admin panel? perhaps it is disabled?

FUDforum Core Developer
Re: Upgrade Issue: Members List Blank [message #40712 is a reply to message #40711] Mon, 07 April 2008 20:13 Go to previous messageGo to next message
treebeard is currently offline  treebeard   
Messages: 44
Registered: April 2004
Location: Huge Universe
Karma: 0
Member
add to buddy list
ignore all messages by this user
Member Search:
Enable/disable the forum member search. Enabled

Members Per Page:
The number of members to show per page in the search result. 40

Is there another setting elsewhere? I searched for "member" and "list" but could not find any other options in the Admin.

Thanks!
Re: Upgrade Issue: Members List Blank [message #40729 is a reply to message #40712] Wed, 09 April 2008 12:01 Go to previous messageGo to next message
treebeard is currently offline  treebeard   
Messages: 44
Registered: April 2004
Location: Huge Universe
Karma: 0
Member
add to buddy list
ignore all messages by this user
Still stumped! Sad
Re: Upgrade Issue: Members List Blank [message #40733 is a reply to message #40712] Wed, 09 April 2008 19:21 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Are there any errors in the PHP error log or the Apache one?

if not make sure your error logging is enabled.


FUDforum Core Developer
Re: Upgrade Issue: Members List Blank [message #40737 is a reply to message #40733] Wed, 09 April 2008 20:41 Go to previous messageGo to next message
treebeard is currently offline  treebeard   
Messages: 44
Registered: April 2004
Location: Huge Universe
Karma: 0
Member
add to buddy list
ignore all messages by this user
I'm not sure what sort of error to look for. Here's the last several errors in the Error Log Viewer:

Wed Apr 9 7:40:12 GMT 2008 (/home/www/forums/churchsndforums/index.php:19
) :
Query: Initiating mysql_connect
Server Version: Unknown
Wed Apr 9 7:41:02 GMT 2008 (/home/www/forums/churchsndforums/index.php:19
) :
Query: Initiating mysql_connect
Server Version: Unknown
Wed Apr 9 7:41:24 GMT 2008 (/home/www/forums/churchsndforums/index.php:19
) :
Query: Initiating mysql_connect
Server Version: Unknown
Wed Apr 9 7:41:39 GMT 2008 (/home/www/forums/churchsndforums/index.php:19
) :
Query: Initiating mysql_connect
Server Version: Unknown
Wed Apr 9 7:41:57 GMT 2008 (/home/www/forums/churchsndforums/index.php:19
) :
Query: Initiating mysql_connect
Server Version: Unknown
Wed Apr 9 7:42:06 GMT 2008 (/home/www/forums/churchsndforums/index.php:19
) :
Query: Initiating mysql_connect
Server Version: Unknown
Wed Apr 9 7:42:15 GMT 2008 (/home/www/forums/churchsndforums/index.php:19
) :
Query: Initiating mysql_connect
Server Version: Unknown
Wed Apr 9 7:42:17 GMT 2008 (/home/www/forums/churchsndforums/index.php:19
) :
Query: Initiating mysql_connect
Server Version: Unknown
Wed Apr 9 7:42:36 GMT 2008 (/home/www/forums/churchsndforums/index.php:19
) :
Query: Initiating mysql_connect
Server Version: Unknown
Wed Apr 9 7:43:01 GMT 2008 (/home/www/forums/churchsndforums/index.php:19
) :
Query: Initiating mysql_connect
Server Version: Unknown
Wed Apr 9 7:44:16 GMT 2008 (/home/www/forums/churchsndforums/index.php:19
) :
Query: Initiating mysql_connect
Server Version: Unknown
Wed Apr 9 7:45:16 GMT 2008 (/home/www/forums/churchsndforums/index.php:19
) :
Query: Initiating mysql_connect
Server Version: Unknown
Wed Apr 9 7:45:30 GMT 2008 (/home/www/forums/churchsndforums/rdf.php:33
) :
Query: Initiating mysql_connect
_GET: array ( 'mode' => 'm', 'l' => '1', 'basic' => '1', 'frm' => '12', 'n' => '25', )
Server Version: Unknown
Wed Apr 9 7:46:05 GMT 2008 (/home/www/forums/churchsndforums/index.php:19
) :
Query: Initiating mysql_connect
Server Version: Unknown
Re: Upgrade Issue: Members List Blank [message #40738 is a reply to message #40737] Wed, 09 April 2008 20:46 Go to previous messageGo to next message
treebeard is currently offline  treebeard   
Messages: 44
Registered: April 2004
Location: Huge Universe
Karma: 0
Member
add to buddy list
ignore all messages by this user
I don't see anything in the apache error logs:

[Wed Apr 09 12:12:01 2008] [notice] SIGHUP received. Attempting to restart
[Wed Apr 09 12:12:01 2008] [notice] Digest: generating secret for digest authentication ...
[Wed Apr 09 12:12:01 2008] [notice] Digest: done
[Wed Apr 09 12:12:01 2008] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Wed Apr 09 12:12:01 2008] [notice] LDAP: SSL support unavailable
[Wed Apr 09 12:12:02 2008] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
[Wed Apr 09 12:12:03 2008] [notice] Apache/2.0.52 (Red Hat) configured -- resuming normal operations
[Wed Apr 09 12:14:15 2008] [notice] SIGHUP received. Attempting to restart
[Wed Apr 09 12:14:15 2008] [notice] Digest: generating secret for digest authentication ...
[Wed Apr 09 12:14:15 2008] [notice] Digest: done
[Wed Apr 09 12:14:15 2008] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Wed Apr 09 12:14:15 2008] [notice] LDAP: SSL support unavailable
[Wed Apr 09 12:14:15 2008] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
[Wed Apr 09 12:14:16 2008] [notice] Apache/2.0.52 (Red Hat) configured -- resuming normal operations
Re: Upgrade Issue: Members List Blank [message #40762 is a reply to message #40738] Thu, 10 April 2008 18:19 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
From the error it looks like an apache error page, since forum never sets windows-1252 charset. You need to look at the php's error log (look inside php.ini or phpinfo() for its location).

FUDforum Core Developer
Re: Upgrade Issue: Members List Blank [message #40788 is a reply to message #40762] Sat, 12 April 2008 12:39 Go to previous messageGo to next message
treebeard is currently offline  treebeard   
Messages: 44
Registered: April 2004
Location: Huge Universe
Karma: 0
Member
add to buddy list
ignore all messages by this user
Ilia wrote on Thu, 10 April 2008 18:19

From the error it looks like an apache error page, since forum never sets windows-1252 charset. You need to look at the php's error log (look inside php.ini or phpinfo() for its location).


Could this be what I'm looking for?

[client 41.207.27.39] PHP Fatal error: Call to undefined function: draw_user_link() in /home/www/forums/churchsndforums/theme/path_info/finduser.php on line 244, referer: http://churchsound.prosoundweb.com/index.php?/ml/0f33fae77188e94aa3f46c494d c76e29/?&S=0f33fae77188e94aa3f46c494dc76e29

(Edit) OK, to check further, I temporarily turned display errors ON, and this is the error that I got when I tried to load the members list:

Fatal error: Call to undefined function: draw_user_link() in /home/www/forums/networkforums/theme/path_info/finduser.php on line 244

which matches the error above. So, what do I do about this error?

Thanks!

[Updated on: Sat, 12 April 2008 13:40]

Report message to a moderator

Re: Upgrade Issue: Members List Blank [message #40800 is a reply to message #40788] Sun, 13 April 2008 08:22 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Yes, that would be a cause of the problem, its a parse error, which will stop page's execution.

Apply this patch:

http://cvs.prohost.org/c/index.cgi/FUDforum/filediff?f=install/forum_data/t hm/path_info/tmpl/finduser.tmpl&v1=1.20&v2=1.21


and rebuild the theme


FUDforum Core Developer
Re: Upgrade Issue: Members List Blank [message #40804 is a reply to message #40800] Sun, 13 April 2008 13:17 Go to previous messageGo to next message
treebeard is currently offline  treebeard   
Messages: 44
Registered: April 2004
Location: Huge Universe
Karma: 0
Member
add to buddy list
ignore all messages by this user
Ilia wrote on Sun, 13 April 2008 08:22

Yes, that would be a cause of the problem, its a parse error, which will stop page's execution.

Apply this patch:

http://cvs.prohost.org/c/index.cgi/FUDforum/filediff?f=install/forum_data/t hm/path_info/tmpl/finduser.tmpl&v1=1.20&v2=1.21


and rebuild the theme


Well, I must be getting closer, but not there yet. I opened up finduser.tmpl and replaced this:

{ROOT}?t=finduser&amp;usr_login={VAR-URL: usr_login}&amp;us={IF: isset($_GET['us']) && !($_GET['us'] % 2)}1{ELSE}2{ENDI}&amp;btn_submit=Find&amp;{DEF: _rsid}

with this from the patch link you gave:

{ROOT}/ml/{IF: isset($_GET['us']) && !($_GET['us'] % 2)}3{ELSE}4{ENDI}/0/{VAR: ul}/{DEF: _rsid}

and rebuilt the theme, but the members list page still failed to load. Perhaps I don't quite get what you mean by "apply this patch"?

Thanks!
Re: Upgrade Issue: Members List Blank [message #40813 is a reply to message #40804] Mon, 14 April 2008 15:57 Go to previous messageGo to next message
Ilia is currently offline  Ilia   United States
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Replacing lines won't do anything.

You need to add what patch adds, which is

{REF: ulink.tmpl} line.


FUDforum Core Developer
Re: Upgrade Issue: Members List Blank [message #40820 is a reply to message #40698] Mon, 14 April 2008 18:21 Go to previous messageGo to next message
treebeard is currently offline  treebeard   
Messages: 44
Registered: April 2004
Location: Huge Universe
Karma: 0
Member
add to buddy list
ignore all messages by this user
Sorry that I'm such a dunderhead, Embarassed but I don't understand what I'm supposed to add or where or how to add it. I'm sure this is simple, but I'm simply lost. where and how do I add the {REF: ulink.tmpl} line?

Thanks!
Re: Upgrade Issue: Members List Blank [message #40824 is a reply to message #40820] Tue, 15 April 2008 13:07 Go to previous messageGo to next message
Ilia is currently offline  Ilia   United States
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The simplest solution would be to download latest file from CVS and replace yours with it and then rebuild the theme...

FUDforum Core Developer
Re: Upgrade Issue: Members List Blank [message #40826 is a reply to message #40824] Tue, 15 April 2008 19:43 Go to previous messageGo to next message
treebeard is currently offline  treebeard   
Messages: 44
Registered: April 2004
Location: Huge Universe
Karma: 0
Member
add to buddy list
ignore all messages by this user
I downloaded the patch from CVS ( http://cvs.prohost.org/c/index.cgi/FUDforum/rlog?f=install/forum_data/thm/p ath_info/tmpl/finduser.tmpl - v. 1.21) and replaced the old finduser.tmpl with this new one, but I got this error when I rebuilt the theme:

Undefined template: "finduser_title" inside "finduser.php.t"

Note: I replaced the v. 1.20 finduser.tmpl in both ../thm/path_info/tmpl and ..//thm/default/tmpl with v. 1.21.

Everything else in the forum appears to work correctly, but the members list is still blank. This is in our Networking forum: http://networkforums.prosoundweb.com/

We have over 20,000 users driving 2.5 million pageviews/month, so I would really like to resolve this! So far I have only upgraded the Network and Church Sound forums; the SR and REP forums (which comprise 90% of our memberships) I've left at 2.7.4 for now.
Re: Upgrade Issue: Members List Blank [message #40836 is a reply to message #40826] Wed, 16 April 2008 13:35 Go to previous messageGo to next message
Ilia is currently offline  Ilia   United States
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Without rebuilding of the theme the changed file won't take into effect.

FUDforum Core Developer
Re: Upgrade Issue: Members List Blank [message #40837 is a reply to message #40836] Wed, 16 April 2008 13:42 Go to previous messageGo to next message
treebeard is currently offline  treebeard   
Messages: 44
Registered: April 2004
Location: Huge Universe
Karma: 0
Member
add to buddy list
ignore all messages by this user
I did rebuild the theme:

Quote:

I got this error when I rebuilt the theme:
Re: Upgrade Issue: Members List Blank [message #40847 is a reply to message #40837] Thu, 17 April 2008 13:50 Go to previous messageGo to next message
Ilia is currently offline  Ilia   United States
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
are you seeing the same php error as before despite the added {REF} ?

FUDforum Core Developer
Re: Upgrade Issue: Members List Blank [message #40849 is a reply to message #40698] Thu, 17 April 2008 16:15 Go to previous messageGo to next message
treebeard is currently offline  treebeard   
Messages: 44
Registered: April 2004
Location: Huge Universe
Karma: 0
Member
add to buddy list
ignore all messages by this user
Yes, the same php error returned when the Members page is loaded, which is:

Fatal error: Call to undefined function: draw_user_link() in /home/www/forums/networkforums/theme/path_info/finduser.php on line 244


Thanks!
Re: Upgrade Issue: Members List Blank [message #40856 is a reply to message #40849] Sun, 20 April 2008 09:53 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The reasons it would give you such an error is because the template change has not been picked up... Are you using a default or custom theme?

FUDforum Core Developer
Re: Upgrade Issue: Members List Blank [message #40898 is a reply to message #40698] Sat, 26 April 2008 11:57 Go to previous messageGo to next message
treebeard is currently offline  treebeard   
Messages: 44
Registered: April 2004
Location: Huge Universe
Karma: 0
Member
add to buddy list
ignore all messages by this user
Just got back from a week's vacation, sorry for the delay in reply. We're using path_info theme. What's custom is there are three additional files which "wrap" the forum: top, side, and footer, which we've been using since we first installed FUD years ago. We've been through several updates before, and never had a conflict with these files. Ilia, you'll probably recall that a couple of years ago we had to split out a shared user table into separate user tables for each forum.
Re: Upgrade Issue: Members List Blank [message #40922 is a reply to message #40898] Mon, 28 April 2008 17:52 Go to previous messageGo to next message
Ilia is currently offline  Ilia   United States
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Well, the patch I've posted needs to be applied to both the finduser.tmpl in the path_info directory and the one in the default directory. once that is done, rebuild the theme...

FUDforum Core Developer
Re: Upgrade Issue: Members List Blank [message #40936 is a reply to message #40698] Tue, 29 April 2008 18:58 Go to previous messageGo to next message
treebeard is currently offline  treebeard   
Messages: 44
Registered: April 2004
Location: Huge Universe
Karma: 0
Member
add to buddy list
ignore all messages by this user
Just did so again, replacing the finduser.tmpl in both the default and path_info dir's and rebuilding the theme (rebuilt both default and path_info themes fwiw, even though the default theme is not being used). Still get this error in the admin section as soon as I rebuild the theme:

Undefined template: "finduser_title" inside "finduser.php.t"

Maybe I'm replacing the wrong files? here's the paths:

./networkforums/thm/path_info/finduser.tmpl
./networkforums/thm/default/finduser.tmpl

Re: Upgrade Issue: Members List Blank [message #40939 is a reply to message #40936] Tue, 29 April 2008 19:41 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You need to add finduser_title entry into msg file inside i18n/english/ directory. Or download msg file from CVS and replace yours with it.

FUDforum Core Developer
Re: Upgrade Issue: Members List Blank [message #40943 is a reply to message #40939] Tue, 29 April 2008 20:56 Go to previous messageGo to next message
treebeard is currently offline  treebeard   
Messages: 44
Registered: April 2004
Location: Huge Universe
Karma: 0
Member
add to buddy list
ignore all messages by this user
I downloaded msg file from CVS and uploaded it to i18n/english and rebuilt the theme, but still getting the

Undefined template: "finduser_title" inside "finduser.php.t"

error when I rebuild the theme and the blank page when I load the members list.
Re: Upgrade Issue: Members List Blank [message #40950 is a reply to message #40943] Wed, 30 April 2008 19:36 Go to previous messageGo to next message
Ilia is currently offline  Ilia   United States
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You need to add this block into the template file:

{SECTION: finduser_title}
{MSG: finduser_title}
{SECTION: END}



FUDforum Core Developer
Re: Upgrade Issue: Members List Blank [message #40952 is a reply to message #40698] Wed, 30 April 2008 20:06 Go to previous messageGo to next message
treebeard is currently offline  treebeard   
Messages: 44
Registered: April 2004
Location: Huge Universe
Karma: 0
Member
add to buddy list
ignore all messages by this user
OK, I've replaced finduser.tmpl with the newest from CVS, replaced i18n/english/msg with the newest from CVS, and I've added the block

{SECTION: finduser_title}
{MSG: finduser_title}
{SECTION: END}

to the finduser.tmpl template but still getting

Undefined template: "finduser_title" inside "finduser.php.t"

Thanks for the continued help....
Re: Upgrade Issue: Members List Blank [message #41002 is a reply to message #40952] Mon, 05 May 2008 19:08 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Did you edit the finduser.tmpl in both your themes?

FUDforum Core Developer
Re: Upgrade Issue: Members List Blank [message #41007 is a reply to message #41002] Tue, 06 May 2008 09:01 Go to previous message
treebeard is currently offline  treebeard   
Messages: 44
Registered: April 2004
Location: Huge Universe
Karma: 0
Member
add to buddy list
ignore all messages by this user
Yes, I did.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Email stopped working after running upgrade to 2.7.7
Next Topic: Invalid DB type
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Dec 09 21:08:54 EST 2018

Total time taken to generate the page: 0.01142 seconds