FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » JavaScript Broken after Import forum data
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
JavaScript Broken after Import forum data [message #40803] Sun, 13 April 2008 12:16 Go to next message
dfgngirl is currently offline  dfgngirl   United States
Messages: 87
Registered: December 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user

Hi,

we had to rebuild our server OS, so I did a "Make forum datadump", rebuilt OS, then reinstalled a fresh Fud and did a "Import forum data". Now, everything JavaScript enabled like the buttons and drop downs above the post text area are broken, spoiler tags don't work anymore, and one Administrative user complains that she can't open threads except by some rube goldburg work around that she's figured out (I'm not experiencing this error personally, but I am the JavaScript errors I am).

I enabled my FireFox error console and here are some examples:

Error: insertTag is not defined
Source File: javascript: insertTag(document.post_form.msg_body, '[B]', '[/B]');
Line: 1


Error: insertTag is not defined
Source File: javascript: insertTag(document.post_form.msg_body, '[I]', '[/I]');
Line: 1


Error: insertTag is not defined
Source File: http://forums.com/index.php?t=post&frm_id=9&
Line: 1


Error: layerVis is not defined
Source File: http://forums.com/index.php?t=post
Line: 1


...etc..

I was wondering if anyone was experiencing this as well, and if there was a solution. Also, is it possible to "upgrade" to the same version and whether this might fix the problem?

Please advise.
Re: JavaScript Broken after Import forum data [message #40814 is a reply to message #40803] Mon, 14 April 2008 16:00 Go to previous messageGo to next message
Ilia is currently offline  Ilia   United States
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Have you tried re-running an upgrade script to version 2.7.7? Even if you are already running 2.7.7, it will rebuild and if necessary fix broken files.

FUDforum Core Developer
Re: JavaScript Broken after Import forum data [message #40818 is a reply to message #40803] Mon, 14 April 2008 16:35 Go to previous messageGo to next message
dfgngirl is currently offline  dfgngirl   United States
Messages: 87
Registered: December 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user

Thanks. I'll try it and report my findings.
Re: JavaScript Broken after Import forum data [message #40821 is a reply to message #40803] Mon, 14 April 2008 21:16 Go to previous messageGo to next message
dfgngirl is currently offline  dfgngirl   United States
Messages: 87
Registered: December 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user

Same same. All JavaScript functions on my board are dead even after the upgrade. Sad
Re: JavaScript Broken after Import forum data [message #40823 is a reply to message #40803] Tue, 15 April 2008 11:22 Go to previous message
dfgngirl is currently offline  dfgngirl   United States
Messages: 87
Registered: December 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user

It now works! It must have been a cache issue - my browser didn't refresh the latest files needed for JavaScript to work.

Anyways, thanks!
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Forum dies after some accounts...
Next Topic: Private messages
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Oct 22 16:50:10 EDT 2017

Total time taken to generate the page: 0.00607 seconds