FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Upgrade to 2.8 RC1 fails (RESOLVED)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Upgrade to 2.8 RC1 fails (RESOLVED) [message #158141] Wed, 04 February 2009 17:58 Go to next message
kerryg is currently offline  kerryg   Canada
Messages: 157
Registered: September 2008
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Hi there. Trying to update from 2.7.7 to 2.8; getting this error when I run the upgrade script.

Quote:
Warning: fread() [function.fread]: Length parameter must be greater than 0 in /home/******/public_html/ParisForums/upgrade.php on line 873

Warning: gzuncompress() [function.gzuncompress]: data error in /home/******/public_html/ParisForums/upgrade.php on line 873
Archive did not pass checksum test, CORRUPT ARCHIVE!
If you've encountered this error it means that you've:
downloaded a corrupt archive
uploaded the archive in ASCII and not BINARY mode
your FTP Server/Decompression software/Operating System added un-needed cartrige return ('\r') characters to the archive, resulting in archive corruption.


Problem is that I've tried all versions of upgrade script (zlib and not), using various methods of downloading/uploading script, checking to make sure it's binary mode each time and not ASCII. Any suggestions of things to try?
Re: Upgrade to 2.8 RC1 fails [message #158145 is a reply to message #158141] Thu, 05 February 2009 00:43 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Have you downloaded the the tar.gz, tar.bz2 or the .zip file?

PS: I've tested the .zip upgrade script with zlib compression and it worked for me.

Best regards.

Frank
Re: Upgrade to 2.8 RC1 fails [message #158147 is a reply to message #158145] Thu, 05 February 2009 01:59 Go to previous message
kerryg is currently offline  kerryg   Canada
Messages: 157
Registered: September 2008
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Thanks Frank - one of them worked for me, the zlib/zip version.

I just tried syncing again and it unfortunately hasn't fixed the USENET problem - I've entered it separately under Bug Reports.

[Updated on: Thu, 05 February 2009 02:30]

Report message to a moderator

Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Auto Delete Posts/Topics After Expiry
Next Topic: french language
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Wed Jun 20 05:55:18 EDT 2018

Total time taken to generate the page: 0.00763 seconds