FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Insert a Link button inserts html code
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Insert a Link button inserts html code [message #158661] Wed, 11 March 2009 01:41 Go to next message
Salo is currently offline  Salo   United States
Messages: 25
Registered: March 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Trying it on your forum:

"You cannot use links until you have posted more than 5 messages."

------

PHP built On: Windows NT CYBERTEC2 5.2 build 3790
Database Version: 4.1.22-community-nt
PHP Version: 4.4.4
Web Server: Microsoft-IIS/6.0
WebServer to PHP interface: cgi-fcgi
Forum Version: 2.8.0
Relavent PHP Settings:
Safe Mode: OFF
Open basedir: none
Display Errors: ON
File Uploads: ON
Maximum File Upload Size: 10M
Magic Quotes: ON
Register Globals: ON
Output Buffering: No
Disabled Functions: none
PSpell Support: No
Zlib Support: Yes


-Salo
Re: Insert a Link button inserts html code [message #158662 is a reply to message #158661] Wed, 11 March 2009 01:41 Go to previous messageGo to next message
Salo is currently offline  Salo   United States
Messages: 25
Registered: March 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Here is a link, inserted with the Insert a Link button:



There code for a link above, but the link is invisible because it is formatted with html tags.


-Salo

[Updated on: Wed, 11 March 2009 01:44]

Report message to a moderator

Re: Insert a Link button inserts html code [message #158663 is a reply to message #158661] Wed, 11 March 2009 01:42 Go to previous messageGo to next message
Salo is currently offline  Salo   United States
Messages: 25
Registered: March 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
But if I dont click the button, the url is correctly converted to a link:

http://forum.greatlakeseuros.com


-Salo
Re: Insert a Link button inserts html code [message #158664 is a reply to message #158663] Wed, 11 March 2009 01:55 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
You are joking, right? You've already posted more than 5 messages. So, unless we increase the setting, it won't check for links anymore.
Re: Insert a Link button inserts html code [message #158669 is a reply to message #158664] Wed, 11 March 2009 08:58 Go to previous messageGo to next message
Salo is currently offline  Salo   United States
Messages: 25
Registered: March 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
The one at the top is actually my 5th, so I had to post that before I could add a link.

That's not the issue.

The issue is, when I click the Insert a Link button, the link is converted to html tags, and does not appear on the forum, like so:



but if i type it out, it is correctly taggged, like so:

http://forum.greatlakeseuros.com

TIA


-Salo
Re: Insert a Link button inserts html code [message #158672 is a reply to message #158669] Wed, 11 March 2009 09:26 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
OK, I get it. Looks like an old bug that existed in prior releases as well. I will post a patch ASAP.
Re: Insert a Link button inserts html code [message #158673 is a reply to message #158672] Wed, 11 March 2009 10:10 Go to previous messageGo to next message
Salo is currently offline  Salo   United States
Messages: 25
Registered: March 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Thanks!

-Salo
Re: Insert a Link button inserts html code [message #158679 is a reply to message #158673] Wed, 11 March 2009 15:44 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
See patch at http://cvs.prohost.org/c/index.cgi/FUDforum/chngview?cn=11891

Instructions on how to apply is at http://cvs.prohost.org/index.php/Applying_patches
Re: Insert a Link button inserts html code [message #158680 is a reply to message #158661] Wed, 11 March 2009 16:14 Go to previous messageGo to next message
Salo is currently offline  Salo   United States
Messages: 25
Registered: March 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Sorry if this is a dumb question...

Trying to follow patch instructions instead of just replacing the file (as I did with this file to fix [img] issue)

I installed the forum in the wwwroot/ folder on my server.

Inside wwwroot/ there are two folders from the forum install

forum/ and

FUDforum/

neither folder contains forum_data/ folder, as is mentioned in the link on how to patch.

What did I do wrong?


-Salo
Re: Insert a Link button inserts html code [message #158681 is a reply to message #158680] Wed, 11 March 2009 16:22 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
You've supplied a Server_Root and Forum_Data_Root when you've installed FUDforum (step 1). If you cannot remember, look in your GLOBALS.php file.

PS: This is a simple patch so why don't you just install it manually?
Re: Insert a Link button inserts html code [message #158682 is a reply to message #158681] Wed, 11 March 2009 16:36 Go to previous messageGo to next message
Salo is currently offline  Salo   United States
Messages: 25
Registered: March 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Applied manually, works. Thanks!!!

-Salo
Re: Insert a Link button inserts html code [message #158688 is a reply to message #158682] Wed, 11 March 2009 21:32 Go to previous messageGo to next message
Salo is currently offline  Salo   United States
Messages: 25
Registered: March 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
hmm... i thought it was working but now it adds a link with no text and when you go back to edit the post there are html tags in there. weird.

-Salo
Re: Insert a Link button inserts html code [message #158692 is a reply to message #158688] Thu, 12 March 2009 01:19 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
What do I need to do to reproduce the problem?
Re: Insert a Link button inserts html code [message #158701 is a reply to message #158661] Thu, 12 March 2009 10:34 Go to previous messageGo to next message
Salo is currently offline  Salo   United States
Messages: 25
Registered: March 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
1. reply to post
2. click Insert a Link button
3. fill in URL
4. click OK
5. scratch head because there is nothing between URL tags


-Salo
Re: Insert a Link button inserts html code [message #158703 is a reply to message #158701] Thu, 12 March 2009 14:17 Go to previous message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
I'm unable to reproduce the problem on my forum. Please check if the patch is still in.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: two users listed as "Priveleged User" in Admin Log
Next Topic: must log in after clicking link to a thread from inside a pm
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Wed Oct 18 09:03:43 EDT 2017

Total time taken to generate the page: 0.00854 seconds