FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Admin control center broken after upgrade (Admin control center broken after upgrade)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Admin control center broken after upgrade [message #158675] Wed, 11 March 2009 12:06 Go to next message
zorgmann is currently offline  zorgmann
Messages: 7
Registered: March 2009
Location: MOW
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

Hello.

I've update forum to FUDforum v2.8.0 with Upgrade Script from "fudforum.org/download.php". After upgrade got this:
***
FUDforum Upgrade Wizard

Checking if SQL permissions to perform the upgrade are avaliable.
Disable the forum.
Forum is now disabled.
Beginning the file upgrade process.
Begining to decompress the archive
Finished decompressing the archive.
File Upgrade Complete.
All changed files were backed up to: "/home/clients/w_fordsc/FUDforum/errors/.backup/".

Beginning SQL Upgrades.
SQL Upgrades Complete.
Adding GLOBAL Variables.
Compiling theme default.
Missing Message entry finduser_flag inside i18n/russian-1251/msg
***

And several issue more:

- error 500 at admin page with such error in apache log - "Premature end of script headers: /home/clients/w_fordsc/public_html/forum/adm/admglobal.php"

- partitions in forum were gone smwr - all topics listed in one

Is it possible to fix this issues somehow?

Thanks for advance. :?
Re: Admin control center broken after upgrade [message #158676 is a reply to message #158675] Wed, 11 March 2009 12:52 Go to previous messageGo to next message
zorgmann is currently offline  zorgmann
Messages: 7
Registered: March 2009
Location: MOW
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

zorgmann wrote on Wed, 11 March 2009 19:06

And several issue more:
- error 500 at admin page with such error in apache log - "Premature end of script headers: /home/clients/w_fordsc/public_html/forum/adm/admglobal.php"
- partitions in forum were gone smwr - all topics listed in one



one more issue:

- java scripts not running - impossible to insert any smile in message.
Re: Admin control center broken after upgrade [message #158677 is a reply to message #158676] Wed, 11 March 2009 13:24 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Hi,

1) We are desupporing non-UTF8 language files like the "russian-1251" you are using. Please use the UTF8 version or unpack the latest "russian-1251" files from the provided zip file.

2) Possibly this problem - http://fudforum.org/forum/index.php?t=msg&th=118221&start=0&

Best of luck!

Frank
Re: Admin control center broken after upgrade [message #158787 is a reply to message #158677] Mon, 23 March 2009 06:10 Go to previous messageGo to next message
zorgmann is currently offline  zorgmann
Messages: 7
Registered: March 2009
Location: MOW
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

naudefj wrote on Wed, 11 March 2009 20:24
Hi,

1) We are desupporing non-UTF8 language files like the "russian-1251" you are using. Please use the UTF8 version or unpack the latest "russian-1251" files from the provided zip file.
Frank


Sorry, can you please point me to correct way to find correct zip file? Neither in upgrade nor in install zip files no languages Sad

Where i'm wrong?

Re: Admin control center broken after upgrade [message #158790 is a reply to message #158787] Tue, 24 March 2009 08:05 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Can you please wait for the next release (planned for April 2009)?

FUDforum 2.8.1's upgrade script will be able to automatically change your theme from "russian-1251" to "russian" (UTF-8).
Re: Admin control center broken after upgrade [message #158793 is a reply to message #158790] Tue, 24 March 2009 09:14 Go to previous messageGo to next message
zorgmann is currently offline  zorgmann
Messages: 7
Registered: March 2009
Location: MOW
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

ok
i'll be patient

thank you for advance!

PS: when exactly new release will be?
Re: Admin control center broken after upgrade [message #158794 is a reply to message #158793] Wed, 25 March 2009 01:58 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
When we have enough new features and the code looks stable enough. My guess is that will be in +- 2 weeks.
Re: Admin control center broken after upgrade [message #159545 is a reply to message #158794] Tue, 09 June 2009 07:58 Go to previous messageGo to next message
zorgmann is currently offline  zorgmann
Messages: 7
Registered: March 2009
Location: MOW
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

hello again!

may i update to 2.8.1 version to have this issue fixed?

thanks.
Re: Admin control center broken after upgrade [message #159546 is a reply to message #159545] Tue, 09 June 2009 11:10 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Yes. Steps:

1. Upgrade to 2.8.1
2. Apply patch http://cvs.prohost.org/c/index.cgi/FUDforum/chngview?cn=11936
3. Apply patch http://cvs.prohost.org/c/index.cgi/FUDforum/chngview?cn=11937
4. Run the MySQL charset changer
5. Run the Message Compactor with from & to charsets
Re: Admin control center broken after upgrade [message #159780 is a reply to message #159546] Tue, 23 June 2009 11:05 Go to previous messageGo to next message
zorgmann is currently offline  zorgmann
Messages: 7
Registered: March 2009
Location: MOW
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

hello again.

with this steps i've ruining everithing not only admin part

i decided to roll back to previous version, i.e. 2.6.15 (which was installed initially)

and get such error:
"
Failed to import default data ("/* Add initial welcome message */ INSERT INTO fud26_msg (thread_id, poster_id, reply_to, ip_addr, host_name, post_stamp, update_stamp, updated_by, icon, subject, attach_cnt, poll_id, foff, length, file_id, offset_preview, length_preview, file_id_preview, attach_cache, poll_cache, mlist_msg_id, msg_opt, apr, flag_cc, flag_country) VALUES (1, 2, 0, '127.0.0.1', NULL, 1237282100, 0, 0, NULL, 'Welcome to FUDforum', 0, 0, -1, 603, 1, -1, 0, 0, NULL, NULL, NULL, 1, 1, NULL, NULL)") into table def_msg, SQL Reason: Unknown column 'flag_cc' in 'field list'
"

seems like this part of code smwr after
"<?php __HALT_COMPILER(); ?>"

is it fixable?
Re: Admin control center broken after upgrade [message #159781 is a reply to message #159780] Tue, 23 June 2009 14:53 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I thought you want to upgrade your forum. However, the string "Failed to import default data" is in install.php, not the upgrade script. Can you please provide more info about the process you're following?
Re: Admin control center broken after upgrade [message #159782 is a reply to message #159781] Tue, 23 June 2009 15:55 Go to previous messageGo to next message
zorgmann is currently offline  zorgmann
Messages: 7
Registered: March 2009
Location: MOW
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

naudefj wrote on Tue, 23 June 2009 22:53
I thought you want to upgrade your forum.



Please believe - me too Sad

naudefj wrote on Tue, 23 June 2009 22:53
However, the string "Failed to import default data" is in install.php, not the upgrade script. Can you please provide more info about the process you're following?



Let's forget about upgrade, ok?

I decided to re-install forum "from scratch" as it was done in 2006 and (you are right) this output wich i provided previously from install.php. Version is "FUDforum_zl_2-6-15.tar.gz".

I'm confused a little... Mysql user has all privileges to selected DB. I see that install drops all tables in selected DB and re-creates tables. I desided to "hack" origin Smile but it has precompiled part.

Thank you for your input.
Re: Admin control center broken after upgrade [message #159783 is a reply to message #159782] Tue, 23 June 2009 16:22 Go to previous message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Why don't you just download the latest upgrade script and run it against your forum? Instructions are available at http://cvs.prohost.org/index.php/Upgrading
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Forcing New Line at Beginning of Signature for News Group Post?
Next Topic: What should I know before I upgrade?
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Jun 19 10:06:10 EDT 2018

Total time taken to generate the page: 0.00908 seconds