FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » i18n characters not showing in dates! (utf-8)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
i18n characters not showing in dates! (utf-8) [message #158915] Wed, 15 April 2009 06:41 Go to next message
Peter Vendike is currently offline  Peter Vendike   Denmark
Messages: 65
Registered: February 2009
Location: Denmark
Karma: 0
Member
Translator
add to buddy list
ignore all messages by this user
Select any language-theme with language-locale different then english in this forum (fudforum.org), look at the dates of messages.

All i18n characters shows up as ???????

like:
german: Märtz= M?rtz
french: février= f?vrier
août= au?t
spanish: sábado= s?abado
swedish: måndag= m?ndag
and so on

Re: i18n characters not showing in dates! (utf-8) [message #158916 is a reply to message #158915] Wed, 15 April 2009 07:22 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
This is a known problem that will be fixed in FUDforum 2.8.1.

A patch is available at http://cvs.prohost.org/c/index.cgi/FUDforum/chngview?cn=11887

Remember to regenerate your themes after applying the patch.
Re: i18n characters not showing in dates! (utf-8) [message #158917 is a reply to message #158916] Wed, 15 April 2009 09:20 Go to previous messageGo to next message
Peter Vendike is currently offline  Peter Vendike   Denmark
Messages: 65
Registered: February 2009
Location: Denmark
Karma: 0
Member
Translator
add to buddy list
ignore all messages by this user
The patch dos'nt work on my system

if I force
$func = '\'.utf8_encode(strftime("';
$close = ')).\'';

without checking for
stristr($GLOBALS['char_set'], 'utf-8'
(commenting out corresponding lines in compiler.inc 1.98)

it works!

I think this global variable is not set on my system?
How do I check this?


Re: i18n characters not showing in dates! (utf-8) [message #158918 is a reply to message #158917] Wed, 15 April 2009 11:25 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
Add an "echo" to the code and look at the output when you generate your theme.

PS: What is in your thm/default/i18n/$lang/charset file?
Re: i18n characters not showing in dates! (utf-8) [message #158925 is a reply to message #158918] Thu, 16 April 2009 00:17 Go to previous messageGo to next message
Peter Vendike is currently offline  Peter Vendike   Denmark
Messages: 65
Registered: February 2009
Location: Denmark
Karma: 0
Member
Translator
add to buddy list
ignore all messages by this user
Hej Frank

Den ons, 15 april 2009 17:25 skrev naudefj:
Add an "echo" to the code and look at the output when you generate your theme.

PS: What is in your thm/default/i18n/$lang/charset file?


all my (unpatched) systemfiles are from the 2.8.0RC2 distribution and all thm/default/i18n/$lang/charset files contains "utf-8".
I don't understand why $GLOBALS['char_set'] is a reference to the content of this file?
Re: i18n characters not showing in dates! (utf-8) [message #158926 is a reply to message #158925] Thu, 16 April 2009 10:47 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
It should be. Look at compiler.inc:

$GLOBALS['char_set'] = trim(file_get_contents($charset));
Re: i18n characters not showing in dates! (utf-8) [message #158930 is a reply to message #158926] Thu, 16 April 2009 12:26 Go to previous message
Peter Vendike is currently offline  Peter Vendike   Denmark
Messages: 65
Registered: February 2009
Location: Denmark
Karma: 0
Member
Translator
add to buddy list
ignore all messages by this user
Thank you, I found it now, will try to understand why the original patch didn't work for me
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: FUDforum v2.8.0 errors
Next Topic: no results when a search includes a numerical character
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Thu Oct 19 10:49:48 EDT 2017

Total time taken to generate the page: 0.00750 seconds