FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Problem with importing the data (blank page)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Problem with importing the data [message #159021] Thu, 23 April 2009 03:48 Go to next message
godo is currently offline  godo   Poland
Messages: 2
Registered: April 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi, I have problem with importing the datadump to new instlation.

AFter importing the page is blank. Below the errors which appears:

THis is after I add to the index.php this code
Quote:
error_reporting(E_ERROR | E_WARNING | E_PARSE | E_COMPILE_ERROR);
ini_set('display_errors', '1');
define('forum_debug', 1);


and the output is below:

Quote:
(/home/users/szczeniak/ycpl/site/forum/index.php:79
/home/users/szczeniak/ycpl/site/forum/index.php:318
/home/users/szczeniak/ycpl/site/forum/theme/default/index.php:41
/home/users/szczeniak/ycpl/site/forum/index.php:1202
) 1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1
Query: UPDATE fud26_ses SET sys_id='352904b706800e8dd8e1d06fcc75a4bc', forum_id=0, time_sec=1240470582, action='PrzeglÄ…danie <a href=\"index.php?t=index\">listy forum</a>', returnto='' WHERE id=
Server Version: 5.0.68



In the httpd-log-error (apache) there are:
Quote:

[Thu Apr 23 09:08:20 2009] [error] [client 66.249.71.23] PHP Notice: Trying to get property of non-object in /home/users/szczeniak/ycpl/site/forum/index.php on l
ine 976
[Thu Apr 23 09:08:20 2009] [error] [client 66.249.71.23] PHP Notice: Trying to get property of non-object in /home/users/szczeniak/ycpl/site/forum/index.php on l
ine 984
[Thu Apr 23 09:08:20 2009] [error] [client 66.249.71.23] PHP Notice: Trying to get property of non-object in /home/users/szczeniak/ycpl/site/forum/index.php on l
ine 987
[Thu Apr 23 09:08:20 2009] [error] [client 66.249.71.23] PHP Notice: Undefined property: stdClass::$time_zone in /home/users/szczeniak/ycpl/site/forum/index.php
on line 1000
[Thu Apr 23 09:08:20 2009] [error] [client 66.249.71.23] PHP Notice: Undefined property: stdClass::$locale in /home/users/szczeniak/ycpl/site/forum/index.php on
line 1004
[Thu Apr 23 09:08:20 2009] [error] [client 66.249.71.23] PHP Notice: Undefined property: stdClass::$id in /home/users/szczeniak/ycpl/site/forum/index.php on lin
e 1019
[Thu Apr 23 09:08:20 2009] [error] [client 66.249.71.23] PHP Notice: Undefined property: stdClass::$id in /home/users/szczeniak/ycpl/site/forum/index.php on lin
e 1019
[Thu Apr 23 09:08:20 2009] [error] [client 66.249.71.23] PHP Notice: Undefined property: stdClass::$ses_id in /home/users/szczeniak/ycpl/site/forum/index.php on
line 1031
[Thu Apr 23 09:08:20 2009] [error] [client 66.249.71.23] PHP Notice: Undefined property: stdClass::$sid in /home/users/szczeniak/ycpl/site/forum/theme/default/a
ctions.php on line 102
[Thu Apr 23 09:08:20 2009] [error] [client 66.249.71.23] PHP Fatal error: SQL Error has occurred, please contact the <a href="mailto:XXX(at)XXX(dot)XX?subject=SQL%20
Error">administrator</a> of the forum and have them review the forum's SQL query log in /home/users/szczeniak/ycpl/forum-data/include/core.inc on line 188







What can I do get my forum back ? I have backup of my forum but after I import the data the forum is gone (blank page).

[Updated on: Thu, 23 April 2009 05:37]

Report message to a moderator

Re: Problem with importing the data [message #159023 is a reply to message #159021] Thu, 23 April 2009 14:24 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3663
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Looks like a data related problem. I've seen a similar problem where the forum's user id=1 (Anonymous Coward) was removed.

You may want to uncomment the following line in your index.php to see all queries:

"#define('fud_query_stats', 1);


Besides that, you will have to trace the code manually to understand where things go south.

Best of luck!

Frank
Re: Problem with importing the data [message #159024 is a reply to message #159023] Thu, 23 April 2009 14:37 Go to previous messageGo to next message
godo is currently offline  godo   Poland
Messages: 2
Registered: April 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
After I uncommented that line, this is what appeared:


Quote:

SELECT s.id AS sid, s.ses_id, s.data, s.returnto, s.sys_id, t.id AS theme_id, t.lang, t.name AS theme_name, t.locale, t.theme, t.pspell_lang, t.theme_opt, u.alias, u.posts_ppg, u.time_zone, u.sig, u.last_visit, u.last_read, u.cat_collapse_status, u.users_opt, u.topics_per_page, u.ignore_list, u.ignore_list, u.buddy_list, u.id, u.group_leader_list, u.email, u.login, u.sq, u.ban_expiry, u.flag_cc FROM fud26_ses s INNER JOIN fud26_users u ON u.id=(CASE WHEN s.user_id>2000000000 THEN 1 ELSE s.user_id END) INNER JOIN fud26_themes t ON t.id=u.theme WHERE s.ses_id='42f54df607dc1ca6b4612fa3ee2ac0d0'

query count: 1 time taken: 0.000687

Affected rows: 0

total sql time: 0.000687

SELECT s.id AS sid, s.ses_id, s.data, s.returnto, s.sys_id, t.id AS theme_id, t.lang, t.name AS theme_name, t.locale, t.theme, t.pspell_lang, t.theme_opt, u.alias, u.posts_ppg, u.time_zone, u.sig, u.last_visit, u.last_read, u.cat_collapse_status, u.users_opt, u.topics_per_page, u.ignore_list, u.ignore_list, u.buddy_list, u.id, u.group_leader_list, u.email, u.login, u.sq, u.ban_expiry, u.flag_cc FROM fud26_ses s INNER JOIN fud26_users u ON u.id=(CASE WHEN s.user_id>2000000000 THEN 1 ELSE s.user_id END) INNER JOIN fud26_themes t ON t.id=u.theme WHERE s.id='777'

query count: 2 time taken: 0.000349

Affected rows: 0

total sql time: 0.001036


Re: Problem with importing the data [message #159025 is a reply to message #159024] Thu, 23 April 2009 14:56 Go to previous message
naudefj is currently offline  naudefj   South Africa
Messages: 3663
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
As far as I understand those queries should each return 1 row. You need to look at the data and figure out why it's returning nothing.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: New categories not become available
Next Topic: upgrade script password issue
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Jul 21 22:33:32 EDT 2018

Total time taken to generate the page: 0.00760 seconds