FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » How To » problem editing forum_rules - single and double quotes
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
problem editing forum_rules - single and double quotes [message #159241] Thu, 14 May 2009 13:10 Go to next message
michiamano is currently offline  michiamano   United States
Messages: 9
Registered: April 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Including any single ['] or double quote ["] in the forum rules results in this error:

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /home/path/to/forum/theme/default/pre_reg.php on line 71

I ran into this problem the last time I tried to modify the rules and worked around it by not using apostrophes or quotation marks but this time I need my apostrophes at the very least.

Suggestions?

Thanks!
Re: problem editing forum_rules - single and double quotes [message #159242 is a reply to message #159241] Thu, 14 May 2009 13:19 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I'm aware of the problem. The workaround is to escape the quotes with backslashes (\).

Best regards.

Frank
Re: problem editing forum_rules - single and double quotes [message #159245 is a reply to message #159242] Thu, 14 May 2009 14:53 Go to previous messageGo to next message
michiamano is currently offline  michiamano   United States
Messages: 9
Registered: April 2009
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
naudefj wrote on Thu, 14 May 2009 13:19
I'm aware of the problem. The workaround is to escape the quotes with backslashes (\).

Best regards.

Frank



Weird. I tried that the first time and it didn't work. Works now for single quotes. Double quotes don't seem to need escaping.

Thanks!
Re: problem editing forum_rules - single and double quotes [message #160555 is a reply to message #159245] Mon, 28 September 2009 14:54 Go to previous message
naudefj is currently offline  naudefj   South Africa
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
As of FUDforum 3.0.0RC1 escaping of quotes is no longer required (they will simply be ignored). However, I recommend you remove them as they will be rendered as-is in future releases (users will see them on-screen).
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: LDAP Integration
Next Topic: ISP Information/Whois not available
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Dec 17 05:13:53 EST 2017

Total time taken to generate the page: 0.00758 seconds