FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » NNTP - Conversion of special characters (UTF-8) doesn't work
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
NNTP - Conversion of special characters (UTF-8) doesn't work [message #159284] Thu, 21 May 2009 04:55 Go to next message
icarus is currently offline  icarus   
Messages: 52
Registered: May 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user

Hi!

I set up a FUDForum for testing purposes. I sync it with a newsserver I set up as well.

When posting mails with UTF-8 encoded characters they aren't translated correctly. I have the feeling that there is no character translation at all.

In which file is the translation done? Can I help?

Michael

P.S.: For testing purposes: The forum is under http://forum.piratenpartei-hamburg.de/ and the newsserver is news://news.piratenpartei-hamburg.de
Re: NNTP - Conversion of special characters (UTF-8) doesn't work [message #159289 is a reply to message #159284] Thu, 21 May 2009 10:23 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You are running on an very old release of FUDforum. I recommend upgrading to 2.8.1 as it contains some UTF-8 fixes for NNTP importing.

Best regards.

Frank
Re: NNTP - Conversion of special characters (UTF-8) doesn't work [message #159292 is a reply to message #159289] Thu, 21 May 2009 14:04 Go to previous messageGo to next message
icarus is currently offline  icarus   
Messages: 52
Registered: May 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user

Hi!

I just tried to upgrade and got the following error:
Warning: mysql_connect() [function.mysql-connect]: Unknown MySQL server host '/var/..../forum.db.php' (3) in /var/..../upgrade.php on line 456

MySQL Error: #2005 (Unknown MySQL server host '/var/..../forum.db.php' (3))

I'm using the FUDForum with sqlite.

Michael
Re: NNTP - Conversion of special characters (UTF-8) doesn't work [message #159323 is a reply to message #159292] Fri, 22 May 2009 16:32 Go to previous message
naudefj is currently offline  naudefj   South Africa
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I just realized that there is not a single line of SQLite code in the upgrade script. I'll make sure it gets added before the next release.

Best regards.

Frank
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: avatar upload
Next Topic: FATAL ERROR: could not open message store for forum id#20000
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Fri Dec 15 13:01:39 EST 2017

Total time taken to generate the page: 0.00652 seconds