FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Attachments in newsgroups aren't decoded
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Attachments in newsgroups aren't decoded [message #159300] Thu, 21 May 2009 17:29 Go to next message
icarus is currently offline  icarus   
Messages: 52
Registered: May 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user

Hi!

With the current version I'm having the problem that attachments are only recognized when they are done in mailinglists but not in newsgroups.

I made the following setup:

Forum at http://news.piratenpartei-hamburg.de
Newsgroup at news://news.piratenpartei-hamburg.de
And a mailinglist

The mailinglist and the newsgroup is synced via the internal newsgroup sync from mailman. The first group in the forum is synced via NNTP the second via the mailing list. So both are synced with the same content.

So please look at http://news.piratenpartei-hamburg.de/index.php?t=msg&th=42&start=0

And look at the same posting at http://news.piratenpartei-hamburg.de/index.php?t=msg&th=41&start=0

Where is the difference in the decoding?

Michael
Re: Attachments in newsgroups aren't decoded [message #159303 is a reply to message #159300] Thu, 21 May 2009 22:44 Go to previous messageGo to next message
kerryg is currently offline  kerryg   Canada
Messages: 157
Registered: September 2008
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
That's very interesting. Those are MIME attachments? I know the NNTP script doesn't understand MIME attachments, but I didn't know the mailing list script did.
Re: Attachments in newsgroups aren't decoded [message #159304 is a reply to message #159303] Fri, 22 May 2009 00:59 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
That's correct, MIME attachments are currently supported in E-mails, but not in USENET posts. We will fix it in a later release.
Re: Attachments in newsgroups aren't decoded [message #159311 is a reply to message #159304] Fri, 22 May 2009 02:33 Go to previous messageGo to next message
icarus is currently offline  icarus   
Messages: 52
Registered: May 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user

Hi!

naudefj schrieb am Fr, 22 Mai 2009 06:59
That's correct, MIME attachments are currently supported in E-mails, but not in USENET posts. We will fix it in a later release.

This feature is really crucial for my plans. Is it somewhat isolated in the mail part so I can include it in the news part? And in which files I have to look?

BTW: Why isn't the decoding engine used as a central function?

Michael
Re: Attachments in newsgroups aren't decoded [message #159313 is a reply to message #159311] Fri, 22 May 2009 10:45 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
Hi,

The code was written in an era where E-mail messages had MIME attachments and USENET had UUencoded attachments. Now that MIME is also used for USENET, a common function makes sense.

I won't get to this any time soon. However, you are welcome to take the initiative to get the job done. To get you started, have a look at scripts/maillist.php, scripts/nntp.php, include/mlist.inc and include/nntp.inc.

Best regards.

Frank
Re: Attachments in newsgroups aren't decoded [message #159767 is a reply to message #159313] Sun, 21 June 2009 21:39 Go to previous message
jcarter is currently offline  jcarter   United States
Messages: 25
Registered: August 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
naudefj wrote on Fri, 22 May 2009 10:45
Hi,

The code was written in an era where E-mail messages had MIME attachments and USENET had UUencoded attachments. Now that MIME is also used for USENET, a common function makes sense.

I won't get to this any time soon. However, you are welcome to take the initiative to get the job done. To get you started, have a look at scripts/maillist.php, scripts/nntp.php, include/mlist.inc and include/nntp.inc.




I implemented this several years ago, but was too lazy to post the patch. I'll post it to {patches} for the latest release. It still doesn't solve the problem of large binary messages in which an attachment is split across several messages.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: can't login to the admin panel
Next Topic: NNTP Sync minor quirks
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Fri Oct 20 10:33:15 EDT 2017

Total time taken to generate the page: 0.00748 seconds