FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Fatal error when upgrading to 2.8.1 from 2.7.7 RESOLVED ( The names and identities have been changed to protect the guilty and the potentially guilty, namely me.)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
icon6.gif  Fatal error when upgrading to 2.8.1 from 2.7.7 RESOLVED [message #159640] Sun, 14 June 2009 02:47 Go to next message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
I have this beautiful brand new theme courtesy of naudefj AKA Frank but when I go to upgrade it crashes big time every time.

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'Db_admin_User'@'server.Host.org' (using password: YES) in 
/home/.server/FTP_User/FUDforum/include/theme/default/db.inc on line 16

Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in 
/home/.server/FTP_User/FUDforum/include/theme/default/db.inc on line 16

Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in 
/home/.server/FTP_User/FUDforum/include/theme/default/db.inc on line 16

Fatal error: SQL Error has occurred, please contact the administrator of the forum and have them review the forum's SQL query log in /home/.server/FTP_User/FUDforum/include/core.inc on line 194



Now by my own admission I am a rank amateur compared to most of you here, but I am a long way from being dumb, I just have very little in the way of knowledge and experience with PHP, coding etc. and what knowledge I do have is hard fought and won (mostly by trial and error) by my own efforts and scouring the internet for information which is generally way over my head.

Of particular concern to me is the "supplied argument is not a valid MySQL-Link resource" portion of this error (I am no stranger to getting errors I do not comprehend) if I cannot sort it out in a reasonable period of time, my usual approach is the biggest hammer option of uninstalling, reinstalling and restoring the most recent backups which might actually contribute to my problem rather than solve it.

But that approach has to stop sometime, and there is no time like the present so if any one has some input I am all ears.

RESOLVED: The quick answer is below the spoiler.

Toggle Spoiler




"I'm a Witcher, I solve human problems; not always using a sword!"

[Updated on: Sun, 21 June 2009 21:30]

Report message to a moderator

Re: Fatal error when upgrading to 2.8.1 from 2.7.7 [message #159641 is a reply to message #159640] Sun, 14 June 2009 02:55 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
This nasty error means that FUDforum couldn't connect to its database. Check if the DB is running. Log in to the ACP and check your database settings (Global Settings Manager), check the Error Log Viewer for errors and try to rebuild the theme.
Re: Fatal error when upgrading to 2.8.1 from 2.7.7 [message #159643 is a reply to message #159641] Sun, 14 June 2009 03:08 Go to previous messageGo to next message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
naudefj wrote on Sun, 14 June 2009 01:55
This nasty error means that FUDforum couldn't connect to its database. Check if the DB is running. Log in to the ACP and check your database settings (Global Settings Manager), check the Error Log Viewer for errors and try to rebuild the theme.


This nasty error means that FUDforum couldn't connect to its database. Check that is what I surmised.

Log in to the ACP and check your database settings (Global Settings Manager) check all as they should be, just as they had been installed 20 minutes prior when I restored my last available backup I did some house keeping and went to upgrade

I can go from 2.7.7 directly to 2.8.1 right?.

check the Error Log Viewer for errors and try to rebuild the theme. check I had already checked the error log and cleared it, there were errors (I will copy them next time, i will even crash it again if I have to) I will check again on all of the above.

This is all part of what I was trying to explain to you in our E-mails, and it is beyond my pay grade sorta.









"I'm a Witcher, I solve human problems; not always using a sword!"
Re: Fatal error when upgrading to 2.8.1 from 2.7.7 [message #159666 is a reply to message #159643] Sun, 14 June 2009 17:57 Go to previous messageGo to next message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
Ok Frank

I got some sleep and I am well rested so let us tackle this varmint.

As I said I backed up the forum and downloaded it, and I am now ready to repeat the process.

Upgrade failed again same error.

Your instructions from last night Check if the DB is running. Log in to the ACP and check your database settings (Global Settings Manager), check the Error Log Viewer for errors and try to rebuild the theme.

It sounds like you expect me to do this before I reinstall the software and restore the backup, and that would be great if I could do that, unfortunately all I get is the error msg. so let's clarify that 1st.

Is it possible to access the admin panel separately?
No it is not as far as I know, but according to the searches I have done it should be via http://your_forum_url/adm/ I used http://piasa.info/adm/ specifically with a variety of adm.php files and received the exact same error as before, I have never been able to log in directly to the admin control panel except on those few occasions when I was kicked out and asked to log in again (usually after changing setting regarding avatars) or when I have closed the forum for maintenance even though I have tried.


Toggle Spoiler


For now I will reinstall Piasa from scratch, and restore the backup, so we can continue.



"I'm a Witcher, I solve human problems; not always using a sword!"
Re: Fatal error when upgrading to 2.8.1 from 2.7.7 [message #159667 is a reply to message #159641] Mon, 15 June 2009 00:48 Go to previous messageGo to next message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
OK I have it reinstalled, and restored, there are some items that were not restored, header images for example, but if I understand it they may need to be stored elsewhere.
And there were several items in the global configuration that I had to manually reset to different values, but all that is normal more or less, I just don't think it should be.

Most of all yes I can access the database and the admin panel Yippee.

To be honest I can't recall ever attempting to connect to the admin panel when I did not have an error to deal with.

There were around 48 error messages along the lines of:

[Error] Invalid Input
[Error] Invalid Message
[Message Sent to User] The message you are trying to view does not exist.
[Error] Disabled feature
[Message Sent to User] This feature has been disabled by the system administrator
Most of them from this IP which is reported as belonging to google, and another one that comes back as a ripe query (what ever that is) I can e-mail them to you but I think they are bots and spiders?
66.249.71.245

The meat you wanted should be these 2 errors

SQL Error Log [clear log]

Toggle Spoiler


I can't make head not tails out of that other than it is referring to fud26_tv6 as not existing and it is there, I looked at it, it refers to message 19 which seems not to be there which is what the message was about (the user had posted a topic but it went poof)

I obfuscated the codes, so if you need the actual numbers let me know and I will e-mail them. The 2nd one i would just delete, I'm not sure on the 1 st!




"I'm a Witcher, I solve human problems; not always using a sword!"
Re: Fatal error when upgrading to 2.8.1 from 2.7.7 [message #159668 is a reply to message #159667] Mon, 15 June 2009 01:58 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Are you restoring to a different version? Restoring between versions is not recommended (see manual), unless you really know what you're doing.

PS: This is too much for me to work through right now, will have a detailed look after work.
icon6.gif  Re: Fatal error when upgrading to 2.8.1 from 2.7.7 [message #159669 is a reply to message #159668] Mon, 15 June 2009 02:12 Go to previous messageGo to next message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
No I am restoring a 2.7.7 back onto a 2.7.7 installation

No problem work always comes before play, I am assuming of course that FUDforum is NOT your occupation, but is a hobby/vocation like me.

Given the skill you have displayed so far, I guess computer programming.


"I'm a Witcher, I solve human problems; not always using a sword!"
Re: Fatal error when upgrading to 2.8.1 from 2.7.7 [message #159672 is a reply to message #159669] Mon, 15 June 2009 13:28 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Quote:
Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'Db_admin_User'@'server.Host.org' (using password: YES) in
/home/.server/FTP_User/FUDforum/include/theme/default/db.inc on line 16


We need to look at the first error - line 16 - a simple mysql_connect() statement. Somehow MySQL denied your user access to the database, indicating that this is no FUDforum problem.

Check if the following settings in GLOBALS.php are correct: DBHOST, DBHOST_USER and DBHOST_PASSWORD. Also try to connect from command line with the provided values to verify that they are correct.
Re: Fatal error when upgrading to 2.8.1 from 2.7.7 [message #159673 is a reply to message #159672] Mon, 15 June 2009 14:36 Go to previous messageGo to next message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
naudefj wrote on Mon, 15 June 2009 12:28
We need to look at the first error - line 16 - a simple mysql_connect() statement. Somehow MySQL denied your user access to the database, indicating that this is no FUDforum problem.

Check if the following settings in GLOBALS.php are correct: DBHOST, DBHOST_USER and DBHOST_PASSWORD. Also try to connect from command line with the provided values to verify that they are correct.


Ok I understand, it being a database problem with my being denied access, not specifically related to FUDforum (other than FUDforum must have access to the database to work properly). In this case we are doing an upgrade so it is ensuring that it has access to all the data stored in the database, and for some reason, thinks it does not have full access.

The rest of it I am a bit fuzzy on, "Globals.php" is one of the things I don't have much understanding of other than it is a simulated link of the non browsable files, is that correct?

DBHOST, DBHOST_USER and DBHOST_PASSWORD are respectively the forums equivalent of MYsql, Database user, and their password, correct?

What I don't understand is command line! I have asked before is that in reference to my browser window or is this located somewhere else. I normally access the database through my hosts Mysql, and the FUDforum Installation files through filezilla or my hosts web panel.

I am obviously looking for something that is different from the above.
I currently use exactly the same information as found in my admin control panel,

I'm on it! To see what I can find!



"I'm a Witcher, I solve human problems; not always using a sword!"
Re: Fatal error when upgrading to 2.8.1 from 2.7.7 [message #159674 is a reply to message #159672] Mon, 15 June 2009 15:01 Go to previous messageGo to next message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
Negative on accessing globals via hosts ftp
Negative on even seeing globals in file zilla.
Downloaded Globals.php from control panel file manager into php editor OK!
DBHOST correct!
DBHOST_USER correct!
DBHOST_PASSWORD. Does not match ! it has 1 extra character in it than what it should have!


"I'm a Witcher, I solve human problems; not always using a sword!"
Re: Fatal error when upgrading to 2.8.1 from 2.7.7 [message #159675 is a reply to message #159674] Mon, 15 June 2009 16:52 Go to previous messageGo to next message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
Changed password, it was refused! System does not accept the character!

Changed password on the host DB user account! Refused!
Tried to reinstall software, installation refused!

ERROR on step 2: Could not open the database you've specified, SQL Reason: Access denied for user 'host_db_user'@'206.87.148.0/255.255.183.0' to database 'zYx456g-*#Ctb$wN'

Currently cannot go forward with this, I have advised my host, in the meantime I will attempt another installation.


"I'm a Witcher, I solve human problems; not always using a sword!"
icon7.gif  Re: Fatal error when upgrading to 2.8.1 from 2.7.7 [message #159676 is a reply to message #159675] Mon, 15 June 2009 18:08 Go to previous message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
Success! Piasa now upgraded to 2.8.1 though it resides on a different domain temporarily.

I have saved backup to hard drive and will keep this installation to work on, and put Piasa back on its home domain as soon as I regain access to mysql.


naudefj You do your self proud, thanks for the assistance, and your patience, I am grateful.


"I'm a Witcher, I solve human problems; not always using a sword!"
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: FUDforum Failed decompressing the archive
Next Topic: Trad error message at upgrade
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Jun 24 09:17:47 EDT 2018

Total time taken to generate the page: 0.00676 seconds