FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » How To » Banner Ad On Every Page
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Banner Ad On Every Page [message #159913] Thu, 09 July 2009 07:28 Go to next message
ANiko is currently offline  ANiko   United States
Messages: 30
Registered: May 2009
Karma: 0
Member
add to buddy list
ignore all messages by this user
Fresh install of FUDforum 2.8.1.

I'm trying to add a banner ad at the top of every page in the forum, but I'm getting nowhere. I used the theme manager to create a new template based on path_info. I used the template editor to edit this new template. In the long list of template files, I picked header.tmpl ยป header -> forum page header. (Maybe that's my mistake. I'm picking the wrong template for the header of every forum page.)

Adding the iframe code in the HTML body before the first table doesn't work, creating a new first row in either of the tables and putting the iframe code in there doesn't work, either. Yes, I rebuilt all themes after saving the change. When I go back to the forum, there is no ad displayed.

Can someone please help me place the iframe code in the right place in the right template file and tell me whatever else I'm doing wrong?

Here is the basic iframe code I've tried inside either of the 2 tables:

<tr>
<td colspan="5" height="65" width="300" align="center" valign="middle">
<iframe src="http://linktoanotherdomain.com?id=myad" width="234" height="60" frameborder="no" scrolling="no"></iframe>
</td>
</tr>

Thanks for any help.
icon6.gif  Re: Banner Ad On Every Page [message #159914 is a reply to message #159913] Thu, 09 July 2009 09:23 Go to previous messageGo to next message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
You are in luck I have been working on something similar, using mouseover.

(you can check it out at the test forum)http://tunstavern.info/ Is that what you are looking for?

Just copy the code between the comments and substitute your own images and links.


"I'm a Witcher, I solve human problems; not always using a sword!"
Re: Banner Ad On Every Page [message #159915 is a reply to message #159914] Thu, 09 July 2009 09:51 Go to previous messageGo to next message
ANiko is currently offline  ANiko   United States
Messages: 30
Registered: May 2009
Karma: 0
Member
add to buddy list
ignore all messages by this user
The Witcher wrote on Thu, 09 July 2009 06:23
Just copy the code between the comments and substitute your own images and links.

Thanks. What's the name of the template file you edited to get that effect and on what line number of that file should I paste it? I've been editing header.tmpl and the change doesn't show up anywhere on any page.
icon6.gif  Re: Banner Ad On Every Page [message #159916 is a reply to message #159915] Thu, 09 July 2009 09:57 Go to previous messageGo to next message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
I just inserted the code into the header through the template editor for that but it depends on exactly what you want to do!
But I will get a line number for you

Do you want it a permanent part of a theme, or do you want it to gone on some themes?





"I'm a Witcher, I solve human problems; not always using a sword!"
Re: Banner Ad On Every Page [message #159917 is a reply to message #159916] Thu, 09 July 2009 10:10 Go to previous messageGo to next message
ANiko is currently offline  ANiko   United States
Messages: 30
Registered: May 2009
Karma: 0
Member
add to buddy list
ignore all messages by this user
The Witcher wrote on Thu, 09 July 2009 06:57
I just inserted the code into the header through the template editor for that

I'm with you there! That's what I've been doing and when I save changes, rebuild all themes and go back to the forum, it hasn't changed one bit. The link is valid so I should see a banner ad, but I don't.

The Witcher wrote on Thu, 09 July 2009 06:57
Do you want it a permanent part of a theme, or do you want it to gone on some themes?


Just the current custom theme and custom template.

Something I find strange with 2.8.1 on a fresh install is there's no way to copy files from the default and path_info themes into my new theme's directory because of the symlinks and almost every file being located inside the locked directory I can't open with an FTP program. I didn't have this problem with the last version. Copy/paste/edit. Simple.
icon6.gif  Re: Banner Ad On Every Page [message #159920 is a reply to message #159917] Thu, 09 July 2009 10:56 Go to previous messageGo to next message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
On that particular attempt I placed the code on line 4 of FUDforums Default header.

But in essence it just has to be after the head tag, you can do the same thing for other themes, and if you search on line there are some java scripts for rotating banners available.

Alternately I believe you can just insert this code into the head for a static banner.

<div align="center"><img src="url_of_your_image"></div>

As for it disappearing on you! When you rebuild themes It does so quite literally, rebuilding them from the templates.

I'm having trouble with that as well and its kind of touchy. If I understand it right you need to make your changes to your "template set" BEFORE! You create the new theme!

Otherwise all your changes will be gone! If you made the changes to the theme itself.

In the page you looked at that was a new installation, I am experimenting with, (got collapsible threads).

And so far it is stable even after several rebuilds.

I will be back to-nite. In the meantime check out the "Templating system explained".






"I'm a Witcher, I solve human problems; not always using a sword!"
Re: Banner Ad On Every Page [message #159921 is a reply to message #159920] Thu, 09 July 2009 11:46 Go to previous messageGo to next message
ANiko is currently offline  ANiko   United States
Messages: 30
Registered: May 2009
Karma: 0
Member
add to buddy list
ignore all messages by this user
The Witcher wrote on Thu, 09 July 2009 07:56
On that particular attempt I placed the code on line 4 of FUDforums Default header.

But in essence it just has to be after the head tag, you can do the same thing for other themes, and if you search on line there are some java scripts for rotating banners available.

Alternately I believe you can just insert this code into the head for a static banner.

<div align="center"><img src="url_of_your_image"></div>


Now this is wierd. No matter where I put the code in the template, the banner is invisible while I'm logged in as admin. As soon as I log out or if I log in as any other user, I can see the banner on every page.

Thanks for your help. I hadn't thought to log out and try another user to check whether they can see the banner until later. I guess I don't understand why admin isn't allowed to see what every other registered user and guest can see on the pages.

The Witcher wrote on Thu, 09 July 2009 07:56
In the meantime check out the "Templating system explained".

Thanks for the advice. I'll reread it.
Re: Banner Ad On Every Page [message #159922 is a reply to message #159921] Thu, 09 July 2009 11:59 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
Quote:
I guess I don't understand why admin isn't allowed to see what every other registered user and guest can see on the pages.


Try to clear your browser cache and force reload the page.

PS: We need to document this procedure on the wiki. It would be great if you guys can help...
icon6.gif  Re: Banner Ad On Every Page [message #159924 is a reply to message #159922] Thu, 09 July 2009 15:44 Go to previous messageGo to next message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
naudefj wrote on Thu, 09 July 2009 10:59

PS: We need to document this procedure on the wiki. It would be great if you guys can help...


I am keeping notes for just that reason, but I am reluctant to put it on the wicki until I am sure about something. And I am still working on it, things like how the heck did i manage to get expand and contract buttons within the thread itself etc.



"I'm a Witcher, I solve human problems; not always using a sword!"

[Updated on: Thu, 22 October 2009 01:47]

Report message to a moderator

Re: Banner Ad On Every Page [message #159925 is a reply to message #159922] Thu, 09 July 2009 16:06 Go to previous messageGo to next message
ANiko is currently offline  ANiko   United States
Messages: 30
Registered: May 2009
Karma: 0
Member
add to buddy list
ignore all messages by this user
naudefj wrote on Thu, 09 July 2009 08:59

Try to clear your browser cache and force reload the page.

Yep, that would have fixed it. Thanks for all the help guys.

UPDATE: No, it doesn't fix it. The admin user is special in this regard and some setting changes don't affect the admin user, even after logging out, closing the browser, clearing the cache, and logging back in. The admin user never sees the banner ad. No great loss though. Wink
icon6.gif  Re: Banner Ad On Every Page [message #159926 is a reply to message #159925] Thu, 09 July 2009 16:23 Go to previous message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
No problem, let me know if you have any flicker, momentary white on the page, unexpected disconnects any thing out of the ordinary.

I am trying to figure out what is the best way to do this with the new version of FUD, since I use as many as 6 such links in my forums.



"I'm a Witcher, I solve human problems; not always using a sword!"
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Add another group colour to bottom of main page?
Next Topic: Define an unexpected error?
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Oct 17 04:04:57 EDT 2017

Total time taken to generate the page: 0.00833 seconds