FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Problems sending NNTP messages.
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Problems sending NNTP messages. [message #161301] Fri, 04 December 2009 14:14 Go to next message
LADave is currently offline  LADave   United States
Messages: 19
Registered: July 2009
Location: Los Angeles
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
This is on FUDForum 3.0.0 RC2 (I know, I need to upgrade...)

Hi all, I'm looking for some ideas on how to track down this specific problem I'm having. I have a NNTP account at http://astraweb.com/ which has been working flawlessly for getting NNTP messages from rec.sport.disc and syncing them to the forum.

The problem I'm having is when trying to send messages back out through the NNTP server. Sometimes the messages send without a hitch and sometimes they don't send at all. I'm not getting any errors in any of my error logs (not sure which one it would show up in) and I can't seem to track down a specific case where it will always fail so I'm having trouble figuring out what the problem may be. If anyone out there has any ideas on what to try to track this down I'm open for suggestions.

A couple questions I have:
If the message does encounter an error when sending, does FUDForum retry or just fail? If it just fails, is this logged anywhere?

The one idea I had that might solve this but is probably overkill would be to have posts that need to be sent via NNTP in a message queue that is emptied via a cron job. This way if there was a failure the cron job would try again next time it was run.

Hoping theres someone out there that has encountered similar issues.
Re: Problems sending NNTP messages. [message #161302 is a reply to message #161301] Sat, 05 December 2009 02:46 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
NNTP errors are logged to errors/.nntp. You may need to edit the script to log additional info.
Re: Problems sending NNTP messages. [message #161303 is a reply to message #161302] Sat, 05 December 2009 18:08 Go to previous messageGo to next message
LADave is currently offline  LADave   United States
Messages: 19
Registered: July 2009
Location: Los Angeles
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
naudefj wrote on Sat, 05 December 2009 02:46
NNTP errors are logged to errors/.nntp. You may need to edit the script to log additional info.


Updated the NNTP logging to report the date and time for the errors so that I can try to track down the problem. Looks like there were some timeout on connecting as well as some unknown errors related to improper return codes on connection. Hopefully these changes will help me track things down, I'll let everyone know what I find.
Re: Problems sending NNTP messages. [message #161304 is a reply to message #161303] Sun, 06 December 2009 00:13 Go to previous message
naudefj is currently offline  naudefj   South Africa
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Sounds like you're making good progress. If any of your changes will be useful to others as well, please post them here so we can commit them to the SVN repository.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: cannot upgrade from RC1 to release
Next Topic: Accidental moderator
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Dec 17 07:06:24 EST 2017

Total time taken to generate the page: 0.00652 seconds