FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » General » PHP discussions » broken pipe-client stopped connection before rwrite completed (Got the broken pipe error while downloading a file from production server)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
broken pipe-client stopped connection before rwrite completed [message #161557] Fri, 08 January 2010 01:56 Go to next message
preeti   United States
Messages: 2
Registered: January 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
it is production server and the apache version is 1.3.41.
Am getting Internet server reset error while downloading *.xls file from the prooduction webserver.Below is the error what i see in the unix backend from log file.

[Thu Jan 7 07:21:55 2010] [info] [client XX.XX.XXX.X] (32)Broken pipe: client stopped connection before rwrite
completed
[Thu Jan 7 07:21:55 2010] [debug] Apache.c(364): (32)Broken pipe: mod_perl: rwrite returned -1 (fd=7, B_EOUT=8
)\n


This is happening only for 'https' and no error is thrown for 'http'.

Please give suggestion as this is a kind of urgent.
Re: broken pipe-client stopped connection before rwrite completed [message #161561 is a reply to message #161557] Fri, 08 January 2010 09:10 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Did yo get this problem while installing FUDforum?

PS: FUDforum is written in PHP, so I cannot see how it can give you a perl error.
Re: broken pipe-client stopped connection before rwrite completed [message #161577 is a reply to message #161561] Mon, 11 January 2010 01:19 Go to previous messageGo to next message
preeti   United States
Messages: 2
Registered: January 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
No this not related to forum installation.
The error I mentioned is related production apache web sever (perl code)when am try to download a file using HTTPS.the connection.Tell me the correct path where I have to post such queries if I have posted in this forum wrongly..
Re: broken pipe-client stopped connection before rwrite completed [message #161580 is a reply to message #161577] Mon, 11 January 2010 11:07 Go to previous message
naudefj is currently offline  naudefj   South Africa
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
This may not be the right place to ask (we mainly discuss FUDforum related issues here). Forums like http://apacheforum.net/ or http://cpanforum.com/dist/mod_perl might be more appropriate.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Failed loading /usr/lib/php/modules//php_ioncube_loader_lin_5.1.so
Next Topic: Errors
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Thu Dec 14 17:29:36 EST 2017

Total time taken to generate the page: 0.00740 seconds