FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Messages are garbled after mporting from backup
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Messages are garbled after mporting from backup [message #162161] Sat, 27 March 2010 14:38
TonyMarston is currently offline  TonyMarston   United Kingdom
Messages: 28
Registered: April 2006
Location: Surrey, UK
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I have, after great difficuty, upgraded my forum from version 2.7.7 to 3.0.0. I can see all the forums, I can see all the messages in each forum, but the body of each message is garbled. It looks as if some text has been chopped off the front and some other text has been added on the end.

I managed to take a backup which I downloaded and imported into a copy of FUDforum which I had installed on my Windows PC. All the message bodies were still garbled, so I looked at the text files in the 'messages' directory. Each file contains the bodies of numerous messages, but there is nothing in the file to indicate where one message ends and another message starts.

I took a look at the fud30_msg table and saw the column names file_id, foff and length. I presume these identify the name of the message file, the character offset with the file, and the character length of the message.

I looked at each of these files with my text editor (EditPad Lite) and I noticed that each one had the line endings set to UNIX style (LF only). I changed them all to Windows style (CR LF) and all the messages became ungarbled. I then FTP'd all these message files onto my remote server hoping that this would cure the problem, but when I checked the messages they were sill garbled.

I'm now in the position where I have a working version of my forum on my PC, but the one on my server is garbage.

Does anyone know how I can fix this problem? How can I get the file contents to match what the database expects so that each message can be extracted and displayed properly?


Tony Marston
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Unable to import into FUDForum2Go appliance
Next Topic: Some small issues
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Oct 21 19:18:55 EDT 2017

Total time taken to generate the page: 0.00595 seconds